summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-02-01 16:18:40 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-02-01 16:18:40 +0000
commit76a9a8acfbdd8ed95fae636b9ed9e32da228cbd7 (patch)
tree675e46e744d2bab44a80a5bc60e6e6d7299df81a /app-misc/g15daemon
parentStable on alpha, bug #257148 (diff)
downloadgentoo-2-76a9a8acfbdd8ed95fae636b9ed9e32da228cbd7.tar.gz
gentoo-2-76a9a8acfbdd8ed95fae636b9ed9e32da228cbd7.tar.bz2
gentoo-2-76a9a8acfbdd8ed95fae636b9ed9e32da228cbd7.zip
Add a missing open() permission and install default configuration file
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/g15daemon')
-rw-r--r--app-misc/g15daemon/ChangeLog13
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch11
-rw-r--r--app-misc/g15daemon/files/g15daemon.conf27
-rw-r--r--app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild134
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild133
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.1.ebuild133
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.2.ebuild133
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild (renamed from app-misc/g15daemon/g15daemon-1.9.3.ebuild)20
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3.ebuild133
9 files changed, 63 insertions, 674 deletions
diff --git a/app-misc/g15daemon/ChangeLog b/app-misc/g15daemon/ChangeLog
index 9d00a2266acc..54bd25f04990 100644
--- a/app-misc/g15daemon/ChangeLog
+++ b/app-misc/g15daemon/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-misc/g15daemon
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.22 2008/09/08 11:44:02 chainsaw Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.23 2009/02/01 16:18:40 jokey Exp $
+
+*g15daemon-1.9.5.3-r2 (01 Feb 2009)
+
+ 01 Feb 2009; <jokey@gentoo.org> +files/g15daemon.conf,
+ +files/g15daemon-1.9.5.3-forgotten-open-mode.patch,
+ -g15daemon-1.2.6a-r1.ebuild, -g15daemon-1.9.0-r1.ebuild,
+ -g15daemon-1.9.1.ebuild, -g15daemon-1.9.2.ebuild, -g15daemon-1.9.3.ebuild,
+ -g15daemon-1.9.5.3.ebuild, +g15daemon-1.9.5.3-r2.ebuild:
+ Add a missing open() permission and install default configuration file
*g15daemon-1.9.5.3-r1 (08 Sep 2008)
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch b/app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch
new file mode 100644
index 000000000000..b475f1d58d69
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch
@@ -0,0 +1,11 @@
+--- ./g15daemon-1.9.5.3/g15daemon/utility_funcs.c 2008-01-26 06:02:07.000000000 +0100
++++ ./g15daemon-1.9.5.3/g15daemon/utility_funcs.c 2009-02-01 17:00:55.203009264 +0100
+@@ -356,7 +356,7 @@
+ config_items_t * item=NULL;
+ char line[1024];
+
+- config_fd = open(filename,O_CREAT|O_RDWR|O_TRUNC);
++ config_fd = open(filename,O_CREAT|O_RDWR|O_TRUNC,0664);
+ if(config_fd){
+ snprintf(line,1024,"# G15Daemon Configuration File\n# any items entered before a [section] header\n# will be in the Global config space\n# comments you wish to keep should start with a semicolon';'\n");
+ write(config_fd,line,strlen(line));
diff --git a/app-misc/g15daemon/files/g15daemon.conf b/app-misc/g15daemon/files/g15daemon.conf
new file mode 100644
index 000000000000..2d2bfc3cabde
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon.conf
@@ -0,0 +1,27 @@
+# G15Daemon Configuration File
+# any items entered before a [section] header
+# will be in the Global config space
+# comments you wish to keep should start with a semicolon';'
+
+[Global]
+Use MR as Cycle Key: Off
+
+[PLUGIN_LOAD_ORDER]
+0: g15plugin_uinput.so
+1: g15plugin_clock.so
+2: g15plugin_tcpserver.so
+TotalPlugins: 3
+
+[PLUGINS]
+Linux UINPUT Keyboard Output: Load
+Clock: Load
+LCDServer: Load
+
+[Keyboard OS Mapping (uinput)]
+device: /dev/input/uinput
+Lkeys.mapped: 0
+
+[Clock]
+24hrFormat: On
+ShowDate: Off
+Digital: On
diff --git a/app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild b/app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild
deleted file mode 100644
index e169ef810b86..000000000000
--- a/app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild,v 1.6 2008/05/29 15:41:32 hawking Exp $
-
-inherit eutils linux-info perl-module python multilib
-
-DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
-HOMEPAGE="http://g15daemon.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 x86"
-IUSE="perl python"
-
-DEPEND="dev-libs/libusb
- dev-libs/libdaemon
- >=dev-libs/libg15-1.1.0
- perl? ( >=dev-perl/Inline-0.4 )
- python? ( dev-lang/python )"
-
-RDEPEND="${DEPEND}
- perl? ( dev-perl/GDGraph )"
-
-uinput_check() {
- ebegin "Checking for uinput support"
- linux_chkconfig_present INPUT_UINPUT
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- eerror "To use g15daemon, you need to compile your kernel with uinput support."
- eerror "Please enable uinput support in your kernel config, found at:"
- eerror
- eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
- eerror
- eerror "Once enabled, you should have the /dev/input/uinput device."
- eerror "g15daemon will not work without the uinput device."
- die "INPUT_UINPUT support not detected!"
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- uinput_check
-}
-
-src_unpack() {
- unpack ${A}
- if use perl; then
- unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
- fi
- if use python; then
- unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
- fi
-}
-
-src_compile() {
- econf || die "configure failed"
-
- emake || die "make failed"
-
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
- perl-module_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} install || die "make install failed"
-
- # remove odd docs installed my make
- rm "${D}/usr/share/doc/${PF}/"{LICENSE,README.usage}
-
- insinto /usr/share/${PN}/contrib
- doins contrib/xmodmaprc
- doins contrib/xmodmap.sh
- if use perl; then
- doins contrib/testbindings.pl
- fi
-
- newconfd "${FILESDIR}/${P}.confd" ${PN}
- newinitd "${FILESDIR}/${P}.initd" ${PN}
-
- if use perl; then
- ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
- docinto perl
- perl-module_src_install
- fi
-
- if use python; then
- ebegin "Installing Python Bindings (g15daemon.py)"
- cd "${WORKDIR}/pyg15daemon"
- python_version
-
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- doins g15daemon.py
- docinto python
- dodoc AUTHORS
- fi
-
- prepalldocs
-}
-
-pkg_postinst() {
- if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- echo ""
- fi
-
- elog "To use g15daemon, you need to add g15daemon to the default runlevel."
- elog "This can be done with:"
- elog "# /sbin/rc-update add g15daemon default"
- elog ""
- elog "To have all new keys working in X11, you'll need create a "
- elog "specific xmodmap in your home directory or edit the existent one."
- elog ""
- elog "Create the xmodmap:"
- elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
- elog ""
- elog "Adding keycodes to an existing xmodmap:"
- elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
- elog ""
- elog "Note: the daemon now supports to use the small round key"
- elog "instead of MR for switching LCD clients. see /etc/conf.d/g15daemon"
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup "/usr/$(get_libdir)/python*/site-packages/g15daemon"
- fi
-}
diff --git a/app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild b/app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild
deleted file mode 100644
index cdeccc9ce255..000000000000
--- a/app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.0-r1.ebuild,v 1.2 2008/05/29 15:41:32 hawking Exp $
-
-inherit eutils linux-info perl-module python multilib
-
-DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
-HOMEPAGE="http://g15daemon.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="perl python"
-
-DEPEND="dev-libs/libusb
- >=dev-libs/libg15-1.2.0
- >=dev-libs/libg15render-1.2
- perl? ( >=dev-perl/Inline-0.4 )
- python? ( dev-lang/python )"
-
-RDEPEND="${DEPEND}
- perl? ( dev-perl/GDGraph )"
-
-uinput_check() {
- ebegin "Checking for uinput support"
- linux_chkconfig_present INPUT_UINPUT
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- eerror "To use g15daemon, you need to compile your kernel with uinput support."
- eerror "Please enable uinput support in your kernel config, found at:"
- eerror
- eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
- eerror
- eerror "Once enabled, you should have the /dev/input/uinput device."
- eerror "g15daemon will not work without the uinput device."
- die "INPUT_UINPUT support not detected!"
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- uinput_check
-}
-
-src_unpack() {
- unpack ${A}
- if use perl; then
- unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
- fi
- if use python; then
- unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
- fi
-}
-
-src_compile() {
- econf || die "configure failed"
-
- emake || die "make failed"
-
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
- perl-module_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} install || die "make install failed"
-
- # remove odd docs installed my make
- rm "${D}/usr/share/doc/${PF}/"{LICENSE,README.usage}
-
- insinto /usr/share/${PN}/contrib
- doins contrib/xmodmaprc
- doins contrib/xmodmap.sh
- if use perl; then
- doins contrib/testbindings.pl
- fi
-
- newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
- newinitd "${FILESDIR}/${PN}-1.2.7-r1.initd" ${PN}
-
- if use perl; then
- ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
- docinto perl
- perl-module_src_install
- fi
-
- if use python; then
- ebegin "Installing Python Bindings (g15daemon.py)"
- cd "${WORKDIR}/pyg15daemon"
- python_version
-
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- doins g15daemon.py
-
- docinto python
- dodoc AUTHORS
- fi
-
- prepalldocs
-}
-
-pkg_postinst() {
- if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- echo ""
- fi
-
- elog "To use g15daemon, you need to add g15daemon to the default runlevel."
- elog "This can be done with:"
- elog "# /sbin/rc-update add g15daemon default"
- elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
- elog ""
- elog "To have all new keys working in X11, you'll need create a "
- elog "specific xmodmap in your home directory or edit the existent one."
- elog ""
- elog "Create the xmodmap:"
- elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
- elog ""
- elog "Adding keycodes to an existing xmodmap:"
- elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup "/usr/$(get_libdir)/python*/site-packages/g15daemon"
- fi
-}
diff --git a/app-misc/g15daemon/g15daemon-1.9.1.ebuild b/app-misc/g15daemon/g15daemon-1.9.1.ebuild
deleted file mode 100644
index 26c56b908ab9..000000000000
--- a/app-misc/g15daemon/g15daemon-1.9.1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.1.ebuild,v 1.2 2008/05/29 15:41:32 hawking Exp $
-
-inherit eutils linux-info perl-module python multilib
-
-DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
-HOMEPAGE="http://g15daemon.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="perl python"
-
-DEPEND="dev-libs/libusb
- >=dev-libs/libg15-1.2.4
- >=dev-libs/libg15render-1.2
- perl? ( >=dev-perl/Inline-0.4 )
- python? ( dev-lang/python )"
-
-RDEPEND="${DEPEND}
- perl? ( dev-perl/GDGraph )"
-
-uinput_check() {
- ebegin "Checking for uinput support"
- linux_chkconfig_present INPUT_UINPUT
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- eerror "To use g15daemon, you need to compile your kernel with uinput support."
- eerror "Please enable uinput support in your kernel config, found at:"
- eerror
- eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
- eerror
- eerror "Once enabled, you should have the /dev/input/uinput device."
- eerror "g15daemon will not work without the uinput device."
- die "INPUT_UINPUT support not detected!"
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- uinput_check
-}
-
-src_unpack() {
- unpack ${A}
- if use perl; then
- unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
- fi
- if use python; then
- unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
- fi
-}
-
-src_compile() {
- econf || die "configure failed"
-
- emake || die "make failed"
-
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
- perl-module_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} install || die "make install failed"
-
- # remove odd docs installed my make
- rm "${D}/usr/share/doc/${PF}/"{LICENSE,README.usage}
-
- insinto /usr/share/${PN}/contrib
- doins contrib/xmodmaprc
- doins contrib/xmodmap.sh
- if use perl; then
- doins contrib/testbindings.pl
- fi
-
- newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
- newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
-
- if use perl; then
- ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
- docinto perl
- perl-module_src_install
- fi
-
- if use python; then
- ebegin "Installing Python Bindings (g15daemon.py)"
- cd "${WORKDIR}/pyg15daemon"
- python_version
-
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- doins g15daemon.py
-
- docinto python
- dodoc AUTHORS
- fi
-
- prepalldocs
-}
-
-pkg_postinst() {
- if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- echo ""
- fi
-
- elog "To use g15daemon, you need to add g15daemon to the default runlevel."
- elog "This can be done with:"
- elog "# /sbin/rc-update add g15daemon default"
- elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
- elog ""
- elog "To have all new keys working in X11, you'll need create a "
- elog "specific xmodmap in your home directory or edit the existent one."
- elog ""
- elog "Create the xmodmap:"
- elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
- elog ""
- elog "Adding keycodes to an existing xmodmap:"
- elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup "/usr/$(get_libdir)/python*/site-packages/g15daemon"
- fi
-}
diff --git a/app-misc/g15daemon/g15daemon-1.9.2.ebuild b/app-misc/g15daemon/g15daemon-1.9.2.ebuild
deleted file mode 100644
index 93ba437c727a..000000000000
--- a/app-misc/g15daemon/g15daemon-1.9.2.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.2.ebuild,v 1.2 2008/05/29 15:41:32 hawking Exp $
-
-inherit eutils linux-info perl-module python multilib
-
-DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
-HOMEPAGE="http://g15daemon.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="perl python"
-
-DEPEND="dev-libs/libusb
- >=dev-libs/libg15-1.2.4
- >=dev-libs/libg15render-1.2
- perl? ( >=dev-perl/Inline-0.4 )
- python? ( dev-lang/python )"
-
-RDEPEND="${DEPEND}
- perl? ( dev-perl/GDGraph )"
-
-uinput_check() {
- ebegin "Checking for uinput support"
- linux_chkconfig_present INPUT_UINPUT
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- eerror "To use g15daemon, you need to compile your kernel with uinput support."
- eerror "Please enable uinput support in your kernel config, found at:"
- eerror
- eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
- eerror
- eerror "Once enabled, you should have the /dev/input/uinput device."
- eerror "g15daemon will not work without the uinput device."
- die "INPUT_UINPUT support not detected!"
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- uinput_check
-}
-
-src_unpack() {
- unpack ${A}
- if use perl; then
- unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
- fi
- if use python; then
- unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
- fi
-}
-
-src_compile() {
- econf || die "configure failed"
-
- emake || die "make failed"
-
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
- perl-module_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} install || die "make install failed"
-
- # remove odd docs installed my make
- rm "${D}/usr/share/doc/${PF}/"{LICENSE,README.usage}
-
- insinto /usr/share/${PN}/contrib
- doins contrib/xmodmaprc
- doins contrib/xmodmap.sh
- if use perl; then
- doins contrib/testbindings.pl
- fi
-
- newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
- newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
-
- if use perl; then
- ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
- docinto perl
- perl-module_src_install
- fi
-
- if use python; then
- ebegin "Installing Python Bindings (g15daemon.py)"
- cd "${WORKDIR}/pyg15daemon"
- python_version
-
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- doins g15daemon.py
-
- docinto python
- dodoc AUTHORS
- fi
-
- prepalldocs
-}
-
-pkg_postinst() {
- if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- echo ""
- fi
-
- elog "To use g15daemon, you need to add g15daemon to the default runlevel."
- elog "This can be done with:"
- elog "# /sbin/rc-update add g15daemon default"
- elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
- elog ""
- elog "To have all new keys working in X11, you'll need create a "
- elog "specific xmodmap in your home directory or edit the existent one."
- elog ""
- elog "Create the xmodmap:"
- elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
- elog ""
- elog "Adding keycodes to an existing xmodmap:"
- elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup "/usr/$(get_libdir)/python*/site-packages/g15daemon"
- fi
-}
diff --git a/app-misc/g15daemon/g15daemon-1.9.3.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild
index 2a51cc3887b6..03d3892b9d90 100644
--- a/app-misc/g15daemon/g15daemon-1.9.3.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.3.ebuild,v 1.2 2008/05/29 15:41:32 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r2.ebuild,v 1.1 2009/02/01 16:18:40 jokey Exp $
+
+EAPI=2
inherit eutils linux-info perl-module python multilib
@@ -54,9 +56,11 @@ src_unpack() {
fi
}
-src_compile() {
- econf || die "configure failed"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-forgotten-open-mode.patch
+}
+src_compile() {
emake || die "make failed"
if use perl; then
@@ -81,6 +85,12 @@ src_install() {
newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
+ dobin "${FILESDIR}/g15daemon-hotplug"
+ insinto /etc/udev/rules.d
+ doins "${FILESDIR}/99-g15daemon.rules"
+
+ insinto /etc
+ doins "${FILESDIR}"/g15daemon.conf
if use perl; then
ebegin "Installing Perl Bindings (G15Daemon.pm)"
@@ -100,8 +110,6 @@ src_install() {
docinto python
dodoc AUTHORS
fi
-
- prepalldocs
}
pkg_postinst() {
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3.ebuild
deleted file mode 100644
index a17acced5637..000000000000
--- a/app-misc/g15daemon/g15daemon-1.9.5.3.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3.ebuild,v 1.2 2008/05/29 15:41:32 hawking Exp $
-
-inherit eutils linux-info perl-module python multilib
-
-DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
-HOMEPAGE="http://g15daemon.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="perl python"
-
-DEPEND="dev-libs/libusb
- >=dev-libs/libg15-1.2.4
- >=dev-libs/libg15render-1.2
- perl? ( >=dev-perl/Inline-0.4 )
- python? ( dev-lang/python )"
-
-RDEPEND="${DEPEND}
- perl? ( dev-perl/GDGraph )"
-
-uinput_check() {
- ebegin "Checking for uinput support"
- linux_chkconfig_present INPUT_UINPUT
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- eerror "To use g15daemon, you need to compile your kernel with uinput support."
- eerror "Please enable uinput support in your kernel config, found at:"
- eerror
- eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
- eerror
- eerror "Once enabled, you should have the /dev/input/uinput device."
- eerror "g15daemon will not work without the uinput device."
- die "INPUT_UINPUT support not detected!"
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- uinput_check
-}
-
-src_unpack() {
- unpack ${A}
- if use perl; then
- unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
- fi
- if use python; then
- unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
- fi
-}
-
-src_compile() {
- econf || die "configure failed"
-
- emake || die "make failed"
-
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
- perl-module_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} install || die "make install failed"
-
- # remove odd docs installed my make
- rm "${D}/usr/share/doc/${PF}/"{LICENSE,README.usage}
-
- insinto /usr/share/${PN}/contrib
- doins contrib/xmodmaprc
- doins contrib/xmodmap.sh
- if use perl; then
- doins contrib/testbindings.pl
- fi
-
- newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
- newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
-
- if use perl; then
- ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
- docinto perl
- perl-module_src_install
- fi
-
- if use python; then
- ebegin "Installing Python Bindings (g15daemon.py)"
- cd "${WORKDIR}/pyg15daemon"
- python_version
-
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- doins g15daemon.py
-
- docinto python
- dodoc AUTHORS
- fi
-
- prepalldocs
-}
-
-pkg_postinst() {
- if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
- echo ""
- fi
-
- elog "To use g15daemon, you need to add g15daemon to the default runlevel."
- elog "This can be done with:"
- elog "# /sbin/rc-update add g15daemon default"
- elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
- elog ""
- elog "To have all new keys working in X11, you'll need create a "
- elog "specific xmodmap in your home directory or edit the existent one."
- elog ""
- elog "Create the xmodmap:"
- elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
- elog ""
- elog "Adding keycodes to an existing xmodmap:"
- elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup "/usr/$(get_libdir)/python*/site-packages/g15daemon"
- fi
-}