summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2005-01-08 13:57:42 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2005-01-08 13:57:42 +0000
commit65fa6e408e32e09fee3b077f5d4278deec79c394 (patch)
treef9f815236f093c54af89dce3fe98c9863025914a /app-misc/fujiplay
parentAdded support for on-the-fly encryption for cdrecord. See bug #71245. (Manif... (diff)
downloadgentoo-2-65fa6e408e32e09fee3b077f5d4278deec79c394.tar.gz
gentoo-2-65fa6e408e32e09fee3b077f5d4278deec79c394.tar.bz2
gentoo-2-65fa6e408e32e09fee3b077f5d4278deec79c394.zip
Fixed compile error in fujiplay
Diffstat (limited to 'app-misc/fujiplay')
-rw-r--r--app-misc/fujiplay/ChangeLog6
-rw-r--r--app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch75
-rw-r--r--app-misc/fujiplay/fujiplay-1.33.ebuild10
-rw-r--r--app-misc/fujiplay/metadata.xml9
4 files changed, 98 insertions, 2 deletions
diff --git a/app-misc/fujiplay/ChangeLog b/app-misc/fujiplay/ChangeLog
index 1fb6bafe5942..7290f9b14a46 100644
--- a/app-misc/fujiplay/ChangeLog
+++ b/app-misc/fujiplay/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/fujiplay
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/fujiplay/ChangeLog,v 1.7 2005/01/01 15:02:52 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fujiplay/ChangeLog,v 1.8 2005/01/08 13:57:42 griffon26 Exp $
+
+ 08 Jan 2005; Maurice van der Pot <griffon26@gentoo.org> +metadata.xml,
+ +files/fujiplay-1.33-unterminated-strings.patch, fujiplay-1.33.ebuild:
+ Fix unterminated strings, closing bug #34931.
07 Dec 2003; Martin Holzer <mholzer@gentoo.org> fujiplay-1.33.ebuild:
digest update. Closes #34931.
diff --git a/app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch b/app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch
new file mode 100644
index 000000000000..5fb87be1474c
--- /dev/null
+++ b/app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch
@@ -0,0 +1,75 @@
+--- fujiplay.c 1999-02-23 10:30:31.000000000 +0100
++++ fujiplay-fixed.c 2005-01-08 14:37:08.711951696 +0100
+@@ -759,40 +759,38 @@
+ return 1;
+ }
+
+-const char *Usage = "\
+-Usage: fujiplay [OPTIONS] PICTURES... (download)
+- charge NUMBER (recharge the flash)
+- shoot (take picture)
+- preview (preview to standard output)
+- upload FILES...
+- delete FILES...
+- setid STRING (set camera ID)
+- setflash MODE (0=Off, 1=On, 2=Strobe, 3=Auto)
+- setdate gmt|local|YYYYMMDDHHMMSS
+-Options:
+- -B NUMBER Set baudrate (115200, 57600, 38400, 19200, 9600 or 0)
+- -D DEVICE Select another device file (default is /dev/fujifilm)
+- -L List command set
+- -7 DS-7 compatibility mode (experimental)
+- -d Delete pictures after successful download
+- -f Force (overwrite existing files)
+- -p Assume picture numbers instead of frame numbers
+- -h Display this help message
+- -v Version information
+-Pictures:
+- all All pictures
+- last Last picture
+- 4 Only picture 4
+- 2-10 Pictures between 2 and 10
+-Files:
+- DSCxxxxx.JPG Files to delete or to upload into the camera
+-";
+-
+-const char *Copyright = "\
+-Fujiplay, $Id: fujiplay.c,v 1.33 1999/02/22 14:13:01 bousch Exp $
+-Written by Thierry Bousch <bousch@topo.math.u-psud.fr>
+-Public domain. Absolutely no warranty.
+-";
++const char *Usage =
++"Usage: fujiplay [OPTIONS] PICTURES... (download)\n"
++" charge NUMBER (recharge the flash)\n"
++" shoot (take picture)\n"
++" preview (preview to standard output)\n"
++" upload FILES...\n"
++" delete FILES...\n"
++" setid STRING (set camera ID)\n"
++" setflash MODE (0=Off, 1=On, 2=Strobe, 3=Auto)\n"
++" setdate gmt|local|YYYYMMDDHHMMSS\n"
++"Options:\n"
++" -B NUMBER Set baudrate (115200, 57600, 38400, 19200, 9600 or 0)\n"
++" -D DEVICE Select another device file (default is /dev/fujifilm)\n"
++" -L List command set\n"
++" -7 DS-7 compatibility mode (experimental)\n"
++" -d Delete pictures after successful download\n"
++" -f Force (overwrite existing files)\n"
++" -p Assume picture numbers instead of frame numbers\n"
++" -h Display this help message\n"
++" -v Version information\n"
++"Pictures:\n"
++" all All pictures\n"
++" last Last picture\n"
++" 4 Only picture 4\n"
++" 2-10 Pictures between 2 and 10\n"
++"Files:\n"
++" DSCxxxxx.JPG Files to delete or to upload into the camera\n";
++
++const char *Copyright =
++"Fujiplay, $Id: fujiplay.c,v 1.33 1999/02/22 14:13:01 bousch Exp $\n"
++"Written by Thierry Bousch <bousch@topo.math.u-psud.fr>\n"
++"Public domain. Absolutely no warranty.\n";
+
+ static void sigint_handler (int sig)
+ {
diff --git a/app-misc/fujiplay/fujiplay-1.33.ebuild b/app-misc/fujiplay/fujiplay-1.33.ebuild
index 7e0925430fdc..44d97aeccd92 100644
--- a/app-misc/fujiplay/fujiplay-1.33.ebuild
+++ b/app-misc/fujiplay/fujiplay-1.33.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/fujiplay/fujiplay-1.33.ebuild,v 1.10 2005/01/01 15:02:52 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fujiplay/fujiplay-1.33.ebuild,v 1.11 2005/01/08 13:57:42 griffon26 Exp $
+
+inherit eutils
DESCRIPTION="Utility for Fujifilm/Leica digital cameras (via serial port)"
HOMEPAGE="http://topo.math.u-psud.fr/~bousch/fujiplay.html"
@@ -16,6 +18,12 @@ RDEPEND=""
S=${WORKDIR}
+src_unpack() {
+ unpack ${PN}.tgz
+ cd ${S}
+ epatch ${FILESDIR}/${P}-unterminated-strings.patch
+}
+
src_compile() {
emake || die
}
diff --git a/app-misc/fujiplay/metadata.xml b/app-misc/fujiplay/metadata.xml
new file mode 100644
index 000000000000..18ef3d4e808d
--- /dev/null
+++ b/app-misc/fujiplay/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bug-wranglers@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+</maintainer>
+</pkgmetadata>