summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-20 05:11:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-20 05:11:55 +0000
commitabc237ada0e2e03caf873db00bd4c65a979f5357 (patch)
tree5f8db40b0f7773ec070a30a16ab64077e79f8f22 /app-misc/figlet
parentMarked ~hppa (bug #341149). (diff)
downloadgentoo-2-abc237ada0e2e03caf873db00bd4c65a979f5357.tar.gz
gentoo-2-abc237ada0e2e03caf873db00bd4c65a979f5357.tar.bz2
gentoo-2-abc237ada0e2e03caf873db00bd4c65a979f5357.zip
remove non-maintainer rev bump; backport changes to stable ebuild to avoid pointless rebuild
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-misc/figlet')
-rw-r--r--app-misc/figlet/ChangeLog7
-rw-r--r--app-misc/figlet/figlet-222-r1.ebuild57
-rw-r--r--app-misc/figlet/figlet-222.ebuild24
3 files changed, 17 insertions, 71 deletions
diff --git a/app-misc/figlet/ChangeLog b/app-misc/figlet/ChangeLog
index 588a8326b74d..c9aa776c2d1b 100644
--- a/app-misc/figlet/ChangeLog
+++ b/app-misc/figlet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/figlet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/ChangeLog,v 1.37 2010/10/20 04:56:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/ChangeLog,v 1.38 2010/10/20 05:11:54 mr_bones_ Exp $
+
+ 20 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org> figlet-222.ebuild,
+ -figlet-222-r1.ebuild:
+ remove non-maintainer rev bump; backport changes to stable ebuild to avoid
+ pointless rebuild
*figlet-222-r1 (20 Oct 2010)
diff --git a/app-misc/figlet/figlet-222-r1.ebuild b/app-misc/figlet/figlet-222-r1.ebuild
deleted file mode 100644
index 5a3c5ae8718b..000000000000
--- a/app-misc/figlet/figlet-222-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-222-r1.ebuild,v 1.1 2010/10/20 04:56:27 jer Exp $
-
-EAPI="2"
-
-inherit eutils bash-completion toolchain-funcs
-
-MY_P=${P/-/}
-DESCRIPTION="program for making large letters out of ordinary text"
-HOMEPAGE="http://www.figlet.org/"
-# Bug 35339 - add more fonts to figlet ebuild
-# The fonts are available from the figlet site, but they don't
-# have versions so we mirror them ourselves.
-SRC_URI="ftp://ftp.figlet.org/pub/figlet/program/unix/${MY_P}.tar.gz
- mirror://gentoo/contributed-${PN}-221.tar.gz
- mirror://gentoo/ms-dos-${PN}-221.tar.gz"
-
-LICENSE="AFL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- cp "${WORKDIR}"/contributed/C64-fonts/*.flf fonts/ || die
- cp "${WORKDIR}"/contributed/bdffonts/*.flf fonts/ || die
- cp "${WORKDIR}"/ms-dos/*.flf fonts/ || die
- cp "${WORKDIR}"/contributed/*.flf fonts/ || die
-
- epatch \
- "${FILESDIR}"/${P}-gentoo.diff \
- "${FILESDIR}"/${P}-includes.diff
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} ${LDFLAGS}" \
- clean all \
- || die "emake failed"
-}
-
-src_install() {
- dodir /usr/bin /usr/share/man/man6 || die "dodir failed"
- chmod +x figlist showfigfonts
- use prefix || ED="${D}"
- emake \
- DESTDIR="${ED}"/usr/bin \
- MANDIR="${ED}"/usr/share/man/man6 \
- DEFAULTFONTDIR="${ED}"/usr/share/figlet \
- install || die "make install failed"
-
- dodoc README figfont.txt
- dobashcompletion "${FILESDIR}"/figlet.bashcomp
-}
diff --git a/app-misc/figlet/figlet-222.ebuild b/app-misc/figlet/figlet-222.ebuild
index ea4c2b319d7b..94594dd6e3fc 100644
--- a/app-misc/figlet/figlet-222.ebuild
+++ b/app-misc/figlet/figlet-222.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-222.ebuild,v 1.17 2010/10/19 06:07:45 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-222.ebuild,v 1.18 2010/10/20 05:11:54 mr_bones_ Exp $
+EAPI=2
inherit eutils bash-completion toolchain-funcs
MY_P=${P/-/}
@@ -19,28 +20,25 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-DEPEND=""
-
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
cp "${WORKDIR}"/contributed/C64-fonts/*.flf fonts/ || die
cp "${WORKDIR}"/contributed/bdffonts/*.flf fonts/ || die
cp "${WORKDIR}"/ms-dos/*.flf fonts/ || die
cp "${WORKDIR}"/contributed/*.flf fonts/ || die
- epatch "${FILESDIR}"/${P}-gentoo.diff
- sed -i \
- -e "s@CFLAGS = -g@CFLAGS = ${CFLAGS}@g" Makefile \
- || die "sed failed"
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-includes.diff
}
src_compile() {
- tc-export CC
- emake CC="${CC}" clean all || die "emake failed"
+ emake clean
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ all || die
}
src_install() {