summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-05-12 21:40:22 +0000
committerPeter Volkov <pva@gentoo.org>2008-05-12 21:40:22 +0000
commitc044111aa5a8f675f6f737820cf41faf67e58670 (patch)
tree0132786abb1553516ac2149b794a89617b5faae2 /app-misc/fdupes
parentStable for HPPA (bug #221063). (diff)
downloadgentoo-2-c044111aa5a8f675f6f737820cf41faf67e58670.tar.gz
gentoo-2-c044111aa5a8f675f6f737820cf41faf67e58670.tar.bz2
gentoo-2-c044111aa5a8f675f6f737820cf41faf67e58670.zip
Fix implicit declaration of memcpy, bug #184925, thank Daniel Santos for report/fix. Don't use generic gcc command, bug #197226, thank Chris Slycord for report/fix.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc/fdupes')
-rw-r--r--app-misc/fdupes/ChangeLog12
-rw-r--r--app-misc/fdupes/fdupes-1.40-r1.ebuild34
-rw-r--r--app-misc/fdupes/files/fdupes-1.40-memcpy.patch20
3 files changed, 64 insertions, 2 deletions
diff --git a/app-misc/fdupes/ChangeLog b/app-misc/fdupes/ChangeLog
index 88b0a8701af5..cbab4c8aea4b 100644
--- a/app-misc/fdupes/ChangeLog
+++ b/app-misc/fdupes/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/fdupes
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/fdupes/ChangeLog,v 1.11 2007/02/08 22:32:33 flameeyes Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fdupes/ChangeLog,v 1.12 2008/05/12 21:40:21 pva Exp $
+
+*fdupes-1.40-r1 (12 May 2008)
+
+ 12 May 2008; Peter Volkov <pva@gentoo.org>
+ +files/fdupes-1.40-memcpy.patch, +fdupes-1.40-r1.ebuild:
+ Fix implicit declaration of memcpy, bug #184925, thank Daniel Santos for
+ report/fix. Don't use generic gcc command, bug #197226, thank Chris
+ Slycord for report/fix.
08 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/app-misc/fdupes/fdupes-1.40-r1.ebuild b/app-misc/fdupes/fdupes-1.40-r1.ebuild
new file mode 100644
index 000000000000..ebd1e926bc8d
--- /dev/null
+++ b/app-misc/fdupes/fdupes-1.40-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fdupes/fdupes-1.40-r1.ebuild,v 1.1 2008/05/12 21:40:21 pva Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="identify/delete duplicate files residing within specified directories"
+HOMEPAGE="http://netdial.caribe.net/~adrian2/fdupes.html"
+SRC_URI="http://netdial.caribe.net/~adrian2/programs/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-memcpy.patch
+}
+
+src_compile() {
+ sed -i -e "s:gcc:$(tc-getCC):" Makefile
+ emake || die
+}
+
+src_install() {
+ dobin fdupes || die
+ doman fdupes.1
+ dodoc CHANGES CONTRIBUTORS INSTALL README TODO
+}
diff --git a/app-misc/fdupes/files/fdupes-1.40-memcpy.patch b/app-misc/fdupes/files/fdupes-1.40-memcpy.patch
new file mode 100644
index 000000000000..03ec0ce2ca8c
--- /dev/null
+++ b/app-misc/fdupes/files/fdupes-1.40-memcpy.patch
@@ -0,0 +1,20 @@
+=== modified file 'md5/md5.c'
+--- md5/md5.c 2008-05-12 21:06:07 +0000
++++ md5/md5.c 2008-05-12 21:06:23 +0000
+@@ -39,6 +39,7 @@
+ */
+
+ #include "md5.h"
++#include <string.h>
+
+ #ifdef TEST
+ /*
+@@ -46,7 +47,6 @@
+ * The test program should print out the same values as given in section
+ * A.5 of RFC 1321, reproduced below.
+ */
+-#include <string.h>
+ main()
+ {
+ static const char *const test[7] = {
+