summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-07-12 15:23:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-07-12 15:23:56 +0000
commit542466a186364fcc6a34015c60e55adee960344c (patch)
tree44e9cc2dd0deab20abbe2a2c380b10d5b8328da5 /app-misc/dnetc
parentremove old version (diff)
downloadgentoo-2-542466a186364fcc6a34015c60e55adee960344c.tar.gz
gentoo-2-542466a186364fcc6a34015c60e55adee960344c.tar.bz2
gentoo-2-542466a186364fcc6a34015c60e55adee960344c.zip
EAPI=2; don't call use during metadata generation
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'app-misc/dnetc')
-rw-r--r--app-misc/dnetc/ChangeLog7
-rw-r--r--app-misc/dnetc/dnetc-2.9103.509.ebuild19
2 files changed, 17 insertions, 9 deletions
diff --git a/app-misc/dnetc/ChangeLog b/app-misc/dnetc/ChangeLog
index 9386b92d68f5..fc3f5423acfd 100644
--- a/app-misc/dnetc/ChangeLog
+++ b/app-misc/dnetc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/dnetc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.59 2010/12/07 02:22:31 mattst88 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.60 2011/07/12 15:23:56 mr_bones_ Exp $
+
+ 12 Jul 2011; Michael Sterrett <mr_bones_@gentoo.org> dnetc-2.9103.509.ebuild:
+ EAPI=2; don't call use during metadata generation
07 Dec 2010; Matt Turner <mattst88@gentoo.org> -dnetc-2.9001.478.ebuild:
This ebuild only supported mipsel (on Playstation2, from the looks). If we
diff --git a/app-misc/dnetc/dnetc-2.9103.509.ebuild b/app-misc/dnetc/dnetc-2.9103.509.ebuild
index 1c13e6f07b96..c43835e9c37f 100644
--- a/app-misc/dnetc/dnetc-2.9103.509.ebuild
+++ b/app-misc/dnetc/dnetc-2.9103.509.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9103.509.ebuild,v 1.4 2010/02/23 10:04:22 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9103.509.ebuild,v 1.5 2011/07/12 15:23:56 mr_bones_ Exp $
+EAPI=2
inherit eutils
MAJ_PV=${PV:0:6}
@@ -23,11 +24,15 @@ RDEPEND="net-dns/bind-tools"
QA_PRESTRIPPED="opt/distributed.net/dnetc"
-if use amd64; then
- S="${WORKDIR}/dnetc${MIN_PV}-linux-amd64-elf"
-elif use x86; then
- S="${WORKDIR}/dnetc${MIN_PV}-linux-x86-elf-uclibc"
-fi
+S=${WORKDIR}/dnetc
+
+src_prepare() {
+ if use amd64; then
+ mv dnetc${MIN_PV}-linux-amd64-elf dnetc
+ elif use x86; then
+ mv dnetc${MIN_PV}-linux-x86-elf-uclibc dnetc
+ fi
+}
src_install() {
exeinto /opt/distributed.net