summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-08-21 23:26:06 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-08-21 23:26:06 +0000
commit431d6b75b8210a4f60730f72e5bab891aea73101 (patch)
tree47e0afd2acadc68e0d21e2672ecd602ae0db0f2e /app-misc/devtodo
parentAdded a patch for 2.6.8.1. (Manifest recommit) (diff)
downloadgentoo-2-431d6b75b8210a4f60730f72e5bab891aea73101.tar.gz
gentoo-2-431d6b75b8210a4f60730f72e5bab891aea73101.tar.bz2
gentoo-2-431d6b75b8210a4f60730f72e5bab891aea73101.zip
Fix bugs 60206 and 60207, patches by Aaron Walker.
Diffstat (limited to 'app-misc/devtodo')
-rw-r--r--app-misc/devtodo/ChangeLog9
-rw-r--r--app-misc/devtodo/Manifest6
-rw-r--r--app-misc/devtodo/devtodo-0.1.17-r2.ebuild52
-rw-r--r--app-misc/devtodo/files/devtodo-fix-TERM-sigabrt.patch23
-rw-r--r--app-misc/devtodo/files/devtodo-fix-cd-builtin.patch13
-rw-r--r--app-misc/devtodo/files/digest-devtodo-0.1.17-r21
6 files changed, 102 insertions, 2 deletions
diff --git a/app-misc/devtodo/ChangeLog b/app-misc/devtodo/ChangeLog
index 74c6bea038b3..ebc2d00fd8fc 100644
--- a/app-misc/devtodo/ChangeLog
+++ b/app-misc/devtodo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/devtodo
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.15 2004/07/21 15:54:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.16 2004/08/21 23:26:06 kloeri Exp $
+
+*devtodo-0.1.17-r2 (22 Aug 2004)
+
+ 22 Aug 2004; Bryan Østergaard <kloeri@gentoo.org>
+ +files/devtodo-fix-TERM-sigabrt.patch, +files/devtodo-fix-cd-builtin.patch,
+ +devtodo-0.1.17-r2.ebuild:
+ Fix bugs 60206 and 60207, patches by Aaron Walker.
21 Jul 2004; Robin H. Johnson <robbat2@gentoo.org> devtodo-0.1.17-r1.ebuild:
fix deps.
diff --git a/app-misc/devtodo/Manifest b/app-misc/devtodo/Manifest
index caa1cddbee9b..1c10e9a544e7 100644
--- a/app-misc/devtodo/Manifest
+++ b/app-misc/devtodo/Manifest
@@ -1,7 +1,11 @@
MD5 26f617dc1d0fe0d93ca6c5454807b01a devtodo-0.1.17-r1.ebuild 1413
MD5 708bc8d1cf20e92b71d189b71d12b641 devtodo-0.1.17.ebuild 939
-MD5 ff2e3865ede03721e740839efca31fa8 ChangeLog 2357
+MD5 b2972e2ef9886f159a32d043f36e9688 devtodo-0.1.17-r2.ebuild 1531
+MD5 d83fec991ee9ea95ca8624fc43477679 ChangeLog 2524
MD5 cb4cff0cd869696d1207553de89551c1 files/digest-devtodo-0.1.17 66
MD5 cb4cff0cd869696d1207553de89551c1 files/digest-devtodo-0.1.17-r1 66
+MD5 cb4cff0cd869696d1207553de89551c1 files/digest-devtodo-0.1.17-r2 66
+MD5 404d78d738ead3b99865b3f9cb33177d files/devtodo-fix-TERM-sigabrt.patch 758
+MD5 68c51e9b769e87f037a34aa64bbc911f files/devtodo-fix-cd-builtin.patch 303
MD5 48d3c0943acaae812475061a16fe6eb9 files/devtodo.patch 2359
MD5 3d389c27b4ba6ade4412c088cefe6f46 files/devtodo-1.1.17-notdl.patch 1985
diff --git a/app-misc/devtodo/devtodo-0.1.17-r2.ebuild b/app-misc/devtodo/devtodo-0.1.17-r2.ebuild
new file mode 100644
index 000000000000..98b0c70f78ba
--- /dev/null
+++ b/app-misc/devtodo/devtodo-0.1.17-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.17-r2.ebuild,v 1.1 2004/08/21 23:26:06 kloeri Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="A nice command line todo list for developers"
+HOMEPAGE="http://swapoff.org/DevTodo"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~s390"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.2 >=sys-libs/readline-4.1"
+DEPEND="${RDEPEND} sys-devel/automake"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Patch to allow compilation with gcc-3.3
+ epatch ${FILESDIR}/${PN}.patch
+ # bug #55371
+ epatch ${FILESDIR}/${PN}-1.1.17-notdl.patch
+
+ # bug 60206 + 60207
+ epatch ${FILESDIR}/${PN}-fix-cd-builtin.patch
+ epatch ${FILESDIR}/${PN}-fix-TERM-sigabrt.patch
+ automake
+}
+
+src_compile() {
+ gnuconfig_update
+ econf --sysconfdir=/etc/devtodo || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog QuickStart README TODO
+ dodoc doc/scripts.sh doc/scripts.tcsh doc/todorc.example contrib/tdrec
+}
+
+pkg_postinst() {
+ einfo "Because of a conflict with app-misc/tdl, the tdl symbolic link"
+ einfo "and manual page have been removed."
+ einfo "If you upgraded from a previous version, you may have to manually"
+ einfo "remove the symbolic links:"
+ einfo " /usr/bin/tdl -> /usr/bin/devtodo"
+ einfo " /usr/share/man/man1/tdl.1.gz -> /usr/share/man/man1/devtodo.1.gz"
+}
diff --git a/app-misc/devtodo/files/devtodo-fix-TERM-sigabrt.patch b/app-misc/devtodo/files/devtodo-fix-TERM-sigabrt.patch
new file mode 100644
index 000000000000..e90f4626cb12
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-fix-TERM-sigabrt.patch
@@ -0,0 +1,23 @@
+--- src/todoterm.cc.orig 2004-08-13 00:11:52.095224000 -0400
++++ src/todoterm.cc 2004-08-13 01:15:38.901461024 -0400
+@@ -2,6 +2,7 @@
+ #include "todoterm.h"
+
+ #ifdef USETERMCAP
++#include <iostream>
+ #include <string>
+ #include <stdexcept>
+ #include <curses.h>
+@@ -14,7 +15,11 @@
+ int getWidth() {
+ if (!info[2047]) {
+ char const *termtype = getenv("TERM");
+- if (!termtype) throw runtime_error("can't get terminal type, please set TERM envar");
++ if (!termtype) {
++ cerr << "can't get terminal type, defaulting to vt100." << endl;
++ cerr << "please set the TERM env variable." << endl;
++ setenv("TERM", "vt100", 0);
++ }
+ int result = tgetent(info, getenv("TERM"));
+ if (result < 0)
+ throw runtime_error("could not access termcap database");
diff --git a/app-misc/devtodo/files/devtodo-fix-cd-builtin.patch b/app-misc/devtodo/files/devtodo-fix-cd-builtin.patch
new file mode 100644
index 000000000000..09c8bf4bb999
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-fix-cd-builtin.patch
@@ -0,0 +1,13 @@
+--- doc/scripts.sh.orig 2004-08-13 00:06:05.751876192 -0400
++++ doc/scripts.sh 2004-08-13 00:06:56.935095160 -0400
+@@ -22,7 +22,9 @@
+
+ cd ()
+ {
+- builtin cd "$@" && [ -r .todo ] && devtodo ${TODO_OPTIONS}
++ builtin cd "$@"
++ RV=$?
++ [ -r .todo ] && devtodo ${TODO_OPTIONS} || return $RV
+ }
+
+ pushd ()
diff --git a/app-misc/devtodo/files/digest-devtodo-0.1.17-r2 b/app-misc/devtodo/files/digest-devtodo-0.1.17-r2
new file mode 100644
index 000000000000..21e6c99eeb79
--- /dev/null
+++ b/app-misc/devtodo/files/digest-devtodo-0.1.17-r2
@@ -0,0 +1 @@
+MD5 cc3cdd3064eaa7270191bee63d3b1a2c devtodo-0.1.17.tar.gz 312755