summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-11-13 10:58:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-11-13 10:58:24 +0000
commitcd6cb8c278ee5b5750a3b37b9862f42084e10fea (patch)
tree2f0db2ea65542b65252f0927086341e31d8bad3e /app-misc/ddccontrol-db/ddccontrol-db-20061014.ebuild
parent"Stable x86, bug #147570" (diff)
downloadgentoo-2-cd6cb8c278ee5b5750a3b37b9862f42084e10fea.tar.gz
gentoo-2-cd6cb8c278ee5b5750a3b37b9862f42084e10fea.tar.bz2
gentoo-2-cd6cb8c278ee5b5750a3b37b9862f42084e10fea.zip
Bug #154660, support for new LCDS.
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'app-misc/ddccontrol-db/ddccontrol-db-20061014.ebuild')
-rw-r--r--app-misc/ddccontrol-db/ddccontrol-db-20061014.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/ddccontrol-db/ddccontrol-db-20061014.ebuild b/app-misc/ddccontrol-db/ddccontrol-db-20061014.ebuild
new file mode 100644
index 000000000000..f9574a238398
--- /dev/null
+++ b/app-misc/ddccontrol-db/ddccontrol-db-20061014.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ddccontrol-db/ddccontrol-db-20061014.ebuild,v 1.1 2006/11/13 10:58:24 robbat2 Exp $
+
+DESCRIPTION="DDCControl monitor database"
+HOMEPAGE="http://ddccontrol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/-db}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf `enable_with nls` || die "econf failed"
+ # Touch db/options.xml.h, so it is not rebuilt
+ touch db/options.xml.h
+ emake # doesn't really build anything, but there for safety
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}