summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-17 21:10:28 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-17 21:10:28 +0000
commitef9b1a12d4c75bd36d564a89d69adf295b708aa1 (patch)
tree9d1cc524f37015ce97e18f382979d58e31c442b5 /app-misc/color
parentMarked stable on amd64 as per bug 190625. (diff)
downloadgentoo-2-ef9b1a12d4c75bd36d564a89d69adf295b708aa1.tar.gz
gentoo-2-ef9b1a12d4c75bd36d564a89d69adf295b708aa1.tar.bz2
gentoo-2-ef9b1a12d4c75bd36d564a89d69adf295b708aa1.zip
Version bump, fix HOMEPAGE, bug #160697
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'app-misc/color')
-rw-r--r--app-misc/color/ChangeLog8
-rw-r--r--app-misc/color/color-1.1.ebuild20
-rw-r--r--app-misc/color/color-1.2.ebuild41
-rw-r--r--app-misc/color/files/digest-color-1.23
4 files changed, 58 insertions, 14 deletions
diff --git a/app-misc/color/ChangeLog b/app-misc/color/ChangeLog
index eed72846350b..384fca92f425 100644
--- a/app-misc/color/ChangeLog
+++ b/app-misc/color/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/color
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/color/ChangeLog,v 1.14 2007/09/27 13:15:29 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/color/ChangeLog,v 1.15 2007/12/17 21:10:27 armin76 Exp $
+
+*color-1.2 (17 Dec 2007)
+
+ 17 Dec 2007; Raúl Porcel <armin76@gentoo.org> color-1.1.ebuild,
+ +color-1.2.ebuild:
+ Version bump, fix HOMEPAGE, bug #160697
27 Sep 2007; Christoph Mende <angelos@gentoo.org> color-1.1.ebuild:
Stable on amd64 wrt bug #193913
diff --git a/app-misc/color/color-1.1.ebuild b/app-misc/color/color-1.1.ebuild
index 5b1f446e61e3..0e83a3ce8bd5 100644
--- a/app-misc/color/color-1.1.ebuild
+++ b/app-misc/color/color-1.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/color/color-1.1.ebuild,v 1.17 2007/09/27 13:15:29 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/color/color-1.1.ebuild,v 1.18 2007/12/17 21:10:27 armin76 Exp $
-inherit ccc
+inherit toolchain-funcs
DESCRIPTION="Easily add ANSI colouring to shell scripts"
-HOMEPAGE="http://runslinux.net/projects.html#color"
+HOMEPAGE="http://www.runslinux.net/?page_id=10"
SRC_URI="http://runslinux.net/projects/color/${P}.tar.gz"
LICENSE="GPL-2"
@@ -13,19 +13,13 @@ SLOT="0"
KEYWORDS="alpha amd64 ~hppa mips ppc ppc64 sparc x86"
IUSE=""
-DEPEND="virtual/libc"
-
src_unpack() {
unpack ${A}
- # replace hardcoded compiler and CFLAGS.
- replace-cc-hardcode
- sed -i "s/-W -Wall -O2 -g/${CFLAGS}/g" ${S}/Makefile
-}
+ cd "${S}"
-src_compile() {
- emake || die
- # some feedback everything went ok.
- echo; ls -l color; size color
+ # Use correct compiler and respect CFLAGS
+ sed -i -e "s/cc/$(tc-getCC)/g" \
+ -e "s/-W -Wall -O2 -g/${CFLAGS}/g" Makefile
}
src_install() {
diff --git a/app-misc/color/color-1.2.ebuild b/app-misc/color/color-1.2.ebuild
new file mode 100644
index 000000000000..520290a2c3f5
--- /dev/null
+++ b/app-misc/color/color-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/color/color-1.2.ebuild,v 1.1 2007/12/17 21:10:27 armin76 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Easily add ANSI colouring to shell scripts"
+HOMEPAGE="http://www.runslinux.net/?page_id=10"
+SRC_URI="http://runslinux.net/projects/color/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Use correct compiler and respect CFLAGS
+ sed -i -e "s/cc/$(tc-getCC)/g" \
+ -e "s/-W -Wall -O2 -g/${CFLAGS}/g" Makefile
+}
+
+src_install() {
+ dobin color
+ dodoc CHANGELOG README
+
+ # symlink for british users.
+ dosym /usr/bin/color /usr/bin/colour
+}
+
+pkg_postinst() {
+ elog "For information on using colour in your shell scripts,"
+ elog "run \`color\` without any arguments."
+ elog
+ elog "To see all the colours available, use this command"
+ elog " $ color --list"
+ elog
+ elog "More examples are available in /usr/share/doc/${PF}."
+}
diff --git a/app-misc/color/files/digest-color-1.2 b/app-misc/color/files/digest-color-1.2
new file mode 100644
index 000000000000..4b6261e44d3a
--- /dev/null
+++ b/app-misc/color/files/digest-color-1.2
@@ -0,0 +1,3 @@
+MD5 075c057fcadb27d356a984739a26a1e2 color-1.2.tar.gz 10040
+RMD160 cdddd71e9861b1332746b49f6610d52316e857c3 color-1.2.tar.gz 10040
+SHA256 7862fffb3d948b47435803461732f7dea4af64c2714219df7f929e20cb818bd9 color-1.2.tar.gz 10040