summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-06 07:56:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-06 07:56:27 +0000
commit01792ddadd802d0193ee91d17dd78aac99875c95 (patch)
tree1984a6a565a8f198e82e06b9a9289e41d45f3e5e /app-misc/chesstask
parentfix my attempt at earlier fix (diff)
downloadgentoo-2-01792ddadd802d0193ee91d17dd78aac99875c95.tar.gz
gentoo-2-01792ddadd802d0193ee91d17dd78aac99875c95.tar.bz2
gentoo-2-01792ddadd802d0193ee91d17dd78aac99875c95.zip
fixups
Diffstat (limited to 'app-misc/chesstask')
-rw-r--r--app-misc/chesstask/chesstask-1.3.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-misc/chesstask/chesstask-1.3.ebuild b/app-misc/chesstask/chesstask-1.3.ebuild
index 39ca08d2eba6..e44f8899999f 100644
--- a/app-misc/chesstask/chesstask-1.3.ebuild
+++ b/app-misc/chesstask/chesstask-1.3.ebuild
@@ -1,23 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/chesstask/chesstask-1.3.ebuild,v 1.3 2003/06/29 23:17:15 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/chesstask/chesstask-1.3.ebuild,v 1.4 2003/08/06 07:55:38 vapier Exp $
+inherit eutils
S=${WORKDIR}/${PN}1_3
-IUSE=""
-SLOT="0"
DESCRIPTION="An editor for chess problems. It will generate PostScript and HTML files."
-SRC_URI="mirror://sourceforge/chesstask/ChessTask1_3src.zip"
HOMEPAGE="http://chesstask.sourceforge.net/"
-KEYWORDS="~ppc"
+SRC_URI="mirror://sourceforge/chesstask/ChessTask1_3src.zip"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+
DEPEND=">=x11-libs/qt-3
- app-text/tetex"
+ app-text/tetex"
src_unpack() {
unpack ${A}
- cd ${S} || die "no such directory ${S}"
- patch -p1 Makefile < ${FILESDIR}/Makefile-1.3.diff || die "Failed to apply patch"
+ cd ${S}
+ epatch ${FILESDIR}/Makefile-1.3.diff
}
@@ -25,7 +27,6 @@ src_compile() {
emake || die
}
-src_install () {
- mkdir -p ${D}/usr/bin
- cp ${S}/ChessTask ${D}/usr/bin
+src_install() {
+ dobin ChessTask
}