summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-16 14:40:47 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-16 14:40:47 +0000
commit287ab33f4bb3d1afe75c15163cf7f04b3dc48fd5 (patch)
treee1a38524f537f035eed7b61bd0bbb282d77fb7bb /app-misc/ca-certificates
parentAdd missing gstreamer useflagswitch, thanks Nikoli for spotting. (diff)
downloadgentoo-2-287ab33f4bb3d1afe75c15163cf7f04b3dc48fd5.tar.gz
gentoo-2-287ab33f4bb3d1afe75c15163cf7f04b3dc48fd5.tar.bz2
gentoo-2-287ab33f4bb3d1afe75c15163cf7f04b3dc48fd5.zip
Version bump.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-misc/ca-certificates')
-rw-r--r--app-misc/ca-certificates/ChangeLog8
-rw-r--r--app-misc/ca-certificates/ca-certificates-20130906.ebuild97
2 files changed, 104 insertions, 1 deletions
diff --git a/app-misc/ca-certificates/ChangeLog b/app-misc/ca-certificates/ChangeLog
index 933f345b7395..3debebd1912f 100644
--- a/app-misc/ca-certificates/ChangeLog
+++ b/app-misc/ca-certificates/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/ca-certificates
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ca-certificates/ChangeLog,v 1.85 2013/07/04 12:25:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ca-certificates/ChangeLog,v 1.86 2013/09/16 14:40:47 radhermit Exp $
+
+*ca-certificates-20130906 (16 Sep 2013)
+
+ 16 Sep 2013; Tim Harder <radhermit@gentoo.org>
+ +ca-certificates-20130906.ebuild:
+ Version bump.
04 Jul 2013; Agostino Sarubbo <ago@gentoo.org>
ca-certificates-20130119.ebuild:
diff --git a/app-misc/ca-certificates/ca-certificates-20130906.ebuild b/app-misc/ca-certificates/ca-certificates-20130906.ebuild
new file mode 100644
index 000000000000..5875d9737472
--- /dev/null
+++ b/app-misc/ca-certificates/ca-certificates-20130906.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ca-certificates/ca-certificates-20130906.ebuild,v 1.1 2013/09/16 14:40:47 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils unpacker
+
+DESCRIPTION="Common CA Certificates PEM files"
+HOMEPAGE="http://packages.debian.org/sid/ca-certificates"
+#NMU_PR="1"
+SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${PV}${NMU_PR:++nmu}${NMU_PR}_all.deb"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+# platforms like AIX don't have a good ar
+DEPEND="kernel_AIX? ( app-arch/deb2targz )
+ !<sys-apps/portage-2.1.10.41"
+# openssl: we run `c_rehash`
+# debianutils: we run `run-parts`
+RDEPEND="${DEPEND}
+ dev-libs/openssl
+ sys-apps/debianutils"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ # For the conversion to having it in CONFIG_PROTECT_MASK,
+ # we need to tell users about it once manually first.
+ [[ -f "${EPREFIX}"/etc/env.d/98ca-certificates ]] \
+ || ewarn "You should run update-ca-certificates manually after etc-update"
+}
+
+src_unpack() {
+ if [[ -n ${EPREFIX} ]] ; then
+ # need to perform everything in the offset, #381937
+ mkdir -p "./${EPREFIX}"
+ cd "./${EPREFIX}" || die
+ fi
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ cd "./${EPREFIX}" || die
+ epatch "${FILESDIR}"/${PN}-20110502-root.patch
+ local relp=$(echo "${EPREFIX}" | sed -e 's:[^/]\+:..:g')
+ sed -i \
+ -e '/="$ROOT/s:ROOT/:ROOT'"${EPREFIX}"'/:' \
+ -e '/RELPATH="\.\./s:"$:'"${relp}"'":' \
+ usr/sbin/update-ca-certificates || die
+}
+
+src_compile() {
+ (
+ echo "# Automatically generated by ${CATEGORY}/${PF}"
+ echo "# $(date -u)"
+ echo "# Do not edit."
+ cd "${S}${EPREFIX}"/usr/share/ca-certificates
+ find * -name '*.crt' | LC_ALL=C sort
+ ) > "${S}${EPREFIX}"/etc/ca-certificates.conf
+
+ sh "${S}${EPREFIX}"/usr/sbin/update-ca-certificates --root "${S}" || die
+}
+
+src_install() {
+ cp -pPR . "${D}"/ || die
+
+ mv "${ED}"/usr/share/doc/{ca-certificates,${PF}} || die
+
+ echo 'CONFIG_PROTECT_MASK="/etc/ca-certificates.conf"' > 98ca-certificates
+ doenvd 98ca-certificates
+}
+
+pkg_postinst() {
+ if [ -d "${EROOT}/usr/local/share/ca-certificates" ] ; then
+ # if the user has local certs, we need to rebuild again
+ # to include their stuff in the db.
+ # However it's too overzealous when the user has custom certs in place.
+ # --fresh is to clean up dangling symlinks
+ "${EROOT}"/usr/sbin/update-ca-certificates --root "${EROOT}"
+ fi
+
+ local c badcerts=0
+ for c in $(find -L "${EROOT}"etc/ssl/certs/ -type l) ; do
+ ewarn "Broken symlink for a certificate at $c"
+ badcerts=1
+ done
+ if [ $badcerts -eq 1 ]; then
+ ewarn "You MUST remove the above broken symlinks"
+ ewarn "Otherwise any SSL validation that use the directory may fail!"
+ ewarn "To batch-remove them, run:"
+ ewarn "find -L ${EROOT}etc/ssl/certs/ -type l -exec rm {} +"
+ fi
+}