summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-18 16:49:44 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-18 16:49:44 +0000
commit7801f0b909c2dd561cbbcd1c4de891de0956044c (patch)
treed3f586aa643c4bed354b3edeef721aabc15dff89 /app-misc/boxes
parentsparc stable wrt #321493 (diff)
downloadgentoo-2-7801f0b909c2dd561cbbcd1c4de891de0956044c.tar.gz
gentoo-2-7801f0b909c2dd561cbbcd1c4de891de0956044c.tar.bz2
gentoo-2-7801f0b909c2dd561cbbcd1c4de891de0956044c.zip
Respecting LDFLAGS, 337632
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/boxes')
-rw-r--r--app-misc/boxes/ChangeLog10
-rw-r--r--app-misc/boxes/boxes-1.1-r1.ebuild32
-rw-r--r--app-misc/boxes/files/1.1-Makefile.patch57
3 files changed, 97 insertions, 2 deletions
diff --git a/app-misc/boxes/ChangeLog b/app-misc/boxes/ChangeLog
index 2ea08197f20e..cf5594ae0627 100644
--- a/app-misc/boxes/ChangeLog
+++ b/app-misc/boxes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/boxes
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/ChangeLog,v 1.22 2009/08/20 03:39:08 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/ChangeLog,v 1.23 2010/09/18 16:49:44 jlec Exp $
+
+*boxes-1.1-r1 (18 Sep 2010)
+
+ 18 Sep 2010; Justin Lecher <jlec@gentoo.org> +files/1.1-Makefile.patch,
+ +boxes-1.1-r1.ebuild:
+ Respecting LDFLAGS, 337632
20 Aug 2009; Jeremy Olexa <darkside@gentoo.org>
-files/boxes-1.0.1-Makefile.patch, -files/boxes-1.0.1-flex.patch:
diff --git a/app-misc/boxes/boxes-1.1-r1.ebuild b/app-misc/boxes/boxes-1.1-r1.ebuild
new file mode 100644
index 000000000000..4ffc058ab998
--- /dev/null
+++ b/app-misc/boxes/boxes-1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/boxes-1.1-r1.ebuild,v 1.1 2010/09/18 16:49:44 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Draw any kind of boxes around your text"
+HOMEPAGE="http://boxes.thomasjensen.com/"
+SRC_URI="http://boxes.thomasjensen.com/download/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin src/boxes || die
+ doman doc/boxes.1 || die
+ dodoc README || die
+ insinto /usr/share/boxes
+ doins boxes-config || die
+}
diff --git a/app-misc/boxes/files/1.1-Makefile.patch b/app-misc/boxes/files/1.1-Makefile.patch
new file mode 100644
index 000000000000..4f4ddac58b3b
--- /dev/null
+++ b/app-misc/boxes/files/1.1-Makefile.patch
@@ -0,0 +1,57 @@
+diff --git a/Makefile b/Makefile
+index 79dda53..71f8d54 100644
+--- a/Makefile
++++ b/Makefile
+@@ -73,7 +73,7 @@
+
+
+ # The following line (GLOBALCONF) is the only line you should need to edit!
+-GLOBALCONF = /usr/share/boxes
++GLOBALCONF = /usr/share/boxes/boxes-config
+ BVERSION = 1.1
+
+ SNAPFILE = boxes-SNAP-$(shell date +%Y%m%d)
+diff --git a/src/Makefile b/src/Makefile
+index 7cfab9f..9ed467b 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -86,8 +86,7 @@
+ LEX = flex
+ YACC = bison
+ CC = gcc
+-CFLAGS = -ansi -I. -Iregexp -Wall -W $(CFLAGS_ADDTL)
+-LDFLAGS = -Lregexp
++CFLAGS += -ansi -I. -Iregexp $(CFLAGS_ADDTL)
+
+ GEN_HDR = parser.h
+ GEN_SRC = parser.c lex.yy.c
+@@ -106,14 +105,13 @@ ALL_OBJ = $(GEN_SRC:.c=.o) $(ORIG_NORM:.c=.o)
+
+
+ build:
+- $(MAKE) CFLAGS_ADDTL=-O boxes
+- strip boxes
++ $(MAKE) boxes
+ debug:
+ $(MAKE) CFLAGS_ADDTL=-g boxes
+
+ boxes: $(ALL_OBJ)
+ $(MAKE) -C regexp CC=$(CC) libregexp.a
+- $(CC) $(LDFLAGS) $(ALL_OBJ) -o boxes -lregexp
++ $(CC) $(LDFLAGS) $(ALL_OBJ) -o boxes -Lregexp -lregexp
+
+ boxes.h:
+ @echo File boxes.h not found or not current. Please run make in the parent directory.
+diff --git a/src/regexp/Makefile b/src/regexp/Makefile
+index 0bd0ace..53966c9 100644
+--- a/src/regexp/Makefile
++++ b/src/regexp/Makefile
+@@ -42,7 +42,7 @@
+ #============================================================================
+
+
+-CFLAGS = -O -I. $(CFLAGS_ADDTL)
++CFLAGS += -I. $(CFLAGS_ADDTL)
+
+ ALL_CL = regexp/regexp.c regexp/regsub.c
+ C_SRC = $(notdir $(ALL_CL))