summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-07 09:48:23 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-07 09:48:23 +0000
commitfaa52ab03f5fb299f3001d62bb59a8663079684f (patch)
tree52b21db2d8565ccf135695ac751464d363123f8e /app-misc/binwalk
parentFix libsoup deps (diff)
downloadgentoo-2-faa52ab03f5fb299f3001d62bb59a8663079684f.tar.gz
gentoo-2-faa52ab03f5fb299f3001d62bb59a8663079684f.tar.bz2
gentoo-2-faa52ab03f5fb299f3001d62bb59a8663079684f.zip
Don't do dependency checking during build.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-misc/binwalk')
-rw-r--r--app-misc/binwalk/ChangeLog6
-rw-r--r--app-misc/binwalk/binwalk-1.2.ebuild4
-rw-r--r--app-misc/binwalk/files/binwalk-1.2-no-deps-check.patch42
3 files changed, 50 insertions, 2 deletions
diff --git a/app-misc/binwalk/ChangeLog b/app-misc/binwalk/ChangeLog
index f33e2b0378f8..6499a9994720 100644
--- a/app-misc/binwalk/ChangeLog
+++ b/app-misc/binwalk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/binwalk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/binwalk/ChangeLog,v 1.27 2013/04/05 08:26:33 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/binwalk/ChangeLog,v 1.28 2013/04/07 09:48:23 radhermit Exp $
+
+ 07 Apr 2013; Tim Harder <radhermit@gentoo.org> binwalk-1.2.ebuild,
+ +files/binwalk-1.2-no-deps-check.patch:
+ Don't do dependency checking during build.
*binwalk-1.2 (05 Apr 2013)
diff --git a/app-misc/binwalk/binwalk-1.2.ebuild b/app-misc/binwalk/binwalk-1.2.ebuild
index c7e82b5ae8ca..dfd20f4ea029 100644
--- a/app-misc/binwalk/binwalk-1.2.ebuild
+++ b/app-misc/binwalk/binwalk-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/binwalk/binwalk-1.2.ebuild,v 1.1 2013/04/05 08:26:33 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/binwalk/binwalk-1.2.ebuild,v 1.2 2013/04/07 09:48:23 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -22,3 +22,5 @@ RDEPEND="sys-apps/file[python]
S=${WORKDIR}/${P}/src
DOCS=( ../docs/README ../docs/API )
+
+PATCHES=( "${FILESDIR}"/${P}-no-deps-check.patch )
diff --git a/app-misc/binwalk/files/binwalk-1.2-no-deps-check.patch b/app-misc/binwalk/files/binwalk-1.2-no-deps-check.patch
new file mode 100644
index 000000000000..67e5094c266d
--- /dev/null
+++ b/app-misc/binwalk/files/binwalk-1.2-no-deps-check.patch
@@ -0,0 +1,42 @@
+--- binwalk-1.2/src/setup.py
++++ binwalk-1.2/src/setup.py
+@@ -5,39 +5,6 @@
+
+ WIDTH = 115
+
+-# Check for pre-requisite modules
+-print "checking pre-requisites"
+-try:
+- import magic
+- try:
+- magic.MAGIC_NO_CHECK_TEXT
+- except Exception, e:
+- print "\n", "*" * WIDTH
+- print "Pre-requisite failure:", str(e)
+- print "It looks like you have an old or incompatible magic module installed."
+- print "Please install the official python-magic module, or download and install it from source: ftp://ftp.astron.com/pub/file/"
+- print "*" * WIDTH, "\n"
+- sys.exit(1)
+-except Exception, e:
+- print "\n", "*" * WIDTH
+- print "Pre-requisite failure:", str(e)
+- print "Please install the python-magic module, or download and install it from source: ftp://ftp.astron.com/pub/file/"
+- print "*" * WIDTH, "\n"
+- sys.exit(1)
+-
+-try:
+- import matplotlib.pyplot
+-except Exception, e:
+- print "\n", "*" * WIDTH
+- print "Pre-requisite check warning:", str(e)
+- print "To take advantage of this tool's entropy plotting capabilities, please install the python-matplotlib module."
+- print "*" * WIDTH, "\n"
+-
+- if raw_input('Continue installation without this module (Y/n)? ').lower().startswith('n'):
+- print 'Quitting...\n'
+- sys.exit(1)
+-
+-
+ # Generate a new magic file from the files in the magic directory
+ print "generating binwalk magic file"
+ magic_files = listdir("magic")