summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-09-29 03:54:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-09-29 03:54:25 +0000
commitd4942a862f04fd7c739319397d2419ad9a86d4ac (patch)
tree22952053ed416130dcd2cc78ebd1b1b583578ade /app-misc/anki
parentupdate HOMEPAGE, add patches (from upstream) to fix broken tests (13 months o... (diff)
downloadgentoo-2-d4942a862f04fd7c739319397d2419ad9a86d4ac.tar.gz
gentoo-2-d4942a862f04fd7c739319397d2419ad9a86d4ac.tar.bz2
gentoo-2-d4942a862f04fd7c739319397d2419ad9a86d4ac.zip
Bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-misc/anki')
-rw-r--r--app-misc/anki/ChangeLog7
-rw-r--r--app-misc/anki/anki-2.0.29.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/app-misc/anki/ChangeLog b/app-misc/anki/ChangeLog
index 2f32c74d9593..560c873f62d8 100644
--- a/app-misc/anki/ChangeLog
+++ b/app-misc/anki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/anki
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.83 2014/08/14 16:50:56 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.84 2014/09/29 03:54:25 patrick Exp $
+
+*anki-2.0.29 (29 Sep 2014)
+
+ 29 Sep 2014; Patrick Lauer <patrick@gentoo.org> +anki-2.0.29.ebuild:
+ Bump
14 Aug 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> anki-2.0.28.ebuild:
x86 stable wrt bug #518844
diff --git a/app-misc/anki/anki-2.0.29.ebuild b/app-misc/anki/anki-2.0.29.ebuild
new file mode 100644
index 000000000000..9f844ac70fbb
--- /dev/null
+++ b/app-misc/anki/anki-2.0.29.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-2.0.29.ebuild,v 1.1 2014/09/29 03:54:25 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils python-single-r1
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="http://ichi2.net/anki/"
+SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex +recording +sound"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/PyQt4[X,svg,webkit]
+ >=dev-python/httplib2-0.7.4
+ dev-python/beautifulsoup:python-2
+ dev-python/send2trash
+ recording? ( media-sound/lame
+ >=dev-python/pyaudio-0.2.4 )
+ sound? ( media-video/mplayer )
+ latex? ( app-text/texlive
+ app-text/dvipng )"
+DEPEND=""
+
+pkg_setup(){
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -r thirdparty || die
+ sed -i -e "s/updates=True/updates=False/" \
+ aqt/profiles.py || die
+}
+
+# Nothing to configure or compile
+src_configure() {
+ true;
+}
+
+src_compile() {
+ true;
+}
+
+src_install() {
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+
+ dodoc README README.development
+ python_domodule aqt anki
+ python_doscript anki/anki
+}
+
+pkg_preinst() {
+ if has_version "<app-misc/anki-2" ; then
+ elog "Anki 2 is a rewrite of Anki with many new features and"
+ elog "a new database format. On the first run your decks are"
+ elog "converted to the new format and a backup of your Anki-1"
+ elog "decks is created. Please read the following:"
+ elog "http://ankisrs.net/anki2.html"
+ fi
+}