summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-11-21 11:33:28 +0000
committerThomas Kahle <tomka@gentoo.org>2013-11-21 11:33:28 +0000
commitaa9ae488b149ae4237ae04ca22569c2213c84b9a (patch)
treedd0a4744716e8baaef562d365ce4aef2944afee7 /app-misc/anki
parentAdd ~arm keyword (diff)
downloadgentoo-2-aa9ae488b149ae4237ae04ca22569c2213c84b9a.tar.gz
gentoo-2-aa9ae488b149ae4237ae04ca22569c2213c84b9a.tar.bz2
gentoo-2-aa9ae488b149ae4237ae04ca22569c2213c84b9a.zip
bump to 2.0.18
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'app-misc/anki')
-rw-r--r--app-misc/anki/ChangeLog7
-rw-r--r--app-misc/anki/anki-2.0.18.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/app-misc/anki/ChangeLog b/app-misc/anki/ChangeLog
index 74346c450024..fef6207161b3 100644
--- a/app-misc/anki/ChangeLog
+++ b/app-misc/anki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/anki
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.70 2013/11/11 20:43:38 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.71 2013/11/21 11:33:28 tomka Exp $
+
+*anki-2.0.18 (21 Nov 2013)
+
+ 21 Nov 2013; Thomas Kahle <tomka@gentoo.org> +anki-2.0.18.ebuild:
+ bump to 2.0.18
*anki-2.0.17 (11 Nov 2013)
diff --git a/app-misc/anki/anki-2.0.18.ebuild b/app-misc/anki/anki-2.0.18.ebuild
new file mode 100644
index 000000000000..f3cec5bb3ca9
--- /dev/null
+++ b/app-misc/anki/anki-2.0.18.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-2.0.18.ebuild,v 1.1 2013/11/21 11:33:28 tomka Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils python-single-r1
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="http://ichi2.net/anki/"
+SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex +recording +sound"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/PyQt4[X,svg,webkit]
+ >=dev-python/httplib2-0.7.4
+ dev-python/beautifulsoup:python-2
+ dev-python/send2trash
+ recording? ( media-sound/lame
+ >=dev-python/pyaudio-0.2.4 )
+ sound? ( media-video/mplayer )
+ latex? ( app-text/texlive
+ app-text/dvipng )"
+DEPEND=""
+
+pkg_setup(){
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -r thirdparty || die
+ sed -i -e "s/updates=True/updates=False/" \
+ aqt/profiles.py || die
+}
+
+# Nothing to configure or compile
+src_configure() {
+ true;
+}
+
+src_compile() {
+ true;
+}
+
+src_install() {
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+
+ dodoc README README.development
+ python_domodule aqt anki
+ python_doscript anki/anki
+}
+
+pkg_preinst() {
+ if has_version "<app-misc/anki-2" ; then
+ elog "Anki 2 is a rewrite of Anki with many new features and"
+ elog "a new database format. On the first run your decks are"
+ elog "converted to the new format and a backup of your Anki-1"
+ elog "decks is created. Please read the following:"
+ elog "http://ankisrs.net/anki2.html"
+ fi
+}