summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-01-08 09:54:01 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-01-08 09:54:01 +0000
commit8e99db4b661bcf838931a9b5e982984de9173e10 (patch)
treea818db7a63cef3631ce7867ae3ecd4318e78b730 /app-leechcraft
parentBump to LeecChraft-0.6.60 release, thanks to 0xd34df00d. (diff)
downloadgentoo-2-8e99db4b661bcf838931a9b5e982984de9173e10.tar.gz
gentoo-2-8e99db4b661bcf838931a9b5e982984de9173e10.tar.bz2
gentoo-2-8e99db4b661bcf838931a9b5e982984de9173e10.zip
Bump to LeecChraft-0.6.60 release, thanks to 0xd34df00d.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-poshuku/ChangeLog9
-rw-r--r--app-leechcraft/lc-poshuku/lc-poshuku-0.6.60.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/app-leechcraft/lc-poshuku/ChangeLog b/app-leechcraft/lc-poshuku/ChangeLog
index e0c335cddd36..d6d098d70251 100644
--- a/app-leechcraft/lc-poshuku/ChangeLog
+++ b/app-leechcraft/lc-poshuku/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-poshuku
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-poshuku/ChangeLog,v 1.8 2013/09/24 15:50:46 maksbotan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-poshuku/ChangeLog,v 1.9 2014/01/08 09:54:01 maksbotan Exp $
+
+*lc-poshuku-0.6.60 (08 Jan 2014)
+
+ 08 Jan 2014; Maxim Koltsov <maksbotan@gentoo.org> +lc-poshuku-0.6.60.ebuild:
+ Bump to LeecChraft-0.6.60 release, thanks to 0xd34df00d.
*lc-poshuku-0.6.0 (24 Sep 2013)
diff --git a/app-leechcraft/lc-poshuku/lc-poshuku-0.6.60.ebuild b/app-leechcraft/lc-poshuku/lc-poshuku-0.6.60.ebuild
new file mode 100644
index 000000000000..106519e2b568
--- /dev/null
+++ b/app-leechcraft/lc-poshuku/lc-poshuku-0.6.60.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-poshuku/lc-poshuku-0.6.60.ebuild,v 1.1 2014/01/08 09:54:01 maksbotan Exp $
+
+EAPI="4"
+
+inherit confutils leechcraft
+
+DESCRIPTION="Poshuku, the full-featured web browser plugin for LeechCraft."
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +cleanweb +fatape +filescheme +fua +idn +keywords +onlinebookmarks
+ +pcre postgres +sqlite wyfv"
+
+DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtwebkit:4
+ idn? ( net-dns/libidn )
+ onlinebookmarks? ( >=dev-libs/qjson-0.7.1-r1 )
+ pcre? ( >=dev-libs/libpcre-8.12 )
+"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="pcre? ( cleanweb )"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable cleanweb POSHUKU_CLEANWEB)
+ $(cmake-utils_use_enable fatape POSHUKU_FATAPE)
+ $(cmake-utils_use_enable filescheme POSHUKU_FILESCHEME)
+ $(cmake-utils_use_enable fua POSHUKU_FUA)
+ $(cmake-utils_use_enable idn IDN)
+ $(cmake-utils_use_enable keywords POSHUKU_KEYWORDS)
+ $(cmake-utils_use_enable onlinebookmarks POSHUKU_ONLINEBOOKMARKS)
+ $(cmake-utils_use_enable pcre POSHUKU_CLEANWEB_PCRE)
+ $(cmake-utils_use_enable wyfv POSHUKU_WYFV)
+ "
+
+ cmake-utils_src_configure
+}