summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-10-02 09:49:30 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-10-02 09:49:30 +0000
commit6be735b664058c89046774524e198ac7c748cc4f (patch)
treeaca9f4019faa4c695843163ea8a117adfa107d56 /app-leechcraft
parentUse sub-slot deps on systemd. (diff)
downloadgentoo-2-6be735b664058c89046774524e198ac7c748cc4f.tar.gz
gentoo-2-6be735b664058c89046774524e198ac7c748cc4f.tar.bz2
gentoo-2-6be735b664058c89046774524e198ac7c748cc4f.zip
Fix poppler/ghostscript issues in dependencies, thanks to 0xd34df00d
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog11
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.5.90-r2.ebuild35
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.5.99-r1.ebuild42
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.6.0-r1.ebuild42
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild10
5 files changed, 137 insertions, 3 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index 724d3dc70016..8e1182ef5f8a 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-leechcraft/lc-monocle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.8 2013/09/24 15:48:06 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.9 2013/10/02 09:49:30 maksbotan Exp $
+
+*lc-monocle-0.6.0-r1 (02 Oct 2013)
+*lc-monocle-0.5.99-r1 (02 Oct 2013)
+*lc-monocle-0.5.90-r2 (02 Oct 2013)
+
+ 02 Oct 2013; Maxim Koltsov <maksbotan@gentoo.org>
+ +lc-monocle-0.5.90-r2.ebuild, +lc-monocle-0.5.99-r1.ebuild,
+ +lc-monocle-0.6.0-r1.ebuild, lc-monocle-9999.ebuild:
+ Fix poppler/ghostscript issues in dependencies, thanks to 0xd34df00d
*lc-monocle-0.6.0 (24 Sep 2013)
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.5.90-r2.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.5.90-r2.ebuild
new file mode 100644
index 000000000000..54c2c4223473
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.5.90-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.5.90-r2.ebuild,v 1.1 2013/10/02 09:49:30 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+djvu debug +fb2 +pdf +spectre"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? (
+ app-text/libspectre
+ || (
+ app-text/poppler[-lcms]
+ <app-text/ghostscript-gpl-9.07
+ )
+ )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)"
+
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.5.99-r1.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.5.99-r1.ebuild
new file mode 100644
index 000000000000..060fd9e54e21
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.5.99-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.5.99-r1.ebuild,v 1.1 2013/10/02 09:49:30 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
+
+RDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? (
+ app-text/libspectre
+ || (
+ app-text/poppler[-lcms]
+ <app-text/ghostscript-gpl-9.07
+ )
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.6.0-r1.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..2882c880ac07
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.6.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.6.0-r1.ebuild,v 1.1 2013/10/02 09:49:30 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
+
+RDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? (
+ app-text/libspectre
+ || (
+ app-text/poppler[-lcms]
+ <app-text/ghostscript-gpl-9.07
+ )
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
index 0c0581fb2791..fe62a29af7d3 100644
--- a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild,v 1.2 2013/04/14 16:18:51 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild,v 1.3 2013/10/02 09:49:30 maksbotan Exp $
EAPI="5"
@@ -15,7 +15,13 @@ IUSE="debug +djvu doc +fb2 +pdf +spectre"
RDEPEND="~app-leechcraft/lc-core-${PV}
pdf? ( app-text/poppler[qt4] )
djvu? ( app-text/djvu )
- spectre? ( app-text/libspectre )"
+ spectre? (
+ app-text/libspectre
+ || (
+ app-text/poppler[-lcms]
+ <app-text/ghostscript-gpl-9.07
+ )
+ )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )"