summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-01-08 09:57:23 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-01-08 09:57:23 +0000
commit3ad3f044fde65e946ee837ccd66d36c026376934 (patch)
tree1bb7f764fda850cdc4c31bfe95ef7984d22b2bf2 /app-leechcraft
parentBump to LeecChraft-0.6.60 release, thanks to 0xd34df00d. (diff)
downloadgentoo-2-3ad3f044fde65e946ee837ccd66d36c026376934.tar.gz
gentoo-2-3ad3f044fde65e946ee837ccd66d36c026376934.tar.bz2
gentoo-2-3ad3f044fde65e946ee837ccd66d36c026376934.zip
Bump to LeecChraft-0.6.60 release, thanks to 0xd34df00d.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-vrooby/ChangeLog9
-rw-r--r--app-leechcraft/lc-vrooby/lc-vrooby-0.6.60.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/app-leechcraft/lc-vrooby/ChangeLog b/app-leechcraft/lc-vrooby/ChangeLog
index f6be71d6bb02..7821f45c9d2a 100644
--- a/app-leechcraft/lc-vrooby/ChangeLog
+++ b/app-leechcraft/lc-vrooby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-vrooby
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-vrooby/ChangeLog,v 1.8 2013/09/24 15:53:50 maksbotan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-vrooby/ChangeLog,v 1.9 2014/01/08 09:57:23 maksbotan Exp $
+
+*lc-vrooby-0.6.60 (08 Jan 2014)
+
+ 08 Jan 2014; Maxim Koltsov <maksbotan@gentoo.org> +lc-vrooby-0.6.60.ebuild:
+ Bump to LeecChraft-0.6.60 release, thanks to 0xd34df00d.
*lc-vrooby-0.6.0 (24 Sep 2013)
diff --git a/app-leechcraft/lc-vrooby/lc-vrooby-0.6.60.ebuild b/app-leechcraft/lc-vrooby/lc-vrooby-0.6.60.ebuild
new file mode 100644
index 000000000000..27b6ce17a8d3
--- /dev/null
+++ b/app-leechcraft/lc-vrooby/lc-vrooby-0.6.60.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-vrooby/lc-vrooby-0.6.60.ebuild,v 1.1 2014/01/08 09:57:23 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Vrooby, removable device manager for LeechCraft."
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug udisks udisks2"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtdbus:4"
+RDEPEND="${DEPEND}
+ udisks? ( sys-fs/udisks:0 )
+ udisks2? ( sys-fs/udisks:2 )
+ "
+
+REQUIRED_USE="|| ( udisks udisks2 )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable udisks VROOBY_UDISKS)
+ $(cmake-utils_use_enable udisks2 VROOBY_UDISKS2)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use udisks2; then
+ elog "You have enabled the experimental UDisks2 backend. "
+ elog "Please try the old udisks:0-based one before "
+ elog "reporting issues."
+ fi
+}