summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-04-10 17:50:01 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-04-10 17:50:01 +0000
commit372ba74e2c11182f6de37469b8e9cfdbd98260cc (patch)
treefb0b42e0d4c2b3fdef6b78cd8032a8f46727ff1f /app-leechcraft/lc-aggregator
parentBump LeechCraft to 0.5.65, thanks to 0xd34df00d. (diff)
downloadgentoo-2-372ba74e2c11182f6de37469b8e9cfdbd98260cc.tar.gz
gentoo-2-372ba74e2c11182f6de37469b8e9cfdbd98260cc.tar.bz2
gentoo-2-372ba74e2c11182f6de37469b8e9cfdbd98260cc.zip
Bump LeechCraft to 0.5.65, thanks to 0xd34df00d.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-aggregator')
-rw-r--r--app-leechcraft/lc-aggregator/ChangeLog8
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-0.6.65.ebuild39
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild13
-rw-r--r--app-leechcraft/lc-aggregator/metadata.xml3
4 files changed, 59 insertions, 4 deletions
diff --git a/app-leechcraft/lc-aggregator/ChangeLog b/app-leechcraft/lc-aggregator/ChangeLog
index 3ba7abe6523d..662d13734165 100644
--- a/app-leechcraft/lc-aggregator/ChangeLog
+++ b/app-leechcraft/lc-aggregator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-leechcraft/lc-aggregator
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.10 2014/04/03 08:02:41 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.11 2014/04/10 17:50:01 maksbotan Exp $
+
+*lc-aggregator-0.6.65 (10 Apr 2014)
+
+ 10 Apr 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +lc-aggregator-0.6.65.ebuild, lc-aggregator-9999.ebuild, metadata.xml:
+ Bump LeechCraft to 0.5.65, thanks to 0xd34df00d.
03 Apr 2014; Mikle Kolyada <zlogene@gentoo.org> lc-aggregator-0.6.60.ebuild:
x86 stable wrt bug #500914
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-0.6.65.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-0.6.65.ebuild
new file mode 100644
index 000000000000..942db9997d56
--- /dev/null
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-0.6.65.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/lc-aggregator-0.6.65.ebuild,v 1.1 2014/04/10 17:50:01 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug mysql +sqlite postgres webaccess"
+
+DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="|| ( mysql sqlite postgres )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enale webaccess AGGREGATOR_WEBACCESS)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_setup(){
+ if use mysql; then
+ ewarn "Support for MySQL databases is experimental and is more likely"
+ ewarn "to contain bugs or mishandle your data than other storage"
+ ewarn "backends. If you do not plan testing the MySQL storage backend"
+ ewarn "itself, consider using other backends."
+ ewarn "Anyway, it is perfectly safe to enable the mysql use flag as"
+ ewarn "long as at least one other storage is enabled since you will"
+ ewarn "be able to choose another storage backend at run time."
+ fi
+}
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
index 05248d42bf17..b8814c42a023 100644
--- a/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild,v 1.1 2013/03/08 21:54:30 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild,v 1.2 2014/04/10 17:50:01 maksbotan Exp $
EAPI="4"
@@ -10,7 +10,7 @@ DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug mysql +sqlite postgres"
+IUSE="debug mysql +sqlite postgres webaccess"
DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
dev-qt/qtwebkit:4"
@@ -19,6 +19,13 @@ RDEPEND="${DEPEND}
REQUIRED_USE="|| ( mysql sqlite postgres )"
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enale webaccess AGGREGATOR_WEBACCESS)
+ )
+ cmake-utils_src_configure
+}
+
pkg_setup(){
if use mysql; then
ewarn "Support for MySQL databases is experimental and is more likely"
diff --git a/app-leechcraft/lc-aggregator/metadata.xml b/app-leechcraft/lc-aggregator/metadata.xml
index 2c857dda08d3..c33962165ff1 100644
--- a/app-leechcraft/lc-aggregator/metadata.xml
+++ b/app-leechcraft/lc-aggregator/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>leechcraft</herd>
+ <use>
+ <flag name="webaccess">Enables web interface submodule for Aggregator</flag>
+ </use>
</pkgmetadata>