summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-11-25 23:16:23 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-11-25 23:16:23 +0000
commita356ca9bf6fe795ad48f6e5b762d86a7a75442de (patch)
tree03778a40051b9173d9a66825670843da77f690fe /app-laptop
parentChanges to use the new linux-* eclasses. (Manifest recommit) (diff)
downloadgentoo-2-a356ca9bf6fe795ad48f6e5b762d86a7a75442de.tar.gz
gentoo-2-a356ca9bf6fe795ad48f6e5b762d86a7a75442de.tar.bz2
gentoo-2-a356ca9bf6fe795ad48f6e5b762d86a7a75442de.zip
Version bump, acerhk-0.5.14 stable on x86
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/acerhk/ChangeLog8
-rw-r--r--app-laptop/acerhk/acerhk-0.5.14.ebuild4
-rw-r--r--app-laptop/acerhk/acerhk-0.5.18.ebuild57
-rw-r--r--app-laptop/acerhk/files/digest-acerhk-0.5.181
4 files changed, 67 insertions, 3 deletions
diff --git a/app-laptop/acerhk/ChangeLog b/app-laptop/acerhk/ChangeLog
index 039c5bd1b82e..4c6a069ddaaa 100644
--- a/app-laptop/acerhk/ChangeLog
+++ b/app-laptop/acerhk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/acerhk
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/ChangeLog,v 1.1 2004/08/26 08:12:23 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/ChangeLog,v 1.2 2004/11/25 23:16:23 sekretarz Exp $
+
+*acerhk-0.5.18 (26 Nov 2004)
+
+ 26 Nov 2004; Karol Wojtaszek <sekretarz@gentoo.org> acerhk-0.5.14.ebuild,
+ +acerhk-0.5.18.ebuild:
+ Version bump, acerhk-0.5.14 stable on x86
26 Aug 2004; Karol Wojtaszek <sekretarz@gentoo.org> :
Initial add. Thanks to Sebastien ESTIENNE <sebest@ovibes.net> and Ronald van
diff --git a/app-laptop/acerhk/acerhk-0.5.14.ebuild b/app-laptop/acerhk/acerhk-0.5.14.ebuild
index 9b9e5f77f839..be45ed8f828b 100644
--- a/app-laptop/acerhk/acerhk-0.5.14.ebuild
+++ b/app-laptop/acerhk/acerhk-0.5.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.14.ebuild,v 1.1 2004/08/26 08:12:23 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.14.ebuild,v 1.2 2004/11/25 23:16:23 sekretarz Exp $
inherit kernel-mod eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.informatik.hu-berlin.de/~tauber/acerhk/archives/acerhk-${PV}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND="virtual/kernel"
diff --git a/app-laptop/acerhk/acerhk-0.5.18.ebuild b/app-laptop/acerhk/acerhk-0.5.18.ebuild
new file mode 100644
index 000000000000..a91be00d0b48
--- /dev/null
+++ b/app-laptop/acerhk/acerhk-0.5.18.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.18.ebuild,v 1.1 2004/11/25 23:16:23 sekretarz Exp $
+
+inherit kernel-mod eutils
+
+DESCRIPTION="Hotkey driver for some Acer and Acer-like laptops"
+HOMEPAGE="http://www.informatik.hu-berlin.de/~tauber/acerhk/"
+SRC_URI="http://www.informatik.hu-berlin.de/~tauber/acerhk/archives/acerhk-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="virtual/kernel"
+RDEPEND=""
+
+src_compile() {
+ unset ARCH
+ emake || die
+}
+
+src_install() {
+ kernel-mod_getversion
+ if [ ${KV_MINOR} -gt 4 ]
+ then
+ KV_OBJ="ko"
+ else
+ KV_OBJ="o"
+ fi
+
+ insinto /lib/modules/${KV}/extra
+ doins acerhk.${KV_OBJ}
+
+ dodoc README COPYING NEWS doc/*
+}
+pkg_postinst() {
+ kernel-mod_getversion
+ if [ ${KV_MINOR} -gt 4 ]
+ then
+ KV_OBJ="ko"
+ else
+ KV_OBJ="o"
+ fi
+
+ echo
+ einfo "Checking kernel module dependancies"
+ test -r "${ROOT}/usr/src/linux/System.map" && \
+ depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
+
+ einfo "You can load the module:"
+ einfo "% modprobe acerhk poll=1"
+ echo
+ einfo "If you need more info about this driver you can read the README file"
+ einfo "% zmore /usr/share/doc/${PN}-${PV}/README.gz"
+}
diff --git a/app-laptop/acerhk/files/digest-acerhk-0.5.18 b/app-laptop/acerhk/files/digest-acerhk-0.5.18
new file mode 100644
index 000000000000..d93ee62645dd
--- /dev/null
+++ b/app-laptop/acerhk/files/digest-acerhk-0.5.18
@@ -0,0 +1 @@
+MD5 16f838f257748ea133dcff74e4502755 acerhk-0.5.18.tar.bz2 27583