summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-12-14 09:57:41 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-12-14 09:57:41 +0000
commit6a47506a9678d5e49aac868d633342966fd63afc (patch)
treeacd1296d13cd746536f97634abe3c4f12c7b672d /app-laptop
parentAdded patches to build on FreeBSD and with GCC4, and be cross-distcc friendly. (diff)
downloadgentoo-2-6a47506a9678d5e49aac868d633342966fd63afc.tar.gz
gentoo-2-6a47506a9678d5e49aac868d633342966fd63afc.tar.bz2
gentoo-2-6a47506a9678d5e49aac868d633342966fd63afc.zip
Version bump.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tp_smapi/ChangeLog7
-rw-r--r--app-laptop/tp_smapi/Manifest4
-rw-r--r--app-laptop/tp_smapi/files/digest-tp_smapi-0.101
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.10.ebuild37
4 files changed, 47 insertions, 2 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index 96966a3c5cc6..8678db435313 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tp_smapi
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.1 2005/12/13 20:40:18 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.2 2005/12/14 09:57:41 brix Exp $
+
+*tp_smapi-0.10 (14 Dec 2005)
+
+ 14 Dec 2005; Henrik Brix Andersen <brix@gentoo.org> +tp_smapi-0.10.ebuild:
+ Version bump.
*tp_smapi-0.09 (13 Dec 2005)
diff --git a/app-laptop/tp_smapi/Manifest b/app-laptop/tp_smapi/Manifest
index c7d510ef7738..ce05b53d1423 100644
--- a/app-laptop/tp_smapi/Manifest
+++ b/app-laptop/tp_smapi/Manifest
@@ -1,4 +1,6 @@
MD5 666f60fc9240a3097a5c69f242dfab90 tp_smapi-0.09.ebuild 758
-MD5 6ce08e5fc5e78352e949119b98505fee ChangeLog 352
+MD5 157481d0aa221a53e7cc7b94e923881e tp_smapi-0.10.ebuild 658
+MD5 01a2e22aa1531fec5f29b5e701d660b9 ChangeLog 476
MD5 b280eebc74d70d85e664debf1adce2c3 metadata.xml 255
MD5 4d7f53e3ed49793eab511c3f2b3bddb4 files/digest-tp_smapi-0.09 61
+MD5 f18aaa92ad22a269103dbf2c2e1b456b files/digest-tp_smapi-0.10 61
diff --git a/app-laptop/tp_smapi/files/digest-tp_smapi-0.10 b/app-laptop/tp_smapi/files/digest-tp_smapi-0.10
new file mode 100644
index 000000000000..71117e0ddbe2
--- /dev/null
+++ b/app-laptop/tp_smapi/files/digest-tp_smapi-0.10
@@ -0,0 +1 @@
+MD5 9a151082327486d56f7b314f578b554d tp_smapi-0.10.tgz 13051
diff --git a/app-laptop/tp_smapi/tp_smapi-0.10.ebuild b/app-laptop/tp_smapi/tp_smapi-0.10.ebuild
new file mode 100644
index 000000000000..d55d0baf35ea
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.10.ebuild,v 1.1 2005/12/14 09:57:41 brix Exp $
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="http://tpctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+BUILD_TARGETS="default"
+MODULE_NAMES="tp_smapi(extra:)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 13; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.13 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc CHANGES README
+}