summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-10-29 20:28:43 +0000
committerOlivier Crête <tester@gentoo.org>2008-10-29 20:28:43 +0000
commit36f9fdc5592398da6691f9f4a1b8e70728ca50a9 (patch)
treea9b75780a5267cefd57e76604d52c3ce6563ee2e /app-laptop
parentVersion bump that works with newer ffmpeg. Fixes bug #218091, #242946. Thanks... (diff)
downloadgentoo-2-36f9fdc5592398da6691f9f4a1b8e70728ca50a9.tar.gz
gentoo-2-36f9fdc5592398da6691f9f4a1b8e70728ca50a9.tar.bz2
gentoo-2-36f9fdc5592398da6691f9f4a1b8e70728ca50a9.zip
Fix init script, fixes bug #216742
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/i8kutils/ChangeLog10
-rw-r--r--app-laptop/i8kutils/files/i8k.init-r150
-rw-r--r--app-laptop/i8kutils/i8kutils-1.25-r1.ebuild44
3 files changed, 102 insertions, 2 deletions
diff --git a/app-laptop/i8kutils/ChangeLog b/app-laptop/i8kutils/ChangeLog
index 6b921a575ed3..c2243ece657e 100644
--- a/app-laptop/i8kutils/ChangeLog
+++ b/app-laptop/i8kutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/i8kutils
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/ChangeLog,v 1.15 2007/04/21 23:10:58 tester Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/ChangeLog,v 1.16 2008/10/29 20:28:43 tester Exp $
+
+*i8kutils-1.25-r1 (29 Oct 2008)
+
+ 29 Oct 2008; Olivier Crête <tester@gentoo.org> +files/i8k.init-r1,
+ +i8kutils-1.25-r1.ebuild:
+ Fix init script, fixes bug #216742
21 Apr 2007; Olivier Crête <tester@gentoo.org> i8kutils-1.25.ebuild:
Use newconfd/newinitd (bug #174266)
diff --git a/app-laptop/i8kutils/files/i8k.init-r1 b/app-laptop/i8kutils/files/i8k.init-r1
new file mode 100644
index 000000000000..21211b0538b7
--- /dev/null
+++ b/app-laptop/i8kutils/files/i8k.init-r1
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+
+depend() {
+ after alsasound
+ after modules
+}
+
+checkconfig() {
+ if [ ! -e /proc/i8k ] ; then
+ eerror "The i8k driver is not installed"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ if [ -n "$VOLUME_UP$VOLUME_DOWN$VOLUME_MUTE" ] ; then
+ ebegin "Starting i8kbuttons"
+ start-stop-daemon --start --quiet --pidfile /var/run/i8kbuttons.pid \
+ --make-pidfile --exec /usr/bin/i8kbuttons --background \
+ -- ${VOLUME_UP:+-u "${VOLUME_UP}"} \
+ ${VOLUME_DOWN:+-d "$VOLUME_DOWN"} \
+ ${VOLUME_MUTE:+-m "$VOLUME_MUTE"} \
+ ${BUTTON_REPEAT:+-r "$BUTTON_REPEAT"}
+ eend $?
+ fi
+ if [ ! -n "$NOMON" ]; then
+ ebegin "Starting i8kmon"
+ start-stop-daemon --start -b --quiet \
+ --pidfile /var/run/i8kmon.pid \
+ --make-pidfile \
+ --exec /usr/bin/i8kmon --background \
+ --name "tclsh /usr/bin/i8kmon" \
+ -- -d ${NOAUTO:+-na} ${TIMEOUT:+-t $TIMEOUT}
+ eend $?
+ fi
+}
+
+stop() {
+ if [ -n "$VOLUME_UP$VOLUME_DOWN$VOLUME_MUTE" ] ; then
+ ebegin "Stopping i8kbuttons"
+ start-stop-daemon --stop --quiet --pidfile /var/run/i8kbuttons.pid
+ eend $?
+ fi
+ if [ ! -n "$NOMON" ]; then
+ ebegin "Stopping i8kmon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/i8kmon.pid
+ eend $?
+ fi
+}
diff --git a/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild b/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild
new file mode 100644
index 000000000000..dad2cbb960d3
--- /dev/null
+++ b/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/i8kutils-1.25-r1.ebuild,v 1.1 2008/10/29 20:28:43 tester Exp $
+
+DESCRIPTION="Dell Inspiron and Latitude utilities"
+HOMEPAGE="http://people.debian.org/~dz/i8k/"
+SRC_URI="http://people.debian.org/~dz/i8k/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="tk"
+
+DEPEND="virtual/libc
+ tk? ( >=dev-lang/tk-8.3.3 )"
+
+src_compile() {
+ make all || die
+}
+
+src_install() {
+ dobin i8kbuttons i8kctl
+ doman i8kbuttons.1 i8kctl.1
+ dosym /usr/bin/i8kctl /usr/bin/i8kfan
+ dodoc README.i8kutils
+ docinto examples/
+ dodoc examples/*
+
+ newinitd ${FILESDIR}/i8k.init-r1 i8k
+ newconfd ${FILESDIR}/i8k.conf i8k
+
+ if use tk
+ then
+ dobin i8kmon
+ doman i8kmon.1
+ docinto /
+ dodoc i8kmon.conf
+ else
+ echo >> ${D}/etc/conf.d/i8k
+ echo '# i8kmon disabled because the package was installed without USE=tk' >> ${D}/etc/conf.d/i8k
+ echo 'NOMON=1' >> ${D}/etc/conf.d/i8k
+ fi
+
+}