summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-03-12 01:56:04 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-03-12 01:56:04 +0000
commitbe8e74922c0229cceccf56bacbc17e5fbf390909 (patch)
tree945bc75fb72fccf4432d7f4faa8b23583e0eb2c5 /app-laptop/pbbuttonsd
parentAdd ~alpha + ~ia64 keywords. (diff)
downloadgentoo-2-be8e74922c0229cceccf56bacbc17e5fbf390909.tar.gz
gentoo-2-be8e74922c0229cceccf56bacbc17e5fbf390909.tar.bz2
gentoo-2-be8e74922c0229cceccf56bacbc17e5fbf390909.zip
New version of pbbuttonsd, supports the MacBook and MacBook Pro.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog7
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.03
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.8.0.ebuild100
3 files changed, 109 insertions, 1 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index f3155b954d9b..4b00f7676d29 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.60 2007/01/23 16:19:30 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.61 2007/03/12 01:56:04 josejx Exp $
+
+*pbbuttonsd-0.8.0 (12 Mar 2007)
+
+ 12 Mar 2007; Joseph Jezak <josejx@gentoo.org> +pbbuttonsd-0.8.0.ebuild:
+ New version of pbbuttonsd, supports the MacBook and MacBook Pro.
23 Jan 2007; Marius Mauch <genone@gentoo.org> pbbuttonsd-0.6.6.ebuild,
pbbuttonsd-0.7.4.ebuild, pbbuttonsd-0.7.8.ebuild, pbbuttonsd-0.7.9.ebuild:
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.0 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.0
new file mode 100644
index 000000000000..f45dd6e51e01
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.0
@@ -0,0 +1,3 @@
+MD5 11c218e54ceb08deaf6111bd82538dbf pbbuttonsd-0.8.0.tar.gz 590755
+RMD160 f2dfeedb6e0316b1fd820202f9f4eb69f12a48ed pbbuttonsd-0.8.0.tar.gz 590755
+SHA256 7efa5efdc2e08b4ed650de32252fd54af0142b10ddaacd08f3bb92b264b484db pbbuttonsd-0.8.0.tar.gz 590755
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.0.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.0.ebuild
new file mode 100644
index 000000000000..33665a84bb5c
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.8.0.ebuild,v 1.1 2007/03/12 01:56:04 josejx Exp $
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Handles power management and special keys on laptops."
+HOMEPAGE="http://pbbuttons.berlios.de"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="acpi alsa debug doc ibam macbook oss"
+
+DEPEND="macbook? ( sys-libs/libsmbios )
+ >=dev-libs/glib-2.6
+ doc? ( app-doc/doxygen )"
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
+ >=dev-libs/glib-2.6"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ eautoconf
+}
+
+src_compile() {
+ # Fix crash bug on some systems
+ replace-flags -O? -O1
+
+ if use macbook; then
+ laptop=macbook
+ elif use x86 || use amd64; then
+ if use acpi; then
+ laptop=acpi
+ else
+ laptop=i386
+ fi
+ # Default to PowerBook
+ else
+ laptop=powerbook
+ fi
+
+ econf laptop=$laptop \
+ $(use_enable debug) \
+ $(use_with doc doxygen_docs) \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with ibam) \
+ || die "Sorry, failed to configure pbbuttonsd"
+
+ # Thanks to Stefan Bruda for this workaround
+ # Using -j1 fixes a parallel build issue with the docs
+ if use doc; then
+ emake -j1 || die "Sorry, failed to compile pbbuttonsd"
+ else
+ emake || die "Sorry, failed to compile pbbuttonsd"
+ fi
+}
+
+src_install() {
+ dodir /etc/power
+ use ibam && dodir /var/lib/ibam
+ make DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+ use doc && dohtml -r doc/*
+}
+
+pkg_postinst() {
+ if [ -e /etc/pbbuttonsd.conf ]; then
+ ewarn "The pbbuttonsd.cnf file replaces /etc/pbuttonsd.conf with a new"
+ ewarn "file (/etc/pbbuttonsd.conf) and a new format. Please check the"
+ ewarn "manual page with 'man pbbuttonsd.cnf' for details."
+ ewarn
+ fi
+
+ if use macbook; then
+ ewarn "Macbook and Macbook Pro users should make sure to have applesmc"
+ ewarn "loaded before starting pbbuttonsdm otherwise auto-adjustments"
+ ewarn "will not work and pbbuttonsd may segfault."
+ fi
+
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work. SysV IPC is also required."
+ ewarn
+ ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
+ ewarn "input from one user. You can set the userallowed option in"
+ ewarn "/etc/pbbuttonsd.conf to limit access."
+ ewarn
+
+ if use ibam; then
+ elog "To properly initialize the IBaM battery database, you will"
+ elog "need to perform a full discharge/charge cycle. For more"
+ elog "details, please see the pbbuttonsd man page."
+ elog
+ fi
+}