summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-13 10:13:40 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-13 10:13:40 +0000
commita3d714e9127412dce43952c4a012b8f07911f503 (patch)
treec1ca0352e52878f1f75e814df114de45379fc07e /app-laptop/acerhk/acerhk-0.5.33.ebuild
parentStable on hppa. See bug #128647. (diff)
downloadgentoo-2-a3d714e9127412dce43952c4a012b8f07911f503.tar.gz
gentoo-2-a3d714e9127412dce43952c4a012b8f07911f503.tar.bz2
gentoo-2-a3d714e9127412dce43952c4a012b8f07911f503.zip
Version bump, remove old
(Portage version: 2.1_pre10-r4)
Diffstat (limited to 'app-laptop/acerhk/acerhk-0.5.33.ebuild')
-rw-r--r--app-laptop/acerhk/acerhk-0.5.33.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-laptop/acerhk/acerhk-0.5.33.ebuild b/app-laptop/acerhk/acerhk-0.5.33.ebuild
new file mode 100644
index 000000000000..a7ab5818813d
--- /dev/null
+++ b/app-laptop/acerhk/acerhk-0.5.33.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.33.ebuild,v 1.1 2006/05/13 10:13:40 genstef Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Hotkey driver for some Acer and Acer-like laptops"
+HOMEPAGE="http://www.informatik.hu-berlin.de/~tauber/acerhk/"
+SRC_URI="http://www.informatik.hu-berlin.de/~tauber/acerhk/archives/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc"
+IUSE=""
+
+MODULE_NAMES="acerhk(extra:)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELSRC=${KV_DIR} KERNELVERSION=${KV_FULL}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README COPYING NEWS
+ docinto doc
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "You can load the module:"
+ einfo "% modprobe acerhk poll=1"
+ einfo "If you need poll=1 you can set it permanently in /etc/modules.d/acerhk"
+ echo
+ einfo "If you need more info about this driver you can read the README file"
+ einfo "% zmore /usr/share/doc/${PF}/README.gz"
+}