summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-06-16 16:35:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-06-16 16:35:46 +0000
commitfd916646945a98c7a77db9011dba699a4b2ff3e3 (patch)
tree7b7a4149add56375dda50ceb9bc5e0c7acb6e864 /app-i18n
parentVersion bump. Fixes ffmpeg-0.6 build failures wrt bug #324281 (diff)
downloadgentoo-2-fd916646945a98c7a77db9011dba699a4b2ff3e3.tar.gz
gentoo-2-fd916646945a98c7a77db9011dba699a4b2ff3e3.tar.bz2
gentoo-2-fd916646945a98c7a77db9011dba699a4b2ff3e3.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-skk/ChangeLog7
-rw-r--r--app-i18n/ibus-skk/ibus-skk-0.0.8.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-i18n/ibus-skk/ChangeLog b/app-i18n/ibus-skk/ChangeLog
index d9bd3f37b51e..93f21d8af50e 100644
--- a/app-i18n/ibus-skk/ChangeLog
+++ b/app-i18n/ibus-skk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-skk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.8 2010/05/26 10:40:04 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.9 2010/06/16 16:35:46 matsuu Exp $
+
+*ibus-skk-0.0.8 (16 Jun 2010)
+
+ 16 Jun 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-skk-0.0.8.ebuild:
+ Version bumped.
26 May 2010; Pacho Ramos <pacho@gentoo.org> ibus-skk-0.0.4.ebuild:
stable amd64, bug 305765
diff --git a/app-i18n/ibus-skk/ibus-skk-0.0.8.ebuild b/app-i18n/ibus-skk/ibus-skk-0.0.8.ebuild
new file mode 100644
index 000000000000..52bbd001d21e
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-0.0.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-0.0.8.ebuild,v 1.1 2010/06/16 16:35:46 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+pkg_setup() {
+ python_set_active_version 2
+
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}