summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-10-18 23:44:03 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-10-18 23:44:03 +0000
commitf230ed7f50f58177065ab94131a51bd9bb05d311 (patch)
tree44da61691f3bc6e78cfd4ba5cd42c8f2147edd30 /app-i18n
parentversion bump, bug 289070 (diff)
downloadgentoo-2-f230ed7f50f58177065ab94131a51bd9bb05d311.tar.gz
gentoo-2-f230ed7f50f58177065ab94131a51bd9bb05d311.tar.bz2
gentoo-2-f230ed7f50f58177065ab94131a51bd9bb05d311.zip
Added libgnomeui dependency. cleanup.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/im-ja/ChangeLog10
-rw-r--r--app-i18n/im-ja/files/im-ja-1.5-gentoo.patch30
-rw-r--r--app-i18n/im-ja/im-ja-1.5-r1.ebuild87
3 files changed, 125 insertions, 2 deletions
diff --git a/app-i18n/im-ja/ChangeLog b/app-i18n/im-ja/ChangeLog
index 2e21a2a46a04..387ecf8bf9e2 100644
--- a/app-i18n/im-ja/ChangeLog
+++ b/app-i18n/im-ja/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/im-ja
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-ja/ChangeLog,v 1.58 2008/07/31 10:10:23 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-ja/ChangeLog,v 1.59 2009/10/18 23:44:03 matsuu Exp $
+
+*im-ja-1.5-r1 (18 Oct 2009)
+
+ 18 Oct 2009; MATSUU Takuto <matsuu@gentoo.org> +im-ja-1.5-r1.ebuild,
+ +files/im-ja-1.5-gentoo.patch:
+ Added libgnomeui dependency. cleanup.
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-i18n/im-ja/files/im-ja-1.5-gentoo.patch b/app-i18n/im-ja/files/im-ja-1.5-gentoo.patch
new file mode 100644
index 000000000000..af78e77876fa
--- /dev/null
+++ b/app-i18n/im-ja/files/im-ja-1.5-gentoo.patch
@@ -0,0 +1,30 @@
+diff -Naur im-ja-1.5.orig/configure.in im-ja-1.5/configure.in
+--- im-ja-1.5.orig/configure.in 2006-04-18 19:52:25.000000000 +0900
++++ im-ja-1.5/configure.in 2009-10-19 08:19:22.000000000 +0900
+@@ -28,6 +28,7 @@
+ PKG_CHECK_MODULES([GTK], gtk+-2.0 >= 2.4.0)
+ PKG_CHECK_MODULES([GCONF], gconf-2.0)
+ PKG_CHECK_MODULES([LIBGLADE], libglade-2.0 >= 2.4.0)
++PKG_CHECK_MODULES([LIBGNOMEUI], libgnomeui-2.0 >= 2.4.0)
+
+ AM_GCONF_SOURCE_2
+
+diff -Naur im-ja-1.5.orig/src/gnome-panel-applet/Makefile.am im-ja-1.5/src/gnome-panel-applet/Makefile.am
+--- im-ja-1.5.orig/src/gnome-panel-applet/Makefile.am 2006-04-18 19:52:24.000000000 +0900
++++ im-ja-1.5/src/gnome-panel-applet/Makefile.am 2009-10-19 08:21:24.000000000 +0900
+@@ -26,13 +26,14 @@
+ -DIM_JA_LIBPROGDIR=\"$(libprogdir)\" \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ $(LIBPANELAPPLET_CFLAGS) \
++ $(LIBGNOMEUI_CFLAGS) \
+ @DEBUG_FLAGS@ \
+ @DISABLE_CANNA_FLAG@ \
+ @DISABLE_ANTHY_FLAG@ \
+ @DISABLE_SKK_FLAG@ \
+ @DISABLE_WNN_FLAG@
+
+-im_ja_applet_LDADD = $(LIBPANELAPPLET_LIBS)
++im_ja_applet_LDADD = $(LIBPANELAPPLET_LIBS) $(LIBGNOMEUI_LIBS)
+
+ uidir = $(datadir)/gnome-2.0/ui
+ ui_DATA = GNOME_ImJaApplet.xml
diff --git a/app-i18n/im-ja/im-ja-1.5-r1.ebuild b/app-i18n/im-ja/im-ja-1.5-r1.ebuild
new file mode 100644
index 000000000000..4787ec56504c
--- /dev/null
+++ b/app-i18n/im-ja/im-ja-1.5-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-ja/im-ja-1.5-r1.ebuild,v 1.1 2009/10/18 23:44:03 matsuu Exp $
+
+inherit autotools gnome2 eutils multilib
+
+DESCRIPTION="A Japanese input module for GTK2 and XIM"
+HOMEPAGE="http://im-ja.sourceforge.net/"
+SRC_URI="http://im-ja.sourceforge.net/${P}.tar.gz
+ http://im-ja.sourceforge.net/old/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="gnome canna freewnn skk anthy"
+# --enable-debug causes build failure with gtk+-2.4
+#IUSE="${IUSE} debug"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=dev-libs/atk-1.6
+ >=x11-libs/gtk+-2.4
+ >=x11-libs/pango-1.2.1
+ >=gnome-base/gconf-2.4
+ >=gnome-base/libglade-2.4
+ >=gnome-base/libgnomeui-2.4
+ gnome? ( >=gnome-base/gnome-panel-2.0 )
+ freewnn? ( app-i18n/freewnn )
+ canna? ( app-i18n/canna )
+ skk? ( virtual/skkserv )
+ anthy? ( app-i18n/anthy )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-perl/URI
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS README ChangeLog TODO"
+
+pkg_config() {
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR="${GTK2_CONFDIR:=/etc/gtk-2.0}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+ # You cannot use `use_enable ...` here. im-ja's configure script
+ # doesn't distinguish --enable-canna from --disable-canna, so
+ # --enable-canna stands for --disable-canna in the script ;-(
+ use gnome || myconf="$myconf --disable-gnome"
+ use canna || myconf="$myconf --disable-canna"
+ use freewnn || myconf="$myconf --disable-wnn"
+ use anthy || myconf="$myconf --disable-anthy"
+ use skk || myconf="$myconf --disable-skk"
+ #use debug && myconf="$myconf --enable-debug"
+
+ # gnome2_src_compile automatically sets debug IUSE flag
+ econf $myconf || die "econf im-ja failed"
+ emake || die "emake im-ja failed"
+}
+
+pkg_postinst() {
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+ fi
+ gnome2_pkg_postinst
+ elog
+ elog "This version of im-ja comes with experimental XIM support."
+ elog "If you'd like to try it out, run im-ja-xim-server and set"
+ elog "environment variable XMODIFIERS to @im=im-ja-xim-server"
+ elog "e.g.)"
+ elog "\t$ export XMODIFIERS=@im=im-ja-xim-server (sh)"
+ elog "\t> setenv XMODIFIERS @im=im-ja-xim-server (csh)"
+ elog
+}
+
+pkg_postrm() {
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+ fi
+ gnome2_pkg_postrm
+}