summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-10 11:49:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-10 11:49:41 +0000
commite7bb0558244d4810dd249b9fb8c68b2f188a73dd (patch)
tree9b786e0fed071beb21a73f9ccc70d27178aa3f18 /app-i18n
parentmysql-python bump for python 2.6 compatibility (diff)
downloadgentoo-2-e7bb0558244d4810dd249b9fb8c68b2f188a73dd.tar.gz
gentoo-2-e7bb0558244d4810dd249b9fb8c68b2f188a73dd.tar.bz2
gentoo-2-e7bb0558244d4810dd249b9fb8c68b2f188a73dd.zip
Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #277565.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/x-unikey/ChangeLog8
-rw-r--r--app-i18n/x-unikey/files/x-unikey-1.0.4-gcc44.patch31
-rw-r--r--app-i18n/x-unikey/x-unikey-1.0.4-r1.ebuild9
3 files changed, 42 insertions, 6 deletions
diff --git a/app-i18n/x-unikey/ChangeLog b/app-i18n/x-unikey/ChangeLog
index a3d5ed15616c..558e94158606 100644
--- a/app-i18n/x-unikey/ChangeLog
+++ b/app-i18n/x-unikey/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/x-unikey
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/ChangeLog,v 1.20 2008/12/31 14:28:43 matsuu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/ChangeLog,v 1.21 2009/08/10 11:49:41 ssuominen Exp $
+
+ 10 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ x-unikey-1.0.4-r1.ebuild, +files/x-unikey-1.0.4-gcc44.patch:
+ Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #277565.
*x-unikey-1.0.4-r1 (31 Dec 2008)
diff --git a/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc44.patch b/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc44.patch
new file mode 100644
index 000000000000..5e59ca131b70
--- /dev/null
+++ b/app-i18n/x-unikey/files/x-unikey-1.0.4-gcc44.patch
@@ -0,0 +1,31 @@
+diff -ur x-unikey-1.0.4.orig/src/ukengine/mactab.cpp x-unikey-1.0.4/src/ukengine/mactab.cpp
+--- x-unikey-1.0.4.orig/src/ukengine/mactab.cpp 2006-04-09 14:46:02.000000000 +0300
++++ x-unikey-1.0.4/src/ukengine/mactab.cpp 2009-08-10 14:50:50.000000000 +0300
+@@ -287,7 +287,7 @@
+ char key[MAX_MACRO_KEY_LEN];
+
+ // Parse the input item
+- char * pos = strchr(item, ':');
++ const char * pos = strchr(item, ':');
+ if (pos == NULL)
+ return -1;
+ int keyLen = (int)(pos - item);
+diff -ur x-unikey-1.0.4.orig/src/ukengine/usrkeymap.cpp x-unikey-1.0.4/src/ukengine/usrkeymap.cpp
+--- x-unikey-1.0.4.orig/src/ukengine/usrkeymap.cpp 2006-04-09 02:31:40.000000000 +0300
++++ x-unikey-1.0.4/src/ukengine/usrkeymap.cpp 2009-08-10 14:48:44.000000000 +0300
+@@ -21,6 +21,8 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
++#include <stdio.h>
++
+ #include "stdafx.h"
+ #include <iostream>
+ using namespace std;
+@@ -262,4 +264,4 @@
+ return i;
+ }
+ return -1;
+-}
+\ No newline at end of file
++}
diff --git a/app-i18n/x-unikey/x-unikey-1.0.4-r1.ebuild b/app-i18n/x-unikey/x-unikey-1.0.4-r1.ebuild
index cfd9938c3ff0..c6fb5c19eaa3 100644
--- a/app-i18n/x-unikey/x-unikey-1.0.4-r1.ebuild
+++ b/app-i18n/x-unikey/x-unikey-1.0.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/x-unikey-1.0.4-r1.ebuild,v 1.1 2008/12/31 14:28:43 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/x-unikey-1.0.4-r1.ebuild,v 1.2 2009/08/10 11:49:41 ssuominen Exp $
inherit autotools eutils multilib
@@ -31,8 +31,9 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-gcc43.patch"
- epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
eautoreconf
}