summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-05-04 03:20:57 +0000
committerNaohiro Aota <naota@gentoo.org>2013-05-04 03:20:57 +0000
commitd992f838154016f8307e086936e6ce9df1c5162d (patch)
tree398c3df66aad45d0b3b76c6dee987ebeaa652eb2 /app-i18n
parentAdd ~x86-fbsd #465136 (diff)
downloadgentoo-2-d992f838154016f8307e086936e6ce9df1c5162d.tar.gz
gentoo-2-d992f838154016f8307e086936e6ce9df1c5162d.tar.bz2
gentoo-2-d992f838154016f8307e086936e6ce9df1c5162d.zip
Version bump wrt #465204
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/mozc/ChangeLog8
-rw-r--r--app-i18n/mozc/files/mozc-1.10.1390.102-drop-Werror.patch12
-rw-r--r--app-i18n/mozc/mozc-1.10.1390.102.ebuild175
3 files changed, 194 insertions, 1 deletions
diff --git a/app-i18n/mozc/ChangeLog b/app-i18n/mozc/ChangeLog
index 34c4ee1a9691..ad9286481404 100644
--- a/app-i18n/mozc/ChangeLog
+++ b/app-i18n/mozc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/mozc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/mozc/ChangeLog,v 1.4 2013/03/02 19:28:02 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/mozc/ChangeLog,v 1.5 2013/05/04 03:20:57 naota Exp $
+
+*mozc-1.10.1390.102 (04 May 2013)
+
+ 04 May 2013; Naohiro Aota <naota@gentoo.org>
+ +files/mozc-1.10.1390.102-drop-Werror.patch, +mozc-1.10.1390.102.ebuild:
+ Version bump wrt #465204
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> mozc-1.3.975.102.ebuild,
mozc-1.5.1090.102.ebuild, mozc-1.6.1187.102.ebuild:
diff --git a/app-i18n/mozc/files/mozc-1.10.1390.102-drop-Werror.patch b/app-i18n/mozc/files/mozc-1.10.1390.102-drop-Werror.patch
new file mode 100644
index 000000000000..e254f38b8745
--- /dev/null
+++ b/app-i18n/mozc/files/mozc-1.10.1390.102-drop-Werror.patch
@@ -0,0 +1,12 @@
+diff --git a/gyp/common.gypi b/gyp/common.gypi
+index 6c176ff..3613b1b 100755
+--- a/gyp/common.gypi
++++ b/gyp/common.gypi
+@@ -58,7 +58,6 @@
+ # warning_cflags will be shared with Mac and Linux.
+ 'warning_cflags': [
+ '-Wall',
+- '-Werror',
+ '-Wno-char-subscripts',
+ '-Wno-sign-compare',
+ '-Wno-deprecated-declarations',
diff --git a/app-i18n/mozc/mozc-1.10.1390.102.ebuild b/app-i18n/mozc/mozc-1.10.1390.102.ebuild
new file mode 100644
index 000000000000..fb5b91b50fd4
--- /dev/null
+++ b/app-i18n/mozc/mozc-1.10.1390.102.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/mozc/mozc-1.10.1390.102.ebuild,v 1.1 2013/05/04 03:20:57 naota Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit elisp-common eutils multilib multiprocessing python-single-r1 toolchain-funcs
+
+DESCRIPTION="The Mozc engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/mozc/"
+
+PROTOBUF_VER="2.5.0"
+GMOCK_VER="1.6.0"
+GTEST_VER="1.6.0"
+JSONCPP_VER="0.6.0-rc2"
+MOZC_URL="http://mozc.googlecode.com/files/${P}.tar.bz2"
+PROTOBUF_URL="http://protobuf.googlecode.com/files/protobuf-${PROTOBUF_VER}.tar.bz2"
+GMOCK_URL="https://googlemock.googlecode.com/files/gmock-${GMOCK_VER}.zip"
+GTEST_URL="https://googletest.googlecode.com/files/gtest-${GTEST_VER}.zip"
+JSONCPP_URL="mirror://sourceforge/jsoncpp/jsoncpp-src-${JSONCPP_VER}.tar.gz"
+SRC_URI="${MOZC_URL} ${PROTOBUF_URL}
+ test? ( ${GMOCK_URL} ${GTEST_URL} ${JSONCPP_URL} )"
+
+LICENSE="Apache-2.0 BSD Boost-1.0 ipadic public-domain unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ibus +qt4 renderer test"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/openssl
+ x11-libs/libxcb
+ emacs? ( virtual/emacs )
+ ibus? ( >=app-i18n/ibus-1.4.1 )
+ renderer? ( x11-libs/gtk+:2 )
+ qt4? (
+ dev-qt/qtgui:4
+ app-i18n/zinnia
+ )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ ~dev-libs/protobuf-2.4.1
+ virtual/pkgconfig"
+
+BUILDTYPE="${BUILDTYPE:-Release}"
+
+RESTRICT="test"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack $(basename ${MOZC_URL})
+
+ cd "${S}"/protobuf
+ unpack $(basename ${PROTOBUF_URL})
+ mv protobuf-${PROTOBUF_VER} files || die
+
+ if use test; then
+ cd "${S}"/third_party
+ unpack $(basename ${GMOCK_URL}) $(basename ${GTEST_URL}) \
+ $(basename ${JSONCPP_URL})
+ mv gmock-${GMOCK_VER} gmock || die
+ mv gtest-${GTEST_VER} gtest || die
+ mv jsoncpp-src-${JSONCPP_VER} jsoncpp || die
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-drop-Werror.patch
+}
+
+src_configure() {
+ local myconf="--server_dir=/usr/$(get_libdir)/mozc"
+
+ if ! use qt4 ; then
+ myconf+=" --noqt"
+ export GYP_DEFINES="use_libzinnia=0"
+ fi
+
+ if ! use renderer ; then
+ export GYP_DEFINES="${GYP_DEFINES} enable_gtk_renderer=0"
+ fi
+
+ # export GYP_DEFINES="${GYP_DEFINES} use_libprotobuf=1"
+
+ "${PYTHON}" build_mozc.py gyp ${myconf} || die "gyp failed"
+}
+
+src_compile() {
+ tc-export CC CXX AR AS RANLIB LD
+
+ local my_makeopts=$(makeopts_jobs)
+ # This is for a safety. -j without a number, makeopts_jobs returns 999.
+ local myjobs=-j${my_makeopts/999/1}
+
+ local mytarget="server/server.gyp:mozc_server"
+ use emacs && mytarget="${mytarget} unix/emacs/emacs.gyp:mozc_emacs_helper"
+ use ibus && mytarget="${mytarget} unix/ibus/ibus.gyp:ibus_mozc"
+ use renderer && mytarget="${mytarget} renderer/renderer.gyp:mozc_renderer"
+ if use qt4 ; then
+ export QTDIR="${EPREFIX}/usr"
+ mytarget="${mytarget} gui/gui.gyp:mozc_tool"
+ fi
+
+ V=1 "${PYTHON}" build_mozc.py build_tools -c "${BUILDTYPE}" ${myjobs} || die
+ V=1 "${PYTHON}" build_mozc.py build -c "${BUILDTYPE}" ${mytarget} ${myjobs} || die
+
+ if use emacs ; then
+ elisp-compile unix/emacs/*.el || die
+ fi
+}
+
+src_test() {
+ tc-export CC CXX AR AS RANLIB LD
+ V=1 "${PYTHON}" build_mozc.py runtests -c "${BUILDTYPE}" || die
+}
+
+src_install() {
+ if use emacs ; then
+ dobin "out_linux/${BUILDTYPE}/mozc_emacs_helper" || die
+ elisp-install ${PN} unix/emacs/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" ${PN} || die
+ fi
+
+ if use ibus ; then
+ exeinto /usr/libexec || die
+ newexe "out_linux/${BUILDTYPE}/ibus_mozc" ibus-engine-mozc || die
+ insinto /usr/share/ibus/component || die
+ doins "out_linux/${BUILDTYPE}/obj/gen/unix/ibus/mozc.xml" || die
+ insinto /usr/share/ibus-mozc || die
+ (
+ cd data/images/unix
+ newins ime_product_icon_opensource-32.png product_icon.png || die
+ for f in ui-*
+ do
+ newins ${f} ${f/ui-} || die
+ done
+ )
+
+ fi
+
+ exeinto "/usr/$(get_libdir)/mozc" || die
+ doexe "out_linux/${BUILDTYPE}/mozc_server" || die
+
+ if use qt4 ; then
+ exeinto "/usr/$(get_libdir)/mozc" || die
+ doexe "out_linux/${BUILDTYPE}/mozc_tool" || die
+ fi
+
+ if use renderer ; then
+ exeinto "/usr/$(get_libdir)/mozc" || die
+ doexe "out_linux/${BUILDTYPE}/mozc_renderer" || die
+ fi
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elisp-site-regen
+ elog "You can use mozc-mode via LEIM (Library of Emacs Input Method)."
+ elog "Write the following settings into your init file (~/.emacs.d/init.el"
+ elog "or ~/.emacs) in order to use mozc-mode by default, or you can call"
+ elog "\`set-input-method' and set \"japanese-mozc\" anytime you have loaded"
+ elog "mozc.el"
+ elog
+ elog " (require 'mozc)"
+ elog " (set-language-environment \"Japanese\")"
+ elog " (setq default-input-method \"japanese-mozc\")"
+ elog
+ elog "Having the above settings, just type C-\\ which is bound to"
+ elog "\`toggle-input-method' by default."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}