summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-05-01 11:21:02 +0000
committerMamoru Komachi <usata@gentoo.org>2004-05-01 11:21:02 +0000
commitcf84d7f6c94fafa5362cfaba3ee1b52167908ab4 (patch)
tree9147634a7bf54a4ee5f1062aa248f2e9a90d08bc /app-i18n
parentNew ebuild. (diff)
downloadgentoo-2-cf84d7f6c94fafa5362cfaba3ee1b52167908ab4.tar.gz
gentoo-2-cf84d7f6c94fafa5362cfaba3ee1b52167908ab4.tar.bz2
gentoo-2-cf84d7f6c94fafa5362cfaba3ee1b52167908ab4.zip
Initial import.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/uim-fep/ChangeLog9
-rw-r--r--app-i18n/uim-fep/Manifest2
-rw-r--r--app-i18n/uim-fep/files/digest-uim-fep-0.1.91
-rw-r--r--app-i18n/uim-fep/metadata.xml5
-rw-r--r--app-i18n/uim-fep/uim-fep-0.1.9.ebuild45
5 files changed, 62 insertions, 0 deletions
diff --git a/app-i18n/uim-fep/ChangeLog b/app-i18n/uim-fep/ChangeLog
new file mode 100644
index 000000000000..749d18f89f0f
--- /dev/null
+++ b/app-i18n/uim-fep/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-i18n/uim-fep
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim-fep/ChangeLog,v 1.1 2004/05/01 11:21:02 usata Exp $
+
+*uim-fep-0.1.9 (01 May 2004)
+
+ 01 May 2004; Mamoru KOMACHI <usata@gentoo.org> uim-fep-0.1.9.ebuild:
+ Initial import.
+
diff --git a/app-i18n/uim-fep/Manifest b/app-i18n/uim-fep/Manifest
new file mode 100644
index 000000000000..ee1144c9496a
--- /dev/null
+++ b/app-i18n/uim-fep/Manifest
@@ -0,0 +1,2 @@
+MD5 86d103beea57276a473d001c7465c9e0 uim-fep-0.1.9.ebuild 1015
+MD5 2e0247f5f2356caf639016b4d4313d6e files/digest-uim-fep-0.1.9 64
diff --git a/app-i18n/uim-fep/files/digest-uim-fep-0.1.9 b/app-i18n/uim-fep/files/digest-uim-fep-0.1.9
new file mode 100644
index 000000000000..591cbdfbadc0
--- /dev/null
+++ b/app-i18n/uim-fep/files/digest-uim-fep-0.1.9
@@ -0,0 +1 @@
+MD5 d1d62ed5433dca31e818e80465a96fcb uim-fep-0.1.9.tar.gz 79731
diff --git a/app-i18n/uim-fep/metadata.xml b/app-i18n/uim-fep/metadata.xml
new file mode 100644
index 000000000000..2d5852c16c60
--- /dev/null
+++ b/app-i18n/uim-fep/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>
diff --git a/app-i18n/uim-fep/uim-fep-0.1.9.ebuild b/app-i18n/uim-fep/uim-fep-0.1.9.ebuild
new file mode 100644
index 000000000000..4246f1a437b5
--- /dev/null
+++ b/app-i18n/uim-fep/uim-fep-0.1.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim-fep/uim-fep-0.1.9.ebuild,v 1.1 2004/05/01 11:21:02 usata Exp $
+
+IUSE="unicode"
+
+DESCRIPTION="UIM multilingual input method frontend processor for console"
+HOMEPAGE="http://www.ice.nuie.nagoya-u.ac.jp/~h013177b/uim-fep/"
+SRC_URI="http://www.ice.nuie.nagoya-u.ac.jp/~h013177b/uim-fep/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=app-i18n/uim-0.3.4.2
+ sys-libs/ncurses"
+
+src_compile() {
+
+ local myconf
+ if use unicode ; then
+ myconf="${myconf} --with-enc=utf-8"
+ else
+ myconf="${myconf} --with-enc=euc-jp"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc README COPYING INSTALL
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "uim-fep is configured for skk. If you want to change it, you can set"
+ einfo "UIM_FEP environment variable to one of skk, prime, anthy, canna,"
+ einfo "tcode and tutcode or run uim-fep with -u option with engines listed above."
+ einfo
+}