summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-08-19 08:47:40 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-08-19 08:47:40 +0000
commitbd29ef400c3102623f1feee13596fd8efe3db0b3 (patch)
treea25598092dd8ee6203c0f99339f060019f59e5b8 /app-i18n
parentamd64 x86 and ppc stable wrt bug#431902. (diff)
downloadgentoo-2-bd29ef400c3102623f1feee13596fd8efe3db0b3.tar.gz
gentoo-2-bd29ef400c3102623f1feee13596fd8efe3db0b3.tar.bz2
gentoo-2-bd29ef400c3102623f1feee13596fd8efe3db0b3.zip
ppc stable wrt bug#431902. Fix automagic fetching during build (already fixed in testing ebuilds).
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx/ChangeLog6
-rw-r--r--app-i18n/fcitx/fcitx-4.2.1.ebuild16
2 files changed, 18 insertions, 4 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index 3ef9c20c16d0..5524e9ae8fee 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/fcitx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.50 2012/07/19 07:43:11 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.51 2012/08/19 08:47:40 scarabeus Exp $
+
+ 19 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> fcitx-4.2.1.ebuild:
+ ppc stable wrt bug#431902. Fix automagic fetching during build (already fixed
+ in testing ebuilds).
*fcitx-4.2.5 (19 Jul 2012)
diff --git a/app-i18n/fcitx/fcitx-4.2.1.ebuild b/app-i18n/fcitx/fcitx-4.2.1.ebuild
index d395a867862b..e0b78911cc9e 100644
--- a/app-i18n/fcitx/fcitx-4.2.1.ebuild
+++ b/app-i18n/fcitx/fcitx-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.2.1.ebuild,v 1.8 2012/06/10 09:15:46 qiaomuf Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.2.1.ebuild,v 1.9 2012/08/19 08:47:40 scarabeus Exp $
EAPI="3"
@@ -8,11 +8,15 @@ inherit multilib cmake-utils eutils
DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
HOMEPAGE="http://www.fcitx.org/"
-SRC_URI="http://fcitx.googlecode.com/files/${P}.tar.xz"
+SRC_URI="
+ http://fcitx.googlecode.com/files/${P}.tar.xz
+ http://fcitx.googlecode.com/files/pinyin.tar.gz
+ http://fcitx.googlecode.com/files/table.tar.gz
+"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
+KEYWORDS="amd64 ppc ~ppc64 x86"
IUSE="cairo dbus debug gtk gtk3 opencc pango qt4 table"
RDEPEND="x11-libs/libX11
@@ -49,6 +53,12 @@ update_gtk3_immodules() {
fi
}
+src_unpack() {
+ unpack ${P}.tar.xz
+ cp "${DISTDIR}"/pinyin.tar.gz "${S}"/data/
+ cp "${DISTDIR}/table.tar.gz" "${S}/data/table"
+}
+
src_configure() {
local mycmakeargs="
-DLIB_INSTALL_DIR=/usr/$(get_libdir)