summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-06 16:06:03 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-06 16:06:03 +0000
commit9ca662a1385c752cd0d2f24a8b92a78a86ce707d (patch)
tree32666ab93be912be34142e37664afca38b66ee02 /app-i18n
parentRemoved RDEPEND=${DEPEND} (diff)
downloadgentoo-2-9ca662a1385c752cd0d2f24a8b92a78a86ce707d.tar.gz
gentoo-2-9ca662a1385c752cd0d2f24a8b92a78a86ce707d.tar.bz2
gentoo-2-9ca662a1385c752cd0d2f24a8b92a78a86ce707d.zip
removed rdepend=depend
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/kinput2/kinput2-3.1_beta4-r2.ebuild37
1 files changed, 12 insertions, 25 deletions
diff --git a/app-i18n/kinput2/kinput2-3.1_beta4-r2.ebuild b/app-i18n/kinput2/kinput2-3.1_beta4-r2.ebuild
index cb899166ab25..ead597c88d7a 100644
--- a/app-i18n/kinput2/kinput2-3.1_beta4-r2.ebuild
+++ b/app-i18n/kinput2/kinput2-3.1_beta4-r2.ebuild
@@ -1,34 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.6 2002/05/07 03:58:19 drobbins Exp
-
-IUSE="canna freewnn"
-
-KEYWORDS="x86"
-
-A="kinput2-v3.1-beta4.tar.gz"
-
-S="${WORKDIR}/kinput2-v3.1-beta4"
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kinput2/kinput2-3.1_beta4-r2.ebuild,v 1.5 2002/11/06 16:06:03 vapier Exp $
+MY_P="kinput2-v3.1-beta4.tar.gz"
DESCRIPTION="A Japanese input server which supports the XIM protocol"
-
-SRC_URI="ftp://ftp.sra.co.jp/pub/x11/kinput2/${A}"
-
+SRC_URI="ftp://ftp.sra.co.jp/pub/x11/kinput2/${MY_P}.tar.gz"
HOMEPAGE="http://www.nec.co.jp/canna/"
+SLOT="0"
LICENSE="as-is"
+KEYWORDS="x86"
+IUSE="canna freewnn"
DEPEND="virtual/glibc
- >=sys-apps/portage-2.0.9
canna? >=app-i18n/canna-3.5_beta2-r1
freewnn? >=app-i18n/freewnn-1.1.1_alpha19 : >=app-i18n/canna-3.5_beta2-r1"
-
-RDEPEND=${DEPEND}
-
-SLOT=0
+S="${WORKDIR}/${MY_P}"
src_unpack() {
-
# unpack the archive
unpack ${A}
@@ -44,23 +33,21 @@ src_unpack() {
# default to UseCanna if we don't have freewnn in useflags
cp Kinput2.conf Kinput2.tmp
use freewnn || sed -e "s:\/\* \#define UseCanna \*\/:\#define UseCanna:" Kinput2.tmp > Kinput2.conf || die
-
}
src_compile() {
-
# create a Makefile from Kinput2.conf
- xmkmf || die "xmkmf failed"
+ xmkmf || die "xmkmf failed"
make Makefiles || die "Makefile creation failed"
# build Kinput2
- make depend ; make
+ make depend || die "make depend failed"
+ make || die "make failed"
}
-src_install () {
-
+src_install() {
# install libs, executables, dictionaries
- make DESTDIR=${D} install || die "installation failed"
+ make DESTDIR=${D} install || die "installation failed"
# install docs
dodoc README NEWS