summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-06-09 16:26:24 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-06-09 16:26:24 +0000
commit958ec15d927b445f509e22167f10e40df0316e88 (patch)
treed9f122a367c5d762063b291ec8d70d6d020bfb2d /app-i18n
parentold (esound depracation) (diff)
downloadgentoo-2-958ec15d927b445f509e22167f10e40df0316e88.tar.gz
gentoo-2-958ec15d927b445f509e22167f10e40df0316e88.tar.bz2
gentoo-2-958ec15d927b445f509e22167f10e40df0316e88.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table/ChangeLog8
-rw-r--r--app-i18n/ibus-table/ibus-table-1.1.0.20090609.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index ea20da2874a2..6d503956bbb9 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.13 2009/06/04 16:18:27 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.14 2009/06/09 16:26:24 matsuu Exp $
+
+*ibus-table-1.1.0.20090609 (09 Jun 2009)
+
+ 09 Jun 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-1.1.0.20090609.ebuild:
+ Version bumped.
*ibus-table-1.1.0.20090603 (04 Jun 2009)
diff --git a/app-i18n/ibus-table/ibus-table-1.1.0.20090609.ebuild b/app-i18n/ibus-table/ibus-table-1.1.0.20090609.ebuild
new file mode 100644
index 000000000000..a65f484dd440
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.1.0.20090609.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090609.ebuild,v 1.1 2009/06/09 16:26:24 matsuu Exp $
+
+EAPI="2"
+inherit eutils python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal nls"
+
+RDEPEND=">=app-i18n/ibus-1.1
+ >=dev-lang/python-2.5[sqlite]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable !minimal additional) \
+ $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}