summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-01-15 08:43:46 +0000
committerNaohiro Aota <naota@gentoo.org>2013-01-15 08:43:46 +0000
commit940631c2636ef9c82193e32e56356667f5192b49 (patch)
tree202429743de2eb7785f4979627e44c67676810a9 /app-i18n
parentDisable werror. Fixes bug#451564. (diff)
downloadgentoo-2-940631c2636ef9c82193e32e56356667f5192b49.tar.gz
gentoo-2-940631c2636ef9c82193e32e56356667f5192b49.tar.bz2
gentoo-2-940631c2636ef9c82193e32e56356667f5192b49.zip
bumped #451850
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-m17n/ChangeLog10
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-1.3.4.ebuild47
2 files changed, 54 insertions, 3 deletions
diff --git a/app-i18n/ibus-m17n/ChangeLog b/app-i18n/ibus-m17n/ChangeLog
index 97ccccddd862..27e317422adf 100644
--- a/app-i18n/ibus-m17n/ChangeLog
+++ b/app-i18n/ibus-m17n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-m17n
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.23 2012/05/03 19:24:28 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.24 2013/01/15 08:43:46 naota Exp $
+
+*ibus-m17n-1.3.4 (15 Jan 2013)
+
+ 15 Jan 2013; Naohiro Aota <naota@gentoo.org> +ibus-m17n-1.3.4.ebuild:
+ bumped #451850
03 May 2012; Jeff Horelick <jdhore@gentoo.org>
ibus-m17n-1.2.0.20091217.ebuild, ibus-m17n-1.3.1.ebuild,
@@ -123,4 +128,3 @@
06 Sep 2008; MATSUU Takuto <matsuu@gentoo.org> +metadata.xml,
+ibus-m17n-0.1.1.20080901.ebuild:
Initial import.
-
diff --git a/app-i18n/ibus-m17n/ibus-m17n-1.3.4.ebuild b/app-i18n/ibus-m17n/ibus-m17n-1.3.4.ebuild
new file mode 100644
index 000000000000..b97009b3bf5d
--- /dev/null
+++ b/app-i18n/ibus-m17n/ibus-m17n-1.3.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ibus-m17n-1.3.4.ebuild,v 1.1 2013/01/15 08:43:46 naota Exp $
+
+EAPI="3"
+
+DESCRIPTION="The M17N engine IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk nls"
+
+RDEPEND=">=app-i18n/ibus-1.3.99.20110817
+ dev-libs/libxml2
+ gtk? ( >=x11-libs/gtk+-2.12.12:2 )
+ dev-libs/m17n-lib
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.16.1"
+RDEPEND="${RDEPEND}
+ dev-db/m17n-db
+ dev-db/m17n-contrib"
+# gtk? (
+# || (
+# >=x11-libs/gtk+-2.90.5:3
+# >=x11-libs/gtk+-2.12.12:2
+# )
+# )
+
+src_configure() {
+ local myconf
+
+ econf \
+ $(use_with gtk gtk 2.0) \
+ $(use_enable nls) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}