summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2013-12-01 07:21:09 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2013-12-01 07:21:09 +0000
commit7f616ace5dbf162bcc0d599f3702433e094ec56b (patch)
treed1fd673441f97fb2c4ac2aaa957bb42e01ea799f /app-i18n
parentBump (diff)
downloadgentoo-2-7f616ace5dbf162bcc0d599f3702433e094ec56b.tar.gz
gentoo-2-7f616ace5dbf162bcc0d599f3702433e094ec56b.tar.bz2
gentoo-2-7f616ace5dbf162bcc0d599f3702433e094ec56b.zip
Version bumped.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 05280D69)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/nkf/ChangeLog7
-rw-r--r--app-i18n/nkf/nkf-2.1.3.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index ca10fd2f0f8d..bb0ec46080c0 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/nkf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.56 2013/09/10 06:53:47 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.57 2013/12/01 07:21:09 matsuu Exp $
+
+*nkf-2.1.3 (01 Dec 2013)
+
+ 01 Dec 2013; MATSUU Takuto <matsuu@gentoo.org> +nkf-2.1.3.ebuild:
+ Version bumped.
*nkf-2.1.2-r2 (10 Sep 2013)
diff --git a/app-i18n/nkf/nkf-2.1.3.ebuild b/app-i18n/nkf/nkf-2.1.3.ebuild
new file mode 100644
index 000000000000..3006ecf19273
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.1.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.1.3.ebuild,v 1.1 2013/12/01 07:21:09 matsuu Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils distutils-r1 perl-module toolchain-funcs
+
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="mirror://sourceforge.jp/nkf/59912/${P}.tar.gz
+ python? ( http://dev.gentoo.org/~naota/files/NKF_python20090602.tgz )"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-macos"
+IUSE="perl python linguas_ja"
+
+src_prepare() {
+ sed -i \
+ -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ Makefile || die
+
+ if use python; then
+ mv "${WORKDIR}/NKF.python" "${S}" || die
+ sed -i -e "s/-s/${CFLAGS}/" NKF.python/setup.py || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" nkf || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_compile
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ emake test || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+
+ if use linguas_ja; then
+ ./nkf -e nkf.1j > nkf.1
+ doman -i18n=ja nkf.1
+ fi
+ dodoc nkf.doc
+
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_install
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils-r1_src_install
+ fi
+}