summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-09-17 07:57:18 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-09-17 07:57:18 +0000
commit6c28d7dd9f5e435c016f91554ee6ac8962981fa2 (patch)
treed97d813a036ba24a442bddc7a6bc40c743f7f960 /app-i18n
parentMigrate to Debian patchset for more fixes #117506#6 by Jonathan. (diff)
downloadgentoo-2-6c28d7dd9f5e435c016f91554ee6ac8962981fa2.tar.gz
gentoo-2-6c28d7dd9f5e435c016f91554ee6ac8962981fa2.tar.bz2
gentoo-2-6c28d7dd9f5e435c016f91554ee6ac8962981fa2.zip
Version bumped.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table/ChangeLog8
-rw-r--r--app-i18n/ibus-table/ibus-table-1.3.9.20110827.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index 85d992e89209..e59be9e1e04b 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.24 2011/04/16 22:21:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.25 2011/09/17 07:57:18 matsuu Exp $
+
+*ibus-table-1.3.9.20110827 (17 Sep 2011)
+
+ 17 Sep 2011; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-1.3.9.20110827.ebuild:
+ Version bumped.
16 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
ibus-table-1.2.0.20100111.ebuild, ibus-table-1.3.0.20100621.ebuild:
diff --git a/app-i18n/ibus-table/ibus-table-1.3.9.20110827.ebuild b/app-i18n/ibus-table/ibus-table-1.3.9.20110827.ebuild
new file mode 100644
index 000000000000..85ae4345ebdd
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.3.9.20110827.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.3.9.20110827.ebuild,v 1.1 2011/09/17 07:57:18 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="sqlite"
+inherit python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ python_convert_shebangs 2 engine/tabcreatedb.py || die
+ sed -i -e "s/python/python2/" \
+ engine/ibus-table-createdb.in engine/ibus-engine-table.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls) --disable-additional
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}