summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-03-27 00:18:15 +0000
committerBen de Groot <yngwin@gentoo.org>2010-03-27 00:18:15 +0000
commit6b2a754935cbf277a2b678cbdb7b70a2c396437c (patch)
treec70a60a66ee20888e6299e02cc9e9641dfe66625 /app-i18n
parentUse qt4-r2.eclass (bug #311481). Formatting. (diff)
downloadgentoo-2-6b2a754935cbf277a2b678cbdb7b70a2c396437c.tar.gz
gentoo-2-6b2a754935cbf277a2b678cbdb7b70a2c396437c.tar.bz2
gentoo-2-6b2a754935cbf277a2b678cbdb7b70a2c396437c.zip
Migrate to eapi3 and qt4-r2.eclass. Drop patch since that is taken care off by the eclass.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/kimera/ChangeLog9
-rw-r--r--app-i18n/kimera/files/kimera-2.11-gentoo.patch10
-rw-r--r--app-i18n/kimera/kimera-2.11.ebuild26
3 files changed, 13 insertions, 32 deletions
diff --git a/app-i18n/kimera/ChangeLog b/app-i18n/kimera/ChangeLog
index ad61ea78aab2..0e86d1e93e0e 100644
--- a/app-i18n/kimera/ChangeLog
+++ b/app-i18n/kimera/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/kimera
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/ChangeLog,v 1.16 2009/05/15 21:36:33 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/ChangeLog,v 1.17 2010/03/27 00:18:15 yngwin Exp $
+
+ 27 Mar 2010; Ben de Groot <yngwin@gentoo.org> kimera-2.11.ebuild,
+ -files/kimera-2.11-gentoo.patch:
+ Migrate to eapi3 and qt4-r2.eclass. Drop patch since that is taken care
+ off by the eclass.
15 May 2009; Markus Meier <maekke@gentoo.org> kimera-2.11.ebuild:
amd64 stable, bug #269834
diff --git a/app-i18n/kimera/files/kimera-2.11-gentoo.patch b/app-i18n/kimera/files/kimera-2.11-gentoo.patch
deleted file mode 100644
index 41272a1589b4..000000000000
--- a/app-i18n/kimera/files/kimera-2.11-gentoo.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -Naur kimera-2.11.orig/kimera.pro kimera-2.11/kimera.pro
---- kimera-2.11.orig/kimera.pro 2009-01-26 00:36:40.000000000 +0900
-+++ kimera-2.11/kimera.pro 2009-02-11 09:12:00.000000000 +0900
-@@ -1,5 +1,5 @@
- TEMPLATE = app
--CONFIG += qt x11 warn_on release
-+CONFIG += qt x11 warn_on release nostrip
- QT += network
- TARGET = kimera-bin
- VERSION = 2.11
diff --git a/app-i18n/kimera/kimera-2.11.ebuild b/app-i18n/kimera/kimera-2.11.ebuild
index eb1bad0f1883..20ff230d35b1 100644
--- a/app-i18n/kimera/kimera-2.11.ebuild
+++ b/app-i18n/kimera/kimera-2.11.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/kimera-2.11.ebuild,v 1.4 2010/01/03 11:15:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/kimera-2.11.ebuild,v 1.5 2010/03/27 00:18:15 yngwin Exp $
-EAPI=1
-inherit eutils multilib qt4
+EAPI=3
+inherit qt4-r2
DESCRIPTION="A Japanese input method which supports the XIM protocol"
SRC_URI="mirror://sourceforge.jp/kimera/37271/${P}.tar.gz"
@@ -19,24 +19,10 @@ DEPEND="x11-libs/qt-core:4
!anthy? ( app-i18n/canna )"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DOCS="AUTHORS README*"
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-src_compile() {
+src_configure() {
local myconf="target.path=/usr/$(get_libdir)/${P}"
-
use anthy || myconf="${myconf} no_anthy=1"
-
- eqmake4 kimera.pro ${myconf} || die
- emake || die
-}
-
-src_install(){
- emake INSTALL_ROOT="${D}" install || die
-
- dodoc AUTHORS README*
+ eqmake4 kimera.pro ${myconf}
}