summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-04-20 20:34:44 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-04-20 20:34:44 +0000
commit5abc316e19d69d1ee2bbb44f6c1dc5e68e0ec9bb (patch)
treef1be16130af14f226ca3278366101723aea4e04a /app-i18n
parentUnmask Java 8. This is long overdue and it's looking good now. (diff)
downloadgentoo-2-5abc316e19d69d1ee2bbb44f6c1dc5e68e0ec9bb.tar.gz
gentoo-2-5abc316e19d69d1ee2bbb44f6c1dc5e68e0ec9bb.tar.bz2
gentoo-2-5abc316e19d69d1ee2bbb44f6c1dc5e68e0ec9bb.zip
Update EAPI.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/x-unikey/ChangeLog7
-rw-r--r--app-i18n/x-unikey/x-unikey-1.0.4-r2.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/app-i18n/x-unikey/ChangeLog b/app-i18n/x-unikey/ChangeLog
index 3d739778ccc1..c1fca6ae19bd 100644
--- a/app-i18n/x-unikey/ChangeLog
+++ b/app-i18n/x-unikey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/x-unikey
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/ChangeLog,v 1.26 2015/04/20 20:30:56 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/ChangeLog,v 1.27 2015/04/20 20:34:44 mrueg Exp $
+
+*x-unikey-1.0.4-r2 (20 Apr 2015)
+
+ 20 Apr 2015; Manuel Rüger <mrueg@gentoo.org> +x-unikey-1.0.4-r2.ebuild:
+ Update EAPI.
20 Apr 2015; Manuel Rüger <mrueg@gentoo.org> -x-unikey-0.9.2.ebuild:
Remove old.
diff --git a/app-i18n/x-unikey/x-unikey-1.0.4-r2.ebuild b/app-i18n/x-unikey/x-unikey-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..5fbe46a0e3bb
--- /dev/null
+++ b/app-i18n/x-unikey/x-unikey-1.0.4-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/x-unikey/x-unikey-1.0.4-r2.ebuild,v 1.1 2015/04/20 20:34:44 mrueg Exp $
+
+EAPI=5
+
+inherit autotools eutils multilib gnome2-utils
+
+DESCRIPTION="Vietnamese X Input Method"
+HOMEPAGE="http://www.unikey.org/"
+SRC_URI="mirror://sourceforge/unikey/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls gtk"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE
+ gtk? ( >=x11-libs/gtk+-2.2:2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-libs/glib
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ # --with-gtk-sysconfdir to prevent sandbox violation only
+ use gtk && myconf="--with-unikey-gtk --with-gtk-sysconfdir=${GTK2_CONFDIR}"
+ econf ${myconf}
+}
+
+src_install() {
+ if use gtk;then
+ dodir "${GTK2_CONFDIR}"
+# emake DESTDIR="${D}" install -C src/unikey-gtk || die
+ fi
+# dobin src/xim/ukxim src/gui/unikey
+ emake DESTDIR="${D}" install
+ doenvd "${FILESDIR}/01x-unikey"
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO
+ cd doc
+ dodoc README1ST keymap-syntax manual options ukmacro \
+ unikey-manual-0.9.pdf unikey.png unikeyrc
+}
+
+pkg_postinst() {
+ elog
+ elog "Go to /etc/env.d/01x-unikey and uncomment appropriate lines"
+ elog "to enable x-unikey"
+ elog
+ if use gtk; then
+ gnome2_query_immodules_gtk2
+ elog "If you want to use x-unikey as the default gtk+ input method,"
+ elog "change GTK_IM_MODULE in /etc/env.d/01x-unikey to \"unikey\""
+ elog
+ fi
+}
+
+pkg_postrm() {
+ use gtk && gnome2_query_immodules_gtk2
+}