summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-07-15 23:22:22 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-07-15 23:22:22 +0000
commit3f48bae42746f6dbef15fe7f591934ad6927876d (patch)
tree13257e4a8e97b96ddb425a14c3d83f6d989adf18 /app-i18n
parentAdd Maris Nartiss as proxied maintainer. (diff)
downloadgentoo-2-3f48bae42746f6dbef15fe7f591934ad6927876d.tar.gz
gentoo-2-3f48bae42746f6dbef15fe7f591934ad6927876d.tar.bz2
gentoo-2-3f48bae42746f6dbef15fe7f591934ad6927876d.zip
Version bump. Proxy commit for Markus Oehme. Fixes bug #517148
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/man-pages-de/ChangeLog7
-rw-r--r--app-i18n/man-pages-de/man-pages-de-1.7.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-i18n/man-pages-de/ChangeLog b/app-i18n/man-pages-de/ChangeLog
index d2e42f1ddba6..14d9fe491cc8 100644
--- a/app-i18n/man-pages-de/ChangeLog
+++ b/app-i18n/man-pages-de/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/man-pages-de
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-de/ChangeLog,v 1.28 2014/02/26 21:32:27 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-de/ChangeLog,v 1.29 2014/07/15 23:22:22 mrueg Exp $
+
+*man-pages-de-1.7 (15 Jul 2014)
+
+ 15 Jul 2014; Manuel Rüger <mrueg@gentoo.org> +man-pages-de-1.7.ebuild:
+ Version bump. Proxy commit for Markus Oehme. Fixes bug #517148
*man-pages-de-1.5 (26 Feb 2014)
diff --git a/app-i18n/man-pages-de/man-pages-de-1.7.ebuild b/app-i18n/man-pages-de/man-pages-de-1.7.ebuild
new file mode 100644
index 000000000000..3e31c6c9b1e6
--- /dev/null
+++ b/app-i18n/man-pages-de/man-pages-de-1.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-de/man-pages-de-1.7.ebuild,v 1.1 2014/07/15 23:22:22 mrueg Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+MY_P="${PN/-/}-${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="http://alioth.debian.org/projects/manpages-de/"
+SRC_URI="http://manpages-de.alioth.debian.org/downloads/${MY_P}.tar.xz"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+DEPEND="${RDEPEND}
+ app-text/po4a"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3-bzip2.patch
+
+ # Use the same compression as every other manpage
+ local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+ if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then
+ PORTAGE_COMPRESS_LOCAL="#"
+ fi
+ if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2|gzip) local PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+ ;;
+ esac
+ fi
+ sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\
+ po/man{1,2,3,4,5,6,7,8}/Makefile.in po/common.mk || die
+ eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake mandir="${ED}"/usr/share/man install
+ dodoc CHANGES README
+}