summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-10-27 16:03:38 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-10-27 16:03:38 +0000
commit0d9887c14496a7e9cb5857f2c55c80082d442b80 (patch)
treec949d700f33dbb0d3d059f0694513f85027209f5 /app-i18n
parenttidy (diff)
downloadgentoo-2-0d9887c14496a7e9cb5857f2c55c80082d442b80.tar.gz
gentoo-2-0d9887c14496a7e9cb5857f2c55c80082d442b80.tar.bz2
gentoo-2-0d9887c14496a7e9cb5857f2c55c80082d442b80.zip
Version bumped.
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog7
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.2.3.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 8d8182359406..5f7f3c9c6af9 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.23 2010/08/11 18:19:18 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.24 2010/10/27 16:03:38 matsuu Exp $
+
+*ibus-anthy-1.2.3 (27 Oct 2010)
+
+ 27 Oct 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-anthy-1.2.3.ebuild:
+ Version bumped.
11 Aug 2010; Joseph Jezak <josejx@gentoo.org>
ibus-anthy-1.2.0.20100115.ebuild, ibus-anthy-1.2.1.ebuild:
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.2.3.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.2.3.ebuild
new file mode 100644
index 000000000000..5f9da3bb6c07
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.2.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.2.3.ebuild,v 1.1 2010/10/27 16:03:38 matsuu Exp $
+
+EAPI=2
+PYTHON_DEPEND="2:2.5"
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2.0.20090904
+ app-i18n/anthy
+ >=dev-python/pygtk-2.15.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ sed -i -e "s/python/python2/" \
+ engine/ibus-engine-anthy.in setup/ibus-setup-anthy.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ elog
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ elog
+ elog "# emerge app-dicts/kasumi"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}