summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-11-02 06:53:22 +0000
committerMu Qiao <qiaomuf@gentoo.org>2011-11-02 06:53:22 +0000
commit0c037744a1e41136ec92b230d0f8d28b13ac14e3 (patch)
treee2cf8cdf1df9b5bb212c82a4058bbdd6f7b0a329 /app-i18n
parentVersion bump. Install new man page. (diff)
downloadgentoo-2-0c037744a1e41136ec92b230d0f8d28b13ac14e3.tar.gz
gentoo-2-0c037744a1e41136ec92b230d0f8d28b13ac14e3.tar.bz2
gentoo-2-0c037744a1e41136ec92b230d0f8d28b13ac14e3.zip
Version bump for fcitx-4.1.2, ppc is dropped due to bug 382669
(Portage version: 2.1.10.32/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx/ChangeLog16
-rw-r--r--app-i18n/fcitx/fcitx-4.0.1.ebuild7
-rw-r--r--app-i18n/fcitx/fcitx-4.1.2.ebuild66
-rw-r--r--app-i18n/fcitx/metadata.xml4
4 files changed, 86 insertions, 7 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index f76bbb6f2ae6..e1174520a652 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-i18n/fcitx
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.34 2010/12/19 02:48:24 qiaomuf Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.35 2011/11/02 06:53:22 qiaomuf Exp $
+
+*fcitx-4.1.2 (02 Nov 2011)
+
+ 02 Nov 2011; Mu Qiao <qiaomuf@gentoo.org> fcitx-4.0.1.ebuild,
+ +fcitx-4.1.2.ebuild, metadata.xml:
+ Version bump for fcitx-4.1.2
+
+*fcitx-4.1.1 (12 Sep 2011)
+
+ 12 Sep 2011; Mu Qiao <qiaomuf@gentoo.org> fcitx-4.0.1.ebuild,
+ +fcitx-4.1.1.ebuild, metadata.xml:
+ Version bump, fix old dependency
19 Dec 2010; Mu Qiao <qiaomuf@gentoo.org> fcitx-4.0.1.ebuild,
+files/fcitx-4.0.1-fix-pango.patch:
diff --git a/app-i18n/fcitx/fcitx-4.0.1.ebuild b/app-i18n/fcitx/fcitx-4.0.1.ebuild
index 25c88b1f6076..f5417f4fbcff 100644
--- a/app-i18n/fcitx/fcitx-4.0.1.ebuild
+++ b/app-i18n/fcitx/fcitx-4.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.0.1.ebuild,v 1.2 2010/12/19 02:48:24 qiaomuf Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.0.1.ebuild,v 1.3 2011/11/02 06:53:22 qiaomuf Exp $
EAPI="3"
@@ -15,8 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="dbus pango"
-RDEPEND="!<=app-i18n/fcitx-configtool-0.1.4
- x11-libs/libX11
+RDEPEND="x11-libs/libX11
x11-libs/libXrender
x11-libs/cairo[X]
media-libs/fontconfig
diff --git a/app-i18n/fcitx/fcitx-4.1.2.ebuild b/app-i18n/fcitx/fcitx-4.1.2.ebuild
new file mode 100644
index 000000000000..fd623736ab73
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-4.1.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.1.2.ebuild,v 1.1 2011/11/02 06:53:22 qiaomuf Exp $
+
+EAPI="3"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://www.fcitx.org/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}_all.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo dbus debug gtk gtk3 opencc pango"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ media-libs/fontconfig
+ pango? ( x11-libs/pango )
+ opencc? ( app-i18n/opencc )
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ cairo? ( x11-libs/cairo[X] )
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ dev-util/pkgconfig"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable cairo)
+ $(cmake-utils_use_enable dbus)
+ $(cmake-utils_use_enable debug)
+ $(cmake-utils_use_enable gtk gtk2_im_module)
+ $(cmake-utils_use_enable gtk3 gtk3_im_module)
+ $(cmake-utils_use_enable opencc)
+ $(cmake-utils_use_enable pango)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc AUTHORS ChangeLog README THANKS TODO || die
+
+ rm -rf "${ED}"/usr/share/fcitx/doc/ || die
+ dodoc doc/pinyin.txt doc/cjkvinput.txt || die
+ dohtml doc/wb_fh.htm || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You should export the following variables to use fcitx"
+ elog " export XMODIFIERS=\"@im=fcitx\""
+ elog " export XIM=fcitx"
+ elog " export XIM_PROGRAM=fcitx"
+ elog
+ elog "If you want to use WuBi ,ErBi or something else."
+ elog " mkdir -p ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/wbx.mb ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/erbi.mb ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/tables.conf ~/.fcitx"
+ elog
+}
diff --git a/app-i18n/fcitx/metadata.xml b/app-i18n/fcitx/metadata.xml
index 76737a4b1614..64aa1a0dcd33 100644
--- a/app-i18n/fcitx/metadata.xml
+++ b/app-i18n/fcitx/metadata.xml
@@ -7,6 +7,8 @@
<name>Mu Qiao</name>
</maintainer>
<use>
- <flag name='pango'>Enable support for <pkg>x11-libs/pango</pkg></flag>
+ <flag name="gtk3">Use GTK+3 instead of 2</flag>
+ <flag name='opencc'>Enable OpenCC for Chinese Transform</flag>
+ <flag name='pango'>Enable support for <pkg>x11-libs/pango</pkg></flag>
</use>
</pkgmetadata>