summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-03-21 14:27:12 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-03-21 14:27:12 +0000
commit016e0f5186116973d1072d19684aee5ac0b428a5 (patch)
tree4c8ba3b5d456934784fb515d34413cd9ecc1a273 /app-i18n
parentQA: Unnecessary definition of S and RDEPEND removed. Adding categories to dep... (diff)
downloadgentoo-2-016e0f5186116973d1072d19684aee5ac0b428a5.tar.gz
gentoo-2-016e0f5186116973d1072d19684aee5ac0b428a5.tar.bz2
gentoo-2-016e0f5186116973d1072d19684aee5ac0b428a5.zip
version bump.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest2
-rw-r--r--app-i18n/anthy-ss/anthy-ss-5117.ebuild70
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-51171
4 files changed, 79 insertions, 1 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index 56c492bc25c4..5614d1b1a963 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.17 2004/03/08 11:07:17 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.18 2004/03/21 14:27:12 hattya Exp $
+
+*anthy-ss-5117 (21 Mar 2004)
+
+ 21 Mar 2004; Akinori Hattori <hattya@gentoo.org> anthy-ss-5117.ebuild:
+ version bump.
*anthy-ss-5106 (08 Mar 2004)
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index ba173005f81c..8d600be4a2a0 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -4,6 +4,7 @@ MD5 4868424ea203c9b831768ba5df2243d8 anthy-ss-5003.ebuild 1486
MD5 790517ab5c6a6a1a7f676e10801d5292 anthy-ss-5012.ebuild 1506
MD5 6e44ae9f72183cc95b442953890d0897 anthy-ss-5021.ebuild 1488
MD5 2fd72e2b7f5b647b389171dcc6dccf7d anthy-ss-5106.ebuild 1488
+MD5 e8a6d8e01fbca6042316ac36577cc8ed anthy-ss-5117.ebuild 1387
MD5 84bff7b207f0d829e08599fbf40176c0 metadata.xml 614
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 98b2c84eaee12f08d78b8f791ef15aa3 files/digest-anthy-ss-4925 63
@@ -11,3 +12,4 @@ MD5 cd17a2429c0b4b31c68aa84b5360490e files/digest-anthy-ss-5003 63
MD5 d246b212d5facc9f7c1aac42d4cc991b files/digest-anthy-ss-5012 63
MD5 0a5d1c1596558566cb22a5c5852d18bd files/digest-anthy-ss-5021 63
MD5 56c8b0fd5cd5e7546a591c861b4973ad files/digest-anthy-ss-5106 63
+MD5 11e39be8a26acebcb26101bfe81aceca files/digest-anthy-ss-5117 63
diff --git a/app-i18n/anthy-ss/anthy-ss-5117.ebuild b/app-i18n/anthy-ss/anthy-ss-5117.ebuild
new file mode 100644
index 000000000000..7d25aed67a12
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-5117.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-5117.ebuild,v 1.1 2004/03/21 14:27:12 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/8747/${MY_P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-5117 b/app-i18n/anthy-ss/files/digest-anthy-ss-5117
new file mode 100644
index 000000000000..abe418e0b6c1
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-5117
@@ -0,0 +1 @@
+MD5 46fd96355ed9b8f4824c2fa451b77d77 anthy-5117.tar.gz 1524596