summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Bouyer <stubear@gentoo.org>2002-10-23 14:17:03 +0000
committerStuart Bouyer <stubear@gentoo.org>2002-10-23 14:17:03 +0000
commitbf23ab0339968c436280f88370061341d64ecf15 (patch)
tree53b173df8fa53497b856103e180ba52ac45b6e1e /app-i18n/xcin
parentOld gotmail packages don't work any more due to Hotmail changes; removing. (diff)
downloadgentoo-2-bf23ab0339968c436280f88370061341d64ecf15.tar.gz
gentoo-2-bf23ab0339968c436280f88370061341d64ecf15.tar.bz2
gentoo-2-bf23ab0339968c436280f88370061341d64ecf15.zip
upgraded to new version and added support for libtabe
Diffstat (limited to 'app-i18n/xcin')
-rw-r--r--app-i18n/xcin/ChangeLog10
-rw-r--r--app-i18n/xcin/files/digest-xcin-2.5.3_pre22
-rw-r--r--app-i18n/xcin/xcin-2.5.3_pre2.ebuild79
3 files changed, 90 insertions, 1 deletions
diff --git a/app-i18n/xcin/ChangeLog b/app-i18n/xcin/ChangeLog
index 10fdcc62271e..d566d4c7da36 100644
--- a/app-i18n/xcin/ChangeLog
+++ b/app-i18n/xcin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-i18n/xcin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xcin/ChangeLog,v 1.2 2002/10/19 22:15:41 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xcin/ChangeLog,v 1.3 2002/10/23 14:17:03 stubear Exp $
+
+*xcin-2.5.3_pre2 (11 Oct 2002)
+
+ 11 Oct 2002; Stuart Bouyer <stubear@gentoo.org> ChangeLog,
+ xcin-2.5.3_pre2.ebuild :
+
+ Initial ebuild submitted by Lloyd Huang <lloyd@coventive.com>
+ Now has support for libtabe.
*xcin-2.5.2.3 (1 Aug 2002)
diff --git a/app-i18n/xcin/files/digest-xcin-2.5.3_pre2 b/app-i18n/xcin/files/digest-xcin-2.5.3_pre2
new file mode 100644
index 000000000000..42a8f5de6372
--- /dev/null
+++ b/app-i18n/xcin/files/digest-xcin-2.5.3_pre2
@@ -0,0 +1,2 @@
+MD5 6f47203be515f505d5a6750dfbabc0bc xcin-2.5.3.pre2.tar.gz 1433915
+MD5 6aea52faf907cb79beac5838057d8edb chewing-2002Jan07-snapshot.tar.gz 1152865
diff --git a/app-i18n/xcin/xcin-2.5.3_pre2.ebuild b/app-i18n/xcin/xcin-2.5.3_pre2.ebuild
new file mode 100644
index 000000000000..9ae60c1707cc
--- /dev/null
+++ b/app-i18n/xcin/xcin-2.5.3_pre2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xcin/xcin-2.5.3_pre2.ebuild,v 1.1 2002/10/23 14:17:03 stubear Exp $
+
+IUSE="nls"
+
+XCIN="${P/_/.}.tar.gz"
+CHEWING="chewing-2002Jan07-snapshot.tar.gz"
+
+DESCRIPTION="Chinese X Input Method"
+
+HOMEPAGE="http://xcin.linux.org.tw/"
+
+SRC_URI="ftp://xcin.linux.org.tw/pub/xcin/xcin/devel/${XCIN}
+ http://chewing.good-man.org/snapshot/${CHEWING}"
+
+LICENSE="XCIN"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=app-i18n/libtabe-0.2.5"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack () {
+ unpack ${XCIN}
+ # patch for chewing support
+ cd ${S}/src/Cinput
+ unpack ${CHEWING}
+ cd chewing
+ ./patch_chewing
+
+ # gcc3.2 changed the way we deal with -I. So until the configure script
+ # is updated we need this hack as a work around.
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}/gentoo-xcin.patch || die
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-xcin-rcdir=/etc \
+ --with-xcin-dir=/usr/lib/X11/xcin25 \
+ --with-db-lib=/usr/lib \
+ --with-tabe-inc=/usr/include/tabe \
+ --with-tabe-lib=/usr/lib || die "./configure failed"
+ make || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ xcin_rcp=${D}/etc \
+ xcin_binp=${D}/usr/bin \
+ xcin_libp=${D}/usr/lib \
+ xcin_modp=${D}/usr/lib/X11/xcin25 \
+ mandir=${D}/usr/share/man \
+ install || die
+ dodir /etc
+ insinto /etc
+ newins ${FILESDIR}/gentoo-xcinrc xcinrc
+ dodoc doc/*
+ docinto En
+ dodoc doc/En/*
+ docinto En/internal
+ dodoc doc/En/internal/*
+ docinto history
+ dodoc doc/history/*
+ docinto internal
+ dodoc doc/internal/*
+ docinto modules
+ dodoc doc/modules/*
+}