summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-07-22 12:08:38 +0000
committerMamoru Komachi <usata@gentoo.org>2005-07-22 12:08:38 +0000
commiteb9ce0efc58fdc301dfe748567f372567f9e09fb (patch)
treea35c80f22ff8d85b46eae7ef1be0fc44942c6f7b /app-i18n/uim
parentInitial import. (diff)
downloadgentoo-2-eb9ce0efc58fdc301dfe748567f372567f9e09fb.tar.gz
gentoo-2-eb9ce0efc58fdc301dfe748567f372567f9e09fb.tar.bz2
gentoo-2-eb9ce0efc58fdc301dfe748567f372567f9e09fb.zip
Prevent uim from creating /share/uim when you do not have app-i18n/prime; bug #99824.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-i18n/uim')
-rw-r--r--app-i18n/uim/ChangeLog7
-rw-r--r--app-i18n/uim/uim-0.4.6-r2.ebuild16
-rw-r--r--app-i18n/uim/uim-0.4.7.ebuild16
3 files changed, 26 insertions, 13 deletions
diff --git a/app-i18n/uim/ChangeLog b/app-i18n/uim/ChangeLog
index abbd0caab95c..84915e503f2f 100644
--- a/app-i18n/uim/ChangeLog
+++ b/app-i18n/uim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/uim
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/ChangeLog,v 1.103 2005/07/21 14:30:17 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/ChangeLog,v 1.104 2005/07/22 12:08:38 usata Exp $
+
+ 22 Jul 2005; Mamoru KOMACHI <usata@gentoo.org> uim-0.4.6-r2.ebuild,
+ uim-0.4.7.ebuild:
+ Prevent uim from creating /share/uim when you do not have app-i18n/prime;
+ bug #99824.
*uim-0.4.7.1-r1 (21 Jul 2005)
diff --git a/app-i18n/uim/uim-0.4.6-r2.ebuild b/app-i18n/uim/uim-0.4.6-r2.ebuild
index 2ccea0cc68bc..6e58b73b2035 100644
--- a/app-i18n/uim/uim-0.4.6-r2.ebuild
+++ b/app-i18n/uim/uim-0.4.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-0.4.6-r2.ebuild,v 1.7 2005/07/18 10:30:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-0.4.6-r2.ebuild,v 1.8 2005/07/22 12:08:38 usata Exp $
inherit eutils kde-functions
@@ -80,16 +80,20 @@ src_compile() {
econf ${myconf} || die "econf failed"
emake -j1 || die "emake failed"
- cd ${WORKDIR}/prime-1.0.0.1
- econf || die
+ if has_version '>=app-i18n/prime-1.0' ; then
+ cd ${WORKDIR}/prime-1.0.0.1
+ econf || die
+ fi
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- cd ${WORKDIR}/prime-1.0.0.1
- make DESTDIR="${D}" install-uim || die "make install-uim failed"
- cd -
+ if has_version '>=app-i18n/prime-1.0' ; then
+ cd ${WORKDIR}/prime-1.0.0.1
+ make DESTDIR="${D}" install-uim || die "make install-uim failed"
+ cd -
+ fi
dodoc AUTHORS ChangeLog INSTALL* NEWS README*
dodoc doc/{HELPER-CANDWIN,KEY,UIM-SH}
diff --git a/app-i18n/uim/uim-0.4.7.ebuild b/app-i18n/uim/uim-0.4.7.ebuild
index 379544723190..7ad5f95a16a2 100644
--- a/app-i18n/uim/uim-0.4.7.ebuild
+++ b/app-i18n/uim/uim-0.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-0.4.7.ebuild,v 1.3 2005/07/18 14:50:56 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-0.4.7.ebuild,v 1.4 2005/07/22 12:08:38 usata Exp $
inherit eutils kde-functions
@@ -77,16 +77,20 @@ src_compile() {
econf ${myconf} --without-scim || die "econf failed"
emake -j1 || die "emake failed"
- cd ${WORKDIR}/prime-1.0.0.1
- econf || die
+ if has_version '>=app-i18n/prime-1.0' ; then
+ cd ${WORKDIR}/prime-1.0.0.1
+ econf || die
+ fi
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- cd ${WORKDIR}/prime-1.0.0.1
- make DESTDIR="${D}" install-uim || die "make install-uim failed"
- cd -
+ if has_version '>=app-i18n/prime-1.0' ; then
+ cd ${WORKDIR}/prime-1.0.0.1
+ make DESTDIR="${D}" install-uim || die "make install-uim failed"
+ cd -
+ fi
dodoc AUTHORS ChangeLog INSTALL* NEWS README*
dodoc doc/{HELPER-CANDWIN,KEY,UIM-SH}