summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-06-22 02:13:29 +0000
committerNaohiro Aota <naota@gentoo.org>2012-06-22 02:13:29 +0000
commitc8762a03be36f245d8743e89e8f36307e793725a (patch)
tree48fa0564b579a12383c165218fdb107e5edd4786 /app-i18n/tomoe
parentUpdate maintainer mail address. (diff)
downloadgentoo-2-c8762a03be36f245d8743e89e8f36307e793725a.tar.gz
gentoo-2-c8762a03be36f245d8743e89e8f36307e793725a.tar.bz2
gentoo-2-c8762a03be36f245d8743e89e8f36307e793725a.zip
Add patch to build with glib-2.32. #422781
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/tomoe')
-rw-r--r--app-i18n/tomoe/ChangeLog6
-rw-r--r--app-i18n/tomoe/files/tomoe-0.6.0-glib232.patch39
-rw-r--r--app-i18n/tomoe/tomoe-0.6.0-r1.ebuild5
3 files changed, 47 insertions, 3 deletions
diff --git a/app-i18n/tomoe/ChangeLog b/app-i18n/tomoe/ChangeLog
index 690c57c0c017..b7e3f849955c 100644
--- a/app-i18n/tomoe/ChangeLog
+++ b/app-i18n/tomoe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/tomoe
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/ChangeLog,v 1.16 2012/06/08 11:52:50 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/ChangeLog,v 1.17 2012/06/22 02:13:29 naota Exp $
+
+ 22 Jun 2012; Naohiro Aota <naota@gentoo.org> +files/tomoe-0.6.0-glib232.patch,
+ tomoe-0.6.0-r1.ebuild:
+ Add patch to build with glib-2.32. #422781
08 Jun 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> tomoe-0.6.0-r1.ebuild:
x86 stable wrt bug #418593
diff --git a/app-i18n/tomoe/files/tomoe-0.6.0-glib232.patch b/app-i18n/tomoe/files/tomoe-0.6.0-glib232.patch
new file mode 100644
index 000000000000..cf073d4d2cfa
--- /dev/null
+++ b/app-i18n/tomoe/files/tomoe-0.6.0-glib232.patch
@@ -0,0 +1,39 @@
+diff --git a/lib/glib-compat-key-file.h b/lib/glib-compat-key-file.h
+index 6cae16b..1fb1490 100644
+--- a/lib/glib-compat-key-file.h
++++ b/lib/glib-compat-key-file.h
+@@ -51,7 +51,7 @@
+ #ifndef __G_KEY_FILE_H__
+ #define __G_KEY_FILE_H__
+
+-#include <glib/gerror.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+diff --git a/lib/glib-utils.h b/lib/glib-utils.h
+index 275c96c..7afca67 100644
+--- a/lib/glib-utils.h
++++ b/lib/glib-utils.h
+@@ -28,7 +28,7 @@
+ #include "config.h"
+ #endif /* HAVE_CONFIG_H */
+
+-#include <glib/garray.h>
++#include <glib.h>
+ #include <glib/gi18n-lib.h>
+ #include "glib-compat-file-utilities.h"
+ #include "glib-compat-key-file.h"
+diff --git a/lib/tomoe.c b/lib/tomoe.c
+index 8578c27..4534017 100644
+--- a/lib/tomoe.c
++++ b/lib/tomoe.c
+@@ -26,7 +26,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <glib/garray.h>
++#include <glib.h>
+ #include "tomoe.h"
+
+ static gboolean initialized = FALSE;
diff --git a/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild b/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild
index 3f95e264a16d..f51df28d86a4 100644
--- a/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild
+++ b/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild,v 1.5 2012/06/08 11:52:50 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild,v 1.6 2012/06/22 02:13:29 naota Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -46,7 +46,8 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}/${P}-export-symbols.patch" \
- "${FILESDIR}/${P}-ldflags.patch"
+ "${FILESDIR}/${P}-ldflags.patch" \
+ "${FILESDIR}/${P}-glib232.patch"
if ! use hyperestraier ; then
sed -i -e "s/use_est=yes/use_est=no/" configure.ac || die