summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-26 22:44:21 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-26 22:44:21 +0000
commit03f62e186c2b31032d3aaaf4727e855a18f87605 (patch)
treedd1d76dc0df3984541d5a95a6d5850428ade7780 /app-i18n/tomoe
parentInitial ebuild, resolves #313869 (diff)
downloadgentoo-2-03f62e186c2b31032d3aaaf4727e855a18f87605.tar.gz
gentoo-2-03f62e186c2b31032d3aaaf4727e855a18f87605.tar.bz2
gentoo-2-03f62e186c2b31032d3aaaf4727e855a18f87605.zip
Removed .la files, bug #299018. Respect LDFLAGS, bug #311989. Added python USE flag, bug #327107. Clean up.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/tomoe')
-rw-r--r--app-i18n/tomoe/ChangeLog11
-rw-r--r--app-i18n/tomoe/files/tomoe-0.6.0-export-symbols.patch240
-rw-r--r--app-i18n/tomoe/files/tomoe-0.6.0-ldflags.patch24
-rw-r--r--app-i18n/tomoe/tomoe-0.6.0-r1.ebuild85
4 files changed, 358 insertions, 2 deletions
diff --git a/app-i18n/tomoe/ChangeLog b/app-i18n/tomoe/ChangeLog
index 3ba129127e0f..3ec669140b5e 100644
--- a/app-i18n/tomoe/ChangeLog
+++ b/app-i18n/tomoe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/tomoe
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/ChangeLog,v 1.11 2010/06/22 18:30:59 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/ChangeLog,v 1.12 2011/05/26 22:44:21 matsuu Exp $
+
+*tomoe-0.6.0-r1 (26 May 2011)
+
+ 26 May 2011; MATSUU Takuto <matsuu@gentoo.org> +tomoe-0.6.0-r1.ebuild,
+ +files/tomoe-0.6.0-export-symbols.patch, +files/tomoe-0.6.0-ldflags.patch:
+ Removed .la files, bug #299018. Respect LDFLAGS, bug #311989. Added python
+ USE flag, bug #327107. Clean up.
22 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
tomoe-0.6.0.ebuild:
diff --git a/app-i18n/tomoe/files/tomoe-0.6.0-export-symbols.patch b/app-i18n/tomoe/files/tomoe-0.6.0-export-symbols.patch
new file mode 100644
index 000000000000..2b2d98b6ddd7
--- /dev/null
+++ b/app-i18n/tomoe/files/tomoe-0.6.0-export-symbols.patch
@@ -0,0 +1,240 @@
+Index: trunk/module/dict/tomoe-dict-xml.c
+===================================================================
+--- trunk/module/dict/tomoe-dict-xml.c (revision 1581)
++++ trunk/module/dict/tomoe-dict-xml.c (revision 1582)
+@@ -303,14 +303,14 @@
+ return success;
+
+ result.name = NULL;
+- result.chars = _tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (dict));
+- success = _tomoe_xml_parser_parse_dictionary_file (dict->filename, &result);
++ result.chars = tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (dict));
++ success = tomoe_xml_parser_parse_dictionary_file (dict->filename, &result);
+ if (result.name) {
+ g_free (dict->name);
+ dict->name = g_strdup (result.name);
+ g_free (result.name);
+ }
+- _tomoe_dict_ptr_array_sort (TOMOE_DICT_PTR_ARRAY (dict));
++ tomoe_dict_ptr_array_sort (TOMOE_DICT_PTR_ARRAY (dict));
+
+ return success;
+ }
+@@ -343,7 +343,7 @@
+ else
+ g_string_append (xml, "<dictionary>\n");
+
+- chars = _tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (dict));
++ chars = tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (dict));
+ for (i = 0; i < chars->len; i++) {
+ gchar *chr_xml;
+ TomoeChar *chr = g_ptr_array_index (chars, i);
+Index: trunk/module/dict/tomoe-dict-unihan.c
+===================================================================
+--- trunk/module/dict/tomoe-dict-unihan.c (revision 1581)
++++ trunk/module/dict/tomoe-dict-unihan.c (revision 1582)
+@@ -193,7 +193,7 @@
+ object = klass->constructor (type, n_props, props);
+ the_singleton = TOMOE_DICT_UNIHAN (object);
+
+- chars = _tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (object));
++ chars = tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (object));
+ _tomoe_unihan_create (chars);
+ } else {
+ object = g_object_ref (G_OBJECT (the_singleton));
+Index: trunk/lib/tomoe-char.c
+===================================================================
+--- trunk/lib/tomoe-char.c (revision 1581)
++++ trunk/lib/tomoe-char.c (revision 1582)
+@@ -143,7 +143,7 @@
+ TomoeChar*
+ tomoe_char_new_from_xml_data (const gchar *data, gssize len)
+ {
+- return _tomoe_xml_parser_parse_char_data (data, len);
++ return tomoe_xml_parser_parse_char_data (data, len);
+ }
+
+ static void
+Index: trunk/lib/tomoe-xml-parser.c
+===================================================================
+--- trunk/lib/tomoe-xml-parser.c (revision 1581)
++++ trunk/lib/tomoe-xml-parser.c (revision 1582)
+@@ -428,8 +428,8 @@
+ }
+
+ gboolean
+-_tomoe_xml_parser_parse_dictionary_file (const gchar *filename,
+- TomoeXMLParsedData *result)
++tomoe_xml_parser_parse_dictionary_file (const gchar *filename,
++ TomoeXMLParsedData *result)
+ {
+ GMarkupParseContext *context;
+ FILE *f;
+@@ -469,7 +469,7 @@
+ }
+
+ TomoeChar *
+-_tomoe_xml_parser_parse_char_data (const gchar *xml, gssize len)
++tomoe_xml_parser_parse_char_data (const gchar *xml, gssize len)
+ {
+ GMarkupParseContext *context;
+ TomoeXMLParsedData result;
+Index: trunk/lib/tomoe-xml-parser.h
+===================================================================
+--- trunk/lib/tomoe-xml-parser.h (revision 1581)
++++ trunk/lib/tomoe-xml-parser.h (revision 1582)
+@@ -37,10 +37,10 @@
+ GPtrArray *chars;
+ };
+
+-gboolean _tomoe_xml_parser_parse_dictionary_file (const gchar *filename,
+- TomoeXMLParsedData *result);
+-TomoeChar *_tomoe_xml_parser_parse_char_data (const gchar *xml,
+- gssize len);
++gboolean tomoe_xml_parser_parse_dictionary_file (const gchar *filename,
++ TomoeXMLParsedData *result);
++TomoeChar *tomoe_xml_parser_parse_char_data (const gchar *xml,
++ gssize len);
+
+
+ G_END_DECLS
+Index: trunk/lib/tomoe-dict-ptr-array.c
+===================================================================
+--- trunk/lib/tomoe-dict-ptr-array.c (revision 1581)
++++ trunk/lib/tomoe-dict-ptr-array.c (revision 1582)
+@@ -50,7 +50,7 @@
+
+ static TomoeDictClass *parent_class;
+
+-G_DEFINE_ABSTRACT_TYPE (TomoeDictPtrArray, _tomoe_dict_ptr_array, TOMOE_TYPE_DICT)
++G_DEFINE_ABSTRACT_TYPE (TomoeDictPtrArray, tomoe_dict_ptr_array, TOMOE_TYPE_DICT)
+
+ static void dispose (GObject *object);
+ static void set_property (GObject *object,
+@@ -75,7 +75,7 @@
+ static gchar *get_available_private_utf8 (TomoeDict *dict);
+
+ static void
+-_tomoe_dict_ptr_array_class_init (TomoeDictPtrArrayClass *klass)
++tomoe_dict_ptr_array_class_init (TomoeDictPtrArrayClass *klass)
+ {
+ GObjectClass *gobject_class;
+ TomoeDictClass *dict_class;
+@@ -123,7 +123,7 @@
+ }
+
+ static void
+-_tomoe_dict_ptr_array_init (TomoeDictPtrArray *dict)
++tomoe_dict_ptr_array_init (TomoeDictPtrArray *dict)
+ {
+ TomoeDictPtrArrayPrivate *priv = TOMOE_DICT_PTR_ARRAY_GET_PRIVATE (dict);
+ priv->chars = g_ptr_array_new();
+@@ -196,7 +196,7 @@
+ }
+
+ void
+-_tomoe_dict_ptr_array_sort (TomoeDictPtrArray *dict)
++tomoe_dict_ptr_array_sort (TomoeDictPtrArray *dict)
+ {
+ TomoeDictPtrArrayPrivate *priv;
+
+@@ -219,7 +219,7 @@
+
+ unregister_char (dict, tomoe_char_get_utf8 (chr));
+ g_ptr_array_add (priv->chars, g_object_ref (G_OBJECT (chr)));
+- _tomoe_dict_ptr_array_sort (TOMOE_DICT_PTR_ARRAY (dict));
++ tomoe_dict_ptr_array_sort (TOMOE_DICT_PTR_ARRAY (dict));
+
+ priv->modified = TRUE;
+
+@@ -449,7 +449,7 @@
+ g_ptr_array_add (*dest_chars, tomoe_char_dup (chr));
+ }
+
+-gboolean
++static gboolean
+ copy (TomoeDict *src_dict, TomoeDict *dest_dict)
+ {
+ TomoeDictPtrArrayPrivate *src_priv, *dest_priv;
+@@ -487,7 +487,7 @@
+ return TOMOE_DICT_PTR_ARRAY_GET_PRIVATE (dict)->editable;
+ }
+
+-gchar *
++static gchar *
+ get_available_private_utf8 (TomoeDict *dict)
+ {
+ TomoeDictPtrArrayPrivate *priv;
+@@ -523,7 +523,7 @@
+ }
+
+ GPtrArray *
+-_tomoe_dict_ptr_array_get_array (TomoeDictPtrArray *dict)
++tomoe_dict_ptr_array_get_array (TomoeDictPtrArray *dict)
+ {
+ g_return_val_if_fail (TOMOE_IS_DICT_PTR_ARRAY (dict), NULL);
+
+Index: trunk/lib/tomoe-dict-ptr-array.h
+===================================================================
+--- trunk/lib/tomoe-dict-ptr-array.h (revision 1581)
++++ trunk/lib/tomoe-dict-ptr-array.h (revision 1582)
+@@ -29,7 +29,7 @@
+
+ #include "tomoe-dict.h"
+
+-#define TOMOE_TYPE_DICT_PTR_ARRAY (_tomoe_dict_ptr_array_get_type ())
++#define TOMOE_TYPE_DICT_PTR_ARRAY (tomoe_dict_ptr_array_get_type ())
+ #define TOMOE_DICT_PTR_ARRAY(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), TOMOE_TYPE_DICT_PTR_ARRAY, TomoeDictPtrArray))
+ #define TOMOE_DICT_PTR_ARRAY_CLASS(klass) (G_TYPE_CHECK_CLASS_CAST ((klass), TOMOE_TYPE_DICT_PTR_ARRAY, TomoeDictPtrArrayClass))
+ #define TOMOE_IS_DICT_PTR_ARRAY(obj) (G_TYPE_CHECK_INSTANCE_TYPE ((obj), TOMOE_TYPE_DICT_PTR_ARRAY))
+@@ -49,9 +49,9 @@
+ TomoeDictClass parent_class;
+ };
+
+-GType _tomoe_dict_ptr_array_get_type (void) G_GNUC_CONST;
+-void _tomoe_dict_ptr_array_sort (TomoeDictPtrArray *dict);
+-GPtrArray *_tomoe_dict_ptr_array_get_array (TomoeDictPtrArray *dict);
++GType tomoe_dict_ptr_array_get_type (void) G_GNUC_CONST;
++void tomoe_dict_ptr_array_sort (TomoeDictPtrArray *dict);
++GPtrArray *tomoe_dict_ptr_array_get_array (TomoeDictPtrArray *dict);
+
+ G_END_DECLS
+
+Index: trunk/lib/Makefile.am
+===================================================================
+--- trunk/lib/Makefile.am (revision 1581)
++++ trunk/lib/Makefile.am (revision 1582)
+@@ -30,13 +30,15 @@
+ tomoe-context.h \
+ tomoe-config.h \
+ tomoe-dict.h \
++ tomoe-dict-ptr-array.h \
+ tomoe-module.h \
+ tomoe-module-impl.h \
+ tomoe-query.h \
+ tomoe-reading.h \
+ tomoe-recognizer.h \
+ tomoe-shelf.h \
+- tomoe-writing.h
++ tomoe-writing.h \
++ tomoe-xml-parser.h
+
+ enum_source_prefix = tomoe-enum-types
+
+@@ -103,15 +105,13 @@
+ tomoe-config.c \
+ tomoe-dict.c \
+ tomoe-dict-ptr-array.c \
+- tomoe-dict-ptr-array.h \
+ tomoe-module.c \
+ tomoe-query.c \
+ tomoe-reading.c \
+ tomoe-recognizer.c \
+ tomoe-shelf.c \
+ tomoe-writing.c \
+- tomoe-xml-parser.c \
+- tomoe-xml-parser.h
++ tomoe-xml-parser.c
+
+ libtomoe_la_LDFLAGS = \
+ -version-info $(LT_VERSION_INFO) \
diff --git a/app-i18n/tomoe/files/tomoe-0.6.0-ldflags.patch b/app-i18n/tomoe/files/tomoe-0.6.0-ldflags.patch
new file mode 100644
index 000000000000..97ddc88f6ad3
--- /dev/null
+++ b/app-i18n/tomoe/files/tomoe-0.6.0-ldflags.patch
@@ -0,0 +1,24 @@
+diff -Naur tomoe-0.6.0.orig/module/dict/Makefile.am tomoe-0.6.0/module/dict/Makefile.am
+--- tomoe-0.6.0.orig/module/dict/Makefile.am 2007-06-18 10:35:40.000000000 +0900
++++ tomoe-0.6.0/module/dict/Makefile.am 2011-05-26 08:47:24.279701286 +0900
+@@ -34,7 +34,7 @@
+
+ LIBADD = $(TOMOE_LIBS) \
+ $(top_builddir)/lib/libtomoe.la
+-LDFLAGS = \
++LDFLAGS += \
+ -rpath $(dict_moduledir) -avoid-version -module \
+ -export-dynamic $(no_undefined) $(LIBTOOL_EXPORT_OPTIONS)
+
+diff -Naur tomoe-0.6.0.orig/module/recognizer/Makefile.am tomoe-0.6.0/module/recognizer/Makefile.am
+--- tomoe-0.6.0.orig/module/recognizer/Makefile.am 2007-04-10 16:24:20.000000000 +0900
++++ tomoe-0.6.0/module/recognizer/Makefile.am 2011-05-26 08:47:36.502740712 +0900
+@@ -23,7 +23,7 @@
+ AM_CPPFLAGS =
+ INCLUDES = $(TOMOE_CFLAGS)
+
+-LDFLAGS = \
++LDFLAGS += \
+ -rpath $(recognizer_moduledir) -avoid-version -module \
+ -export-dynamic $(no_undefined) $(LIBTOOL_EXPORT_OPTIONS)
+
diff --git a/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild b/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..c0b08004cd6d
--- /dev/null
+++ b/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild,v 1.1 2011/05/26 22:44:21 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+inherit autotools eutils multilib python
+
+DESCRIPTION="Japanese handwriting recognition engine"
+HOMEPAGE="http://tomoe.sourceforge.jp/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc hyperestraier mysql ruby python static-libs subversion"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ruby? ( dev-ruby/ruby-glib2 )
+ hyperestraier? ( app-text/hyperestraier )
+ subversion? (
+ >=dev-libs/apr-1
+ dev-vcs/subversion
+ )
+ mysql? ( dev-db/mysql )
+ python? (
+ dev-python/pygobject:2
+ dev-python/pygtk:2
+ )"
+# test? ( app-dicts/uconv )
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-export-symbols.patch" \
+ "${FILESDIR}/${P}-ldflags.patch"
+
+ if ! use hyperestraier ; then
+ sed -i -e "s/use_est=yes/use_est=no/" configure.ac || die
+ fi
+ if ! use mysql ; then
+ sed -i -e "s/use_mysql=yes/use_mysql=no/" configure.ac || die
+ fi
+ if ! use subversion ; then
+ sed -i -e "s/use_svn=yes/use_svn=no/" macros/svn.m4 || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # --with-python b0rked
+ use python || myconf="${myconf} --without-python"
+
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_with ruby) \
+ $(use_enable static-libs static) \
+ $(use_enable ruby dict-ruby) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ find "${ED}/usr/$(get_libdir)/tomoe" \( -name '*.la' -o -name '*.a' \) -type f -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -type f -delete || die
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS TODO || die
+}