summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-04-19 06:28:24 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-04-19 06:28:24 +0000
commitd2a70a15b695631ceca07733dd56919e8ebb5e04 (patch)
tree9c25cfe8959bb4e1e4dabfd8924cc7163cee4835 /app-i18n/scim
parentRemove old (diff)
downloadgentoo-2-d2a70a15b695631ceca07733dd56919e8ebb5e04.tar.gz
gentoo-2-d2a70a15b695631ceca07733dd56919e8ebb5e04.tar.bz2
gentoo-2-d2a70a15b695631ceca07733dd56919e8ebb5e04.zip
Version bumped.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/scim')
-rw-r--r--app-i18n/scim/ChangeLog7
-rw-r--r--app-i18n/scim/scim-1.4.9.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/app-i18n/scim/ChangeLog b/app-i18n/scim/ChangeLog
index 5e685cba7969..aadcd4b2fd92 100644
--- a/app-i18n/scim/ChangeLog
+++ b/app-i18n/scim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.130 2009/03/15 13:37:13 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.131 2009/04/19 06:28:24 matsuu Exp $
+
+*scim-1.4.9 (19 Apr 2009)
+
+ 19 Apr 2009; MATSUU Takuto <matsuu@gentoo.org> +scim-1.4.9.ebuild:
+ Version bumped.
15 Mar 2009; Brent Baude <ranger@gentoo.org> scim-1.4.7-r2.ebuild:
Marking scim-1.4.7-r2 ppc64 for bug 246064
diff --git a/app-i18n/scim/scim-1.4.9.ebuild b/app-i18n/scim/scim-1.4.9.ebuild
new file mode 100644
index 000000000000..5d35ef808ea9
--- /dev/null
+++ b/app-i18n/scim/scim-1.4.9.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-1.4.9.ebuild,v 1.1 2009/04/19 06:28:24 matsuu Exp $
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="x11-libs/libX11
+ >=x11-libs/gtk+-2
+ >=dev-libs/atk-1
+ >=x11-libs/pango-1
+ >=dev-libs/glib-2
+ !app-i18n/scim-cvs"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ doc? ( app-doc/doxygen
+ >=app-text/docbook-xsl-stylesheets-1.73.1 )
+ dev-lang/perl
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.33
+ sys-devel/libtool"
+
+get_gtk_confdir() {
+ if use amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && use x86 ) ; then
+ echo "/etc/gtk-2.0/${CHOST}"
+ else
+ echo "/etc/gtk-2.0"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.4.7-syslibltdl.patch"
+ rm "${S}"/src/ltdl.{cpp,h}
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+ # bug #83625
+ filter-flags -fvisibility-inlines-hidden
+ filter-flags -fvisibility=hidden
+
+ # bug #191696
+ ## We cannot use "use_enable"
+ #if ! use gtk ; then
+ # myconf="${myconf} --disable-panel-gtk"
+ # myconf="${myconf} --disable-setup-ui"
+ # myconf="${myconf} --disable-gtk2-immodule"
+ #fi
+
+ econf \
+ $(use_with doc doxygen) \
+ --enable-ld-version-script \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README AUTHORS ChangeLog docs/developers docs/scim.cfg
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=\"scim\""
+ elog "export QT_IM_MODULE=\"scim\""
+ elog
+ elog "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
+ elog "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
+ elog
+ elog "If you prefer KDE/Qt interface, try emerge app-i18n/skim."
+ elog
+ elog "To use Chinese input methods:"
+ elog " # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
+ elog "To use Korean input methods:"
+ elog " # emerge app-i18n/scim-hangul"
+ elog "To use Japanese input methods:"
+ elog " # emerge app-i18n/scim-anthy"
+ elog "To use various input methods (more than 30 languages):"
+ elog " # emerge app-i18n/scim-m17n"
+ elog
+ ewarn
+ ewarn "If you upgraded from scim-1.2.x or scim-1.0.x, you should remerge all SCIM modules."
+ ewarn
+ epause 10
+
+ [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > "${ROOT}$(get_gtk_confdir)/gtk.immodules"
+}
+
+pkg_postrm() {
+
+ [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > "${ROOT}$(get_gtk_confdir)/gtk.immodules"
+}