summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-10-10 16:31:29 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-10-10 16:31:29 +0000
commit23dcae518c988abbe28c2903a82e847c9a140fd7 (patch)
tree2a6043842730d21df3b25b9bdea232275373609f /app-i18n/scim
parentMarked stable on amd64 for bug #150746 (diff)
downloadgentoo-2-23dcae518c988abbe28c2903a82e847c9a140fd7.tar.gz
gentoo-2-23dcae518c988abbe28c2903a82e847c9a140fd7.tar.bz2
gentoo-2-23dcae518c988abbe28c2903a82e847c9a140fd7.zip
Fixed kanji input issue, bug 142056.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-i18n/scim')
-rw-r--r--app-i18n/scim/ChangeLog6
-rw-r--r--app-i18n/scim/files/scim-1.4.5-imengine.patch21
-rw-r--r--app-i18n/scim/scim-1.4.5.ebuild13
3 files changed, 36 insertions, 4 deletions
diff --git a/app-i18n/scim/ChangeLog b/app-i18n/scim/ChangeLog
index 42fbf500b292..9c8b11be27ed 100644
--- a/app-i18n/scim/ChangeLog
+++ b/app-i18n/scim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/scim
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.100 2006/10/10 10:54:37 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.101 2006/10/10 16:31:29 matsuu Exp $
+
+ 10 Oct 2006; MATSUU Takuto <matsuu@gentoo.org>
+ +files/scim-1.4.5-imengine.patch, scim-1.4.5.ebuild:
+ Fixed kanji input issue, bug 142056.
10 Oct 2006; MATSUU Takuto <matsuu@gentoo.org> scim-1.4.4.ebuild,
scim-1.4.5.ebuild:
diff --git a/app-i18n/scim/files/scim-1.4.5-imengine.patch b/app-i18n/scim/files/scim-1.4.5-imengine.patch
new file mode 100644
index 000000000000..e850f0aac741
--- /dev/null
+++ b/app-i18n/scim/files/scim-1.4.5-imengine.patch
@@ -0,0 +1,21 @@
+diff -urN scim-1.4.4/modules/IMEngine/scim_rawcode_imengine.cpp scim-1.4.3/modules/IMEngine/scim_rawcode_imengine.cpp
+--- scim-1.4.4/modules/IMEngine/scim_rawcode_imengine.cpp 2006-01-12 08:00:36.000000000 +0100
++++ scim-1.4.3/modules/IMEngine/scim_rawcode_imengine.cpp 2005-08-15 16:27:56.000000000 +0200
+@@ -53,6 +53,8 @@
+ static String __rawcode_locales ("zh_CN.GB18030,zh_CN.GBK,zh_CN.GB2312,zh_TW,zh_TW.EUC-TW,zh_HK,ja_JP,ja_JP.sjis,ko_KR,en_US.UTF-8");
+
+ static std::vector<String> __rawcode_encodings;
++static const char * _DEFAULT_LANGUAGES = N_(
++ "zh_CN,zh_TW,zh_HK,zh_SG,ja_JP,ko_KR");
+
+ extern "C" {
+ void scim_module_init (void)
+@@ -99,7 +82,7 @@
+ // implementation of RawCode
+ RawCodeFactory::RawCodeFactory ()
+ {
+- set_locales (__rawcode_locales);
++ set_languages (String (_(_DEFAULT_LANGUAGES)));
+ }
+
+ RawCodeFactory::~RawCodeFactory ()
diff --git a/app-i18n/scim/scim-1.4.5.ebuild b/app-i18n/scim/scim-1.4.5.ebuild
index add24a2f63eb..6c9b2c529545 100644
--- a/app-i18n/scim/scim-1.4.5.ebuild
+++ b/app-i18n/scim/scim-1.4.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-1.4.5.ebuild,v 1.2 2006/10/10 10:54:37 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-1.4.5.ebuild,v 1.3 2006/10/10 16:31:29 matsuu Exp $
-inherit flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
HOMEPAGE="http://www.scim-im.org/"
@@ -29,13 +29,20 @@ PDEPEND="!alpha? ( !hppa? ( kde? ( app-i18n/skim ) ) )
!alpha? ( !hppa? ( !ppc64? ( !sparc? ( qt3? ( || ( app-i18n/scim-qtimm app-i18n/scim-bridge ) ) ) ) ) )"
get_gtk_confdir() {
- if useq amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && useq x86 ) ; then
+ if use amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && use x86 ) ; then
echo "/etc/gtk-2.0/${CHOST}"
else
echo "/etc/gtk-2.0"
fi
}
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-imengine.patch
+}
+
src_compile() {
# bug #83625
filter-flags -fvisibility-inlines-hidden