summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-06-14 13:46:46 +0000
committerNaohiro Aota <naota@gentoo.org>2011-06-14 13:46:46 +0000
commitcddbd45f8a16ced21d45aa3e70eb43dbe7a8a371 (patch)
treee37e0e2a95b940769310b9abec4a92fee4428711 /app-i18n/scim-tables
parent Disable nonnull warning for newsnntp.c. QA (diff)
downloadgentoo-2-cddbd45f8a16ced21d45aa3e70eb43dbe7a8a371.tar.gz
gentoo-2-cddbd45f8a16ced21d45aa3e70eb43dbe7a8a371.tar.bz2
gentoo-2-cddbd45f8a16ced21d45aa3e70eb43dbe7a8a371.zip
version bumped
(Portage version: 2.2.0_alpha40/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/scim-tables')
-rw-r--r--app-i18n/scim-tables/ChangeLog7
-rw-r--r--app-i18n/scim-tables/scim-tables-0.5.10.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-i18n/scim-tables/ChangeLog b/app-i18n/scim-tables/ChangeLog
index e9f90dc660ee..4f31fb0842b2 100644
--- a/app-i18n/scim-tables/ChangeLog
+++ b/app-i18n/scim-tables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-tables
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/ChangeLog,v 1.65 2011/02/13 19:17:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/ChangeLog,v 1.66 2011/06/14 13:46:46 naota Exp $
+
+*scim-tables-0.5.10 (14 Jun 2011)
+
+ 14 Jun 2011; Naohiro Aota <naota@gentoo.org> +scim-tables-0.5.10.ebuild:
+ version bumped
13 Feb 2011; Raúl Porcel <armin76@gentoo.org> scim-tables-0.5.8-r1.ebuild:
Drop alpha/sparc keywords
diff --git a/app-i18n/scim-tables/scim-tables-0.5.10.ebuild b/app-i18n/scim-tables/scim-tables-0.5.10.ebuild
new file mode 100644
index 000000000000..50b764236a4b
--- /dev/null
+++ b/app-i18n/scim-tables/scim-tables-0.5.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/scim-tables-0.5.10.ebuild,v 1.1 2011/06/14 13:46:46 naota Exp $
+
+inherit autotools base eutils
+
+DESCRIPTION="Smart Common Input Method (SCIM) Generic Table Input Method Server"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+LANGS="am ar bn gu hi ja kn ko ml ne pa ru ta te th uk vi zh"
+for i in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${i}"
+done
+
+RDEPEND=">=app-i18n/scim-1.4.7-r2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.8+gcc-4.3.patch" )
+
+pkg_setup() {
+ elog "Not all languages are going to be compiled."
+ elog "Please set LINGUAS to your preferred language(s)."
+ elog "Supported LINGUAS values are:"
+ elog "${LANGS}"
+}
+
+src_unpack() {
+ base_src_unpack
+
+ strip-linguas ${LANGS}
+ local use_languages="additional ${LINGUAS}"
+ elog "Languages being compiled are: ${use_languages}"
+
+ cd "${S}"
+ sed -i -e "/^SUBDIRS/s/.*/SUBDIRS = ${use_languages}/g" \
+ tables/Makefile.{am,in} || die "sed ${m} failed"
+
+ AT_NO_RECURSIVE=yes AT_M4DIR=${S}/m4 eautoreconf
+}
+
+src_compile() {
+ econf \
+ --disable-skim-support \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking \
+ --without-arts || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README ChangeLog AUTHORS
+}