summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2006-07-27 17:02:39 +0000
committerMamoru Komachi <usata@gentoo.org>2006-07-27 17:02:39 +0000
commitc1c8ca92c6aa6bc189f85408cde7406cfb7daa59 (patch)
treec833aa7d432a0ded2ee06181aa72748e0bde7959 /app-i18n/scim-tables
parentAdded locales needed for app-i18n/scim-tables (diff)
downloadgentoo-2-c1c8ca92c6aa6bc189f85408cde7406cfb7daa59.tar.gz
gentoo-2-c1c8ca92c6aa6bc189f85408cde7406cfb7daa59.tar.bz2
gentoo-2-c1c8ca92c6aa6bc189f85408cde7406cfb7daa59.zip
Added LINGUAS support.
(Portage version: 2.1-r1)
Diffstat (limited to 'app-i18n/scim-tables')
-rw-r--r--app-i18n/scim-tables/ChangeLog9
-rw-r--r--app-i18n/scim-tables/files/digest-scim-tables-0.5.6-r16
-rw-r--r--app-i18n/scim-tables/scim-tables-0.5.6-r1.ebuild70
3 files changed, 84 insertions, 1 deletions
diff --git a/app-i18n/scim-tables/ChangeLog b/app-i18n/scim-tables/ChangeLog
index eba0e02457f4..ed201627d7e8 100644
--- a/app-i18n/scim-tables/ChangeLog
+++ b/app-i18n/scim-tables/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/scim-tables
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/ChangeLog,v 1.39 2006/07/03 19:37:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/ChangeLog,v 1.40 2006/07/27 17:02:39 usata Exp $
+
+*scim-tables-0.5.6-r1 (27 Jul 2006)
+
+ 27 Jul 2006; Mamoru KOMACHI <usata@gentoo.org>
+ +scim-tables-0.5.6-r1.ebuild:
+ Added LINGUAS support. (It dramatically reduces startup time to disable
+ languages you do not use at all)
03 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
scim-tables-0.5.6.ebuild:
diff --git a/app-i18n/scim-tables/files/digest-scim-tables-0.5.6-r1 b/app-i18n/scim-tables/files/digest-scim-tables-0.5.6-r1
new file mode 100644
index 000000000000..135643ee8e14
--- /dev/null
+++ b/app-i18n/scim-tables/files/digest-scim-tables-0.5.6-r1
@@ -0,0 +1,6 @@
+MD5 122f8bcc6b7eb5805df46461ed48bf2c kde-admindir-3.5.3.tar.bz2 187248
+RMD160 81eedc1b81f2cee6709b7c8ad08859024da090f6 kde-admindir-3.5.3.tar.bz2 187248
+SHA256 0cd8bf32dad0affa56edf5723747275be2b1e0702abefc28ded8763ad58fe07b kde-admindir-3.5.3.tar.bz2 187248
+MD5 ff8d59e8f3dedb7dd7c6d87c8fc408db scim-tables-0.5.6.tar.gz 7058913
+RMD160 768b298cd9359742eedf1297f73a5be6eee3361e scim-tables-0.5.6.tar.gz 7058913
+SHA256 408cddeed4f5f9105f61822388fcd8947b1f2ba2d66bdabfa2be4e4f1d9393d0 scim-tables-0.5.6.tar.gz 7058913
diff --git a/app-i18n/scim-tables/scim-tables-0.5.6-r1.ebuild b/app-i18n/scim-tables/scim-tables-0.5.6-r1.ebuild
new file mode 100644
index 000000000000..c3bf77186f6e
--- /dev/null
+++ b/app-i18n/scim-tables/scim-tables-0.5.6-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/scim-tables-0.5.6-r1.ebuild,v 1.1 2006/07/27 17:02:39 usata Exp $
+
+inherit kde-functions autotools eutils
+
+DESCRIPTION="Smart Common Input Method (SCIM) Generic Table Input Method Server"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz
+ mirror://gentoo/kde-admindir-3.5.3.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="kde nls"
+LANGS="am ar bn gu hi ja kn ko ml ne pa ru ta te th vi zh"
+for i in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${i}"
+done
+
+RDEPEND="|| ( x11-libs/libXt virtual/x11 )
+ || ( >=app-i18n/scim-1.1 >=app-i18n/scim-cvs-1.1 )
+ !alpha? ( !sparc? ( kde? ( app-i18n/skim ) ) )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ einfo "Not all languages are going to be compiled."
+ einfo "Please set LINGUAS to your preferred language(s)."
+ einfo "Supported LINGUAS values are:"
+ einfo "${LANGS}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fixconfigure.patch"
+ epatch "${FILESDIR}/${PN}-qt335.patch"
+
+ AT_NO_RECURSIVE=yes eautoreconf
+}
+
+src_compile() {
+ strip-linguas ${LANGS}
+ local use_languages="additional ${LINGUAS}"
+ einfo "Languages being compiled are: ${use_languages}"
+
+ for m in Makefile.in Makefile.am ; do
+ sed -e "/^SUBDIRS/s/.*/SUBDIRS = ${use_languages}/g" \
+ tables/${m} > ${T}/${m} || die "sed ${m} failed"
+ cp ${T}/${m} tables/${m} || die "mv ${m} failed"
+ done
+
+ econf \
+ $(use_enable kde skim-support) \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking \
+ --without-arts || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README ChangeLog AUTHORS
+}