summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-01-22 11:06:27 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-01-22 11:06:27 +0000
commitfaed712d9c4fd9706f56bf9d2e446c4994dd7c26 (patch)
treea35045248d356d6cf12938597f2e6cbd771e0642 /app-i18n/prime
parentAdded LatticeMico32 (lm32) softmmu target. Added USE="nss rbd spice threads +... (diff)
downloadgentoo-2-faed712d9c4fd9706f56bf9d2e446c4994dd7c26.tar.gz
gentoo-2-faed712d9c4fd9706f56bf9d2e446c4994dd7c26.tar.bz2
gentoo-2-faed712d9c4fd9706f56bf9d2e446c4994dd7c26.zip
Convert to ruby-ng. Fixed parallel make issue.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/prime')
-rw-r--r--app-i18n/prime/ChangeLog10
-rw-r--r--app-i18n/prime/files/prime-1.0.0.1-libdir.patch14
-rw-r--r--app-i18n/prime/files/prime-1.0.0.1-parallel.patch12
-rw-r--r--app-i18n/prime/prime-1.0.0.1-r1.ebuild52
4 files changed, 86 insertions, 2 deletions
diff --git a/app-i18n/prime/ChangeLog b/app-i18n/prime/ChangeLog
index 4f95d8ca881e..d3a8ecce46db 100644
--- a/app-i18n/prime/ChangeLog
+++ b/app-i18n/prime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/prime
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/prime/ChangeLog,v 1.64 2010/01/23 10:18:30 matsuu Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/prime/ChangeLog,v 1.65 2012/01/22 11:06:26 matsuu Exp $
+
+*prime-1.0.0.1-r1 (22 Jan 2012)
+
+ 22 Jan 2012; MATSUU Takuto <matsuu@gentoo.org> +prime-1.0.0.1-r1.ebuild,
+ +files/prime-1.0.0.1-libdir.patch, +files/prime-1.0.0.1-parallel.patch:
+ Convert to ruby-ng. Fixed parallel make issue.
23 Jan 2010; MATSUU Takuto <matsuu@gentoo.org> prime-1.0.0.1.ebuild:
Fixed erubydoc issue, bug #299427.
diff --git a/app-i18n/prime/files/prime-1.0.0.1-libdir.patch b/app-i18n/prime/files/prime-1.0.0.1-libdir.patch
new file mode 100644
index 000000000000..efa521969237
--- /dev/null
+++ b/app-i18n/prime/files/prime-1.0.0.1-libdir.patch
@@ -0,0 +1,14 @@
+--- prime-1.0.0.1.orig/src/prime.src 2005-03-07 16:51:34.000000000 +0900
++++ prime-1.0.0.1/src/prime.src 2010-05-27 18:44:37.000000000 +0900
+@@ -12,8 +12,10 @@
+ # the GNU General Public License version 2.
+ #
+
++require 'rbconfig'
++
+ PRIME_BINDIR = '%bindir%'
+-PRIME_LIBDIR = '%rubydir%'
++PRIME_LIBDIR = Config::CONFIG["sitelibdir"]
+ $LOAD_PATH.unshift(PRIME_LIBDIR) unless $LOAD_PATH.member?(PRIME_LIBDIR)
+
+ require 'getoptlong'
diff --git a/app-i18n/prime/files/prime-1.0.0.1-parallel.patch b/app-i18n/prime/files/prime-1.0.0.1-parallel.patch
new file mode 100644
index 000000000000..46d87fb94649
--- /dev/null
+++ b/app-i18n/prime/files/prime-1.0.0.1-parallel.patch
@@ -0,0 +1,12 @@
+diff -Naur prime-1.0.0.1.orig//src/Makefile.am prime-1.0.0.1//src/Makefile.am
+--- prime-1.0.0.1.orig//src/Makefile.am 2004-03-26 02:19:51.000000000 +0900
++++ prime-1.0.0.1//src/Makefile.am 2010-05-27 18:29:20.000000000 +0900
+@@ -23,7 +23,7 @@
+
+ ## FIXME: Consider other commands.
+ ## FIXME: (2004-02-05) <komatsu@taiyaki.org>
+-@PRIME_COMMAND@: $(script_sources) Makefile
++$(primelib_SCRIPTS): $(script_sources) Makefile
+ ruby -e " \
+ command_suffixes = ['', \
+ '-userdict-update', '-userdict-convert', \
diff --git a/app-i18n/prime/prime-1.0.0.1-r1.ebuild b/app-i18n/prime/prime-1.0.0.1-r1.ebuild
new file mode 100644
index 000000000000..f3fee1eecb6b
--- /dev/null
+++ b/app-i18n/prime/prime-1.0.0.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/prime/prime-1.0.0.1-r1.ebuild,v 1.1 2012/01/22 11:06:26 matsuu Exp $
+
+EAPI="3"
+# don't work with ruby19
+# jruby: sary-ruby issue
+# rbx: sary-ruby issue
+USE_RUBY="ruby18 ree18"
+inherit autotools eutils ruby-ng
+
+DESCRIPTION="Japanese PRedictive Input Method Editor"
+HOMEPAGE="http://taiyaki.org/prime/"
+SRC_URI="http://prime.sourceforge.jp/src/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=app-dicts/prime-dict-1.0.0
+ >=dev-libs/suikyo-2.1.0
+ dev-ruby/ruby-progressbar
+ dev-ruby/sary-ruby"
+
+S="${WORKDIR}/${P/_/-}"
+
+all_ruby_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-parallel.patch" \
+ "${FILESDIR}/${P}-libdir.patch"
+ eautoreconf
+}
+
+each_ruby_configure() {
+ econf \
+ --with-prime-docdir=/usr/share/doc/${PF}/html \
+ --with-rubydir=$(ruby_rbconfig_value 'sitelibdir') || die
+}
+
+each_ruby_compile() {
+ emake || die
+}
+
+each_ruby_install() {
+ emake DESTDIR="${D}" install install-etc || die
+}
+
+all_ruby_install() {
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+ dohtml -r doc/* || die
+}