summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2014-08-28 08:15:40 +0000
committerNaohiro Aota <naota@gentoo.org>2014-08-28 08:15:40 +0000
commitfa9bb2a2ed75d5957f5fc771b9452f7024397e81 (patch)
treedcc4d9cc98399f95711c52e5dea4f1309c627cc5 /app-i18n/nkf
parentAutomagic kerberos library fix for squid-3.3.13 as well (diff)
downloadgentoo-2-fa9bb2a2ed75d5957f5fc771b9452f7024397e81.tar.gz
gentoo-2-fa9bb2a2ed75d5957f5fc771b9452f7024397e81.tar.bz2
gentoo-2-fa9bb2a2ed75d5957f5fc771b9452f7024397e81.zip
Fix broken Japanese man page, patch by Takurou Kitagawa. #519466
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/ChangeLog7
-rw-r--r--app-i18n/nkf/nkf-2.1.3-r1.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index cd1205a0b41c..465eea69aee6 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/nkf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.61 2014/08/09 08:30:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.62 2014/08/28 08:15:40 naota Exp $
+
+*nkf-2.1.3-r1 (28 Aug 2014)
+
+ 28 Aug 2014; Naohiro Aota <naota@gentoo.org> +nkf-2.1.3-r1.ebuild:
+ Fix broken Japanese man page, patch by Takurou Kitagawa. #519466
09 Aug 2014; Jeroen Roovers <jer@gentoo.org> nkf-2.1.3.ebuild:
Make USE=python mv/patch conditional again (bug #519464 by Takurou Kitagawa).
diff --git a/app-i18n/nkf/nkf-2.1.3-r1.ebuild b/app-i18n/nkf/nkf-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..3df434016508
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.1.3-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.1.3-r1.ebuild,v 1.1 2014/08/28 08:15:40 naota Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils distutils-r1 perl-module toolchain-funcs
+
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="mirror://sourceforge.jp/nkf/59912/${P}.tar.gz
+ linguas_ja? ( http://dev.gentoo.org/~naota/files/nkf.1j )
+ python? ( http://dev.gentoo.org/~naota/files/NKF_python20090602.tgz )"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-macos"
+IUSE="perl python linguas_ja"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/{s|-g -O2||;s|=|+=|;}' \
+ -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ Makefile || die
+
+ if use linguas_ja; then
+ cp "${DISTDIR}"/nkf.1j "${S}" || die
+ fi
+
+ if use python; then
+ mv "${WORKDIR}/NKF.python" "${S}" || die
+ epatch "${FILESDIR}"/${P}-strip.patch
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" nkf || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_compile
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ emake test || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+
+ if use linguas_ja; then
+ ./nkf -e nkf.1j > nkf.1
+ doman -i18n=ja nkf.1
+ fi
+ dodoc nkf.doc
+
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_install
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils-r1_src_install
+ fi
+}